Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Update RPM Errors

Discussion in 'General Discussion' started by SJR, Dec 3, 2018.

  1. SJR

    SJR Member

    Joined:
    Jan 2, 2017
    Messages:
    24
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    USA
    cPanel Access Level:
    Website Owner
    Just started getting this error when running WHM > Software > System Update:

    System update process has started.

    “yum” reported error code “1” when it ended: w/ yum -y
    Often errors like this can be resolved by running `yum makecache`

    System update process has finished.

    I tried reboot, and 'yum makecache' and still shows error.

    Any thoughts?

    Centos 7.5; v76.0.11
     
  2. SJR

    SJR Member

    Joined:
    Jan 2, 2017
    Messages:
    24
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    USA
    cPanel Access Level:
    Website Owner
    I 'think' this problem was introduce when I did the upgrade from v76.0.10 to v76.0.11.
    I usually run System Update each time there is a new cPanel upgrade and I have never seen this error before.
    Now I can see in the cPanel upgrade script this error:

    Code:
    [2018-12-04 04:36:30 -0700]      [/usr/local/cpanel/scripts/rpmup] ---> Package
    libXtst.x86_64 0:1.2.3-1.el7 will be installed
    [2018-12-04 04:36:30 -0700]      [/usr/local/cpanel/scripts/rpmup] --> Finished
    Dependency Resolution
    [2018-12-04 04:36:30 -0700]      [/usr/local/cpanel/scripts/rpmup] Error: Package:
    git-instaweb-1.8.3.1-20.el7.noarch (updates)
    [2018-12-04 04:36:30 -0700]      [/usr/local/cpanel/scripts/rpmup] Error: Package:
    git-instaweb-1.8.3.1-20.el7.noarch (updates)
    [2018-12-04 04:36:30 -0700]      [/usr/local/cpanel/scripts/rpmup]  You could try
    using --skip-broken to work around the problem
    [2018-12-04 04:36:30 -0700]      [/usr/local/cpanel/scripts/rpmup]  You could try
    running: rpm -Va --nofiles --nodigest
    [2018-12-04 04:36:30 -0700]      [/usr/local/cpanel/scripts/rpmup] (XID m22vvz) The
    system failed to execute yum with the arguments “--assumeyes --config /etc/yum.conf
    update” because of an error: The “/usr/bin/yum --assumeyes --config /etc/yum.conf
    update” command (process 31273) reported error number 1 when it ended. : Error:
    Package: git-instaweb-1.8.3.1-20.el7.noarch (updates)
    [2018-12-04 04:36:30 -0700]      [/usr/local/cpanel/scripts/rpmup]         
    Requires: httpd
    [2018-12-04 04:36:30 -0700]      [/usr/local/cpanel/scripts/rpmup] Error: Package:
    git-instaweb-1.8.3.1-20.el7.noarch (updates)
    [2018-12-04 04:36:30 -0700]      [/usr/local/cpanel/scripts/rpmup]         
    Requires: mod_ssl
    [2018-12-04 04:36:30 -0700]      [/usr/local/cpanel/scripts/rpmup] checkyum version
    22.3
    [2018-12-04 04:36:30 -0700]    - Finished command `/usr/local/cpanel/scripts/rpmup`
    in 18.613 seconds
    [2018-12-04 04:36:30 -0700]   25% complete
     
    #2 SJR, Dec 4, 2018
    Last edited by a moderator: Dec 5, 2018
  3. cPanelLauren

    cPanelLauren Forums Analyst II Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    6,161
    Likes Received:
    474
    Trophy Points:
    233
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    Hi @SJR


    That package that it's experiencing the issue with seems to be causing a conflict. It looks like possibly some of the error is missing but when searching for the package I'm not finding it.

    Code:
    yum search git-instaweb
    Loaded plugins: fastestmirror, universal-hooks
    Loading mirror speeds from cached hostfile
     * EA4: 67.222.0.10
     * EA4-experimental: 67.222.0.10
     * cpanel-addons-production-feed: 67.222.0.10
     * base: repo1.dal.innoscale.net
     * epel: fedora-epel.mirror.lstn.net
     * extras: ftpmirror.your.org
     * updates: repo1.dal.innoscale.net
    No matches found
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. Brittany C

    Brittany C Member

    Joined:
    Oct 17, 2018
    Messages:
    5
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    Madison, WI
    cPanel Access Level:
    Root Administrator
    I'm having a similar issue with this package on cPanel version 76.0.14 and CloudLinux 7.5
    I've verified mod_ssl is enabled:


    Code:
    (XID gqnbun) The system failed to execute yum with the arguments “--assumeyes --config /etc/yum.conf update --disablerepo=epel” because of an error: The “/usr/bin/yum --assumeyes --config /etc/yum.conf update --disablerepo=epel” command (process 12531) reported error number 1 when it ended. : Error: Package: git-instaweb-1.8.3.1-20.el7.noarch (cloudlinux-x86_64-server-7)
               Requires: mod_ssl
    Error: Package: git-instaweb-1.8.3.1-20.el7.noarch (cloudlinux-x86_64-server-7)
               Requires: httpd
     
  5. cPanelLauren

    cPanelLauren Forums Analyst II Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    6,161
    Likes Received:
    474
    Trophy Points:
    233
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    Hi @Brittany C


    Can you show me the output of the following:

    Code:
    ls -lah /etc/yum.repos.d
    The issue you're having with this repo is the same as what the OP was having.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. Brittany C

    Brittany C Member

    Joined:
    Oct 17, 2018
    Messages:
    5
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    Madison, WI
    cPanel Access Level:
    Root Administrator
    Code:
    ls -lah /etc/yum.repos.d
    total 76K
    drwxr-xr-x.   2 root root 4.0K Dec 13 21:50 .
    drwxr-xr-x. 105 root root  12K Dec 17 12:14 ..
    -rw-r--r--    1 root root  329 May  7  2018 centos-extras.repo
    -rw-r--r--    1 root root  752 Aug 16  2017 cloudlinux-ea4-experimental.repo
    -rw-r--r--    1 root root  657 Aug 16  2017 cloudlinux-ea4.repo
    -rw-r--r--    1 root root  731 Aug 16  2017 cloudlinux-ea4-testing.repo
    -rw-r--r--    1 root root  232 May  7  2018 cloudlinux-imunify360.repo
    -rw-r--r--    1 root root 2.9K May  7  2018 cloudlinux.repo
    -rw-r--r--    1 root root  244 Dec 13 21:50 cPAddons.repo
    -rw-------    1 root root  239 Nov  5 21:51 cpanel-plugins.repo
    -rw-r--r--    1 root root  204 May 30  2017 EA4.repo
    -rw-r--r--    1 root root  951 Oct  2  2017 epel.repo
    -rw-r--r--    1 root root 1.1K Oct  2  2017 epel-testing.repo
    -rw-r--r--    1 root root  119 Nov 22 11:41 kernelcare.repo
    -rw-r--r--    1 root root  267 May 30  2017 MariaDB100.repo
    -rw-r--r--    1 root root  257 May 30  2017 MariaDB101.repo
     
  7. cPanelLauren

    cPanelLauren Forums Analyst II Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    6,161
    Likes Received:
    474
    Trophy Points:
    233
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    Can you please open a ticket using the link in my signature? Once open please reply with the Ticket ID here so that we can update this thread with the resolution once the ticket is resolved.


    Thanks!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. Brittany C

    Brittany C Member

    Joined:
    Oct 17, 2018
    Messages:
    5
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    Madison, WI
    cPanel Access Level:
    Root Administrator
    Ticket # 10988413
     
  9. cPanelLauren

    cPanelLauren Forums Analyst II Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    6,161
    Likes Received:
    474
    Trophy Points:
    233
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    Hi @Brittany C


    Thanks, I'm watching that ticket and I'll update here when the issue has been resolved.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  10. aztopdavid

    aztopdavid Member

    Joined:
    Jan 1, 2016
    Messages:
    9
    Likes Received:
    4
    Trophy Points:
    3
    Location:
    Arizona
    cPanel Access Level:
    Root Administrator
    I think I'm having the same problem. My VPS (running v80.0.4 on CENTOS 7.5) has been sending me "Panel & WHM update failure" notifications for two days, with this:

    I ran "Upgrade to latest version" in WHM and it produced this error:

    Code:
    [/usr/local/cpanel/scripts/rpmup] (XID jgt4bp) The system failed to execute yum with the arguments “--assumeyes --config /etc/yum.conf update” because of an error: The “/usr/bin/yum --assumeyes --config /etc/yum.conf update” command (process 20124) reported error number 1 when it ended. : Error: Package: git-instaweb-1.8.3.1-20.el7.noarch (updates)
    I just ran "ls -lah /etc/yum.repos.d" and here's the output:

    Code:
    ls -lah /etc/yum.repos.d
    total 72K
    drwxr-xr-x  2 root root 4.0K May 15 01:31 .
    drwxr-xr-x 97 root root 8.0K May 15 07:30 ..
    -rw-r--r--  1 root root 1.7K Oct 30  2018 CentOS-Base.repo
    -rw-r--r--  1 root root 1.7K Apr 29  2016 CentOS-Base.repo.bak
    -rw-r--r--  1 root root 1.3K Oct 30  2018 CentOS-CR.repo
    -rw-r--r--  1 root root 1.3K Apr 29  2016 CentOS-CR.repo.bak
    -rw-r--r--  1 root root  649 Oct  8  2018 CentOS-Debuginfo.repo
    -rw-r--r--  1 root root  314 Oct  8  2018 CentOS-fasttrack.repo
    -rw-r--r--  1 root root  630 Oct  8  2018 CentOS-Media.repo
    -rw-r--r--  1 root root 1.3K Oct  8  2018 CentOS-Sources.repo
    -rw-r--r--  1 root root 4.7K Oct  8  2018 CentOS-Vault.repo
    -rw-r--r--  1 root root  257 May 15 01:31 cPAddons.repo
    -rw-------  1 root root  241 Feb 22 09:18 cpanel-plugins.repo
    -rw-r--r--  1 root root  204 Aug  7  2015 EA4.repo
    -rw-r--r--  1 root root 1.8K Feb  5 15:08 mysql-community.repo
    -rw-r--r--  1 root root 1.9K Apr 27  2017 mysql-community-source.repo
    Do I have the same problem described in this topic?
     
  11. Brittany C

    Brittany C Member

    Joined:
    Oct 17, 2018
    Messages:
    5
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    Madison, WI
    cPanel Access Level:
    Root Administrator
    Yup!
    The error occurs when you have git-all installed as the git-instaweb-1.8.3.1-20.el7.noarch is not compatible with the latest version. You can remedy it by uninstalling the package. That's how I fixed it at least.
     
    cPanelLauren likes this.
  12. aztopdavid

    aztopdavid Member

    Joined:
    Jan 1, 2016
    Messages:
    9
    Likes Received:
    4
    Trophy Points:
    3
    Location:
    Arizona
    cPanel Access Level:
    Root Administrator
    Thanks! I think I need a little more specificity on "...uninstalling the package" if you're willing. I don't remember how I wound up on the "CURRENT" cPanel & WHM update tier, rather than RELEASE (which is why I'm at 80.0.4 instead of 78.0.23), but I must have done that at some point. I have fairly simple needs, with mostly garden-variety web-hosting, mailman lists, and nothing "fancy" (nobody is using Git™ Version Control).
     
  13. cPanelLauren

    cPanelLauren Forums Analyst II Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    6,161
    Likes Received:
    474
    Trophy Points:
    233
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    You can uninstall the package by using

    Code:
    yum remove package-name 
    The git packages you have installed aren't even our Git Version Control packages so it's not something which was installed for cPanel we preface ours with cpanel- for example:

    Code:
    cpanel-git-2.21.0-1.cp1178.x86_64
    cpanel-git-gitweb-2.21.0-1.cp1178.x86_64
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  14. Brittany C

    Brittany C Member

    Joined:
    Oct 17, 2018
    Messages:
    5
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    Madison, WI
    cPanel Access Level:
    Root Administrator
    I would run
    Code:
    yum list installed | grep git
    to see which packages are installed. In my case it was "git-all", so I was able to run:
    Code:
    yum remove git-all
    If you need any git packages, you should be able to re-install them on an individual basis
     
  15. aztopdavid

    aztopdavid Member

    Joined:
    Jan 1, 2016
    Messages:
    9
    Likes Received:
    4
    Trophy Points:
    3
    Location:
    Arizona
    cPanel Access Level:
    Root Administrator
    On edit: I was composing while Brittany was responding. I'll try just removing "git-all" and see how that goes.

    Thanks, I'm getting closer to understanding. When I run "yum list installed" the only results starting with "git" are:
    Code:
    git.x86_64        1.8.3.1-14.el7_5    @updates
    git-all.noarch    1.8.3.1-14.el7_5    @updates
    git-cvs.noarch    1.8.3.1-14.el7_5    @updates
    git-email.noarch  1.8.3.1-14.el7_5    @updates
    git-gui.noarch    1.8.3.1-14.el7_5    @updates
    git-p4.noarch     1.8.3.1-14.el7_5    @updates
    git-svn.x86_64    1.8.3.1-14.el7_5    @updates
    gitk.noarch       1.8.3.1-14.el7_5    @updates
    So I see "git-all.noarch" there but nothing about "git-instaweb" so I'm still not sure how I should (safely) proceed.
     
    #15 aztopdavid, May 15, 2019
    Last edited: May 15, 2019
  16. cPanelLauren

    cPanelLauren Forums Analyst II Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    6,161
    Likes Received:
    474
    Trophy Points:
    233
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    Interesting, I of course have the git.x86_64 package but not the others here's what I get when i run that for git:

    Code:
    [root@server ~]# yum list installed |grep git
    cpanel-git.x86_64                                2.21.0-1.cp1178       installed
    cpanel-git-gitweb.x86_64                         2.21.0-1.cp1178       installed
    cpanel-git-templates.x86_64                      2.21.0-1.cp1178       installed
    git.x86_64                                       1.8.3.1-14.el7_5      @updates
    
    But ultimately the package causing the issue for you is specifically:

    Code:
    git-instaweb-1.8.3.1-20.el7.noarch 
    @Brittany C is correct as well, if you're not using anything git related you can remove all of it.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  17. aztopdavid

    aztopdavid Member

    Joined:
    Jan 1, 2016
    Messages:
    9
    Likes Received:
    4
    Trophy Points:
    3
    Location:
    Arizona
    cPanel Access Level:
    Root Administrator
    I ran "yum remove git-all" successfully, then did another "Upgrade to latest version" to see if it would throw any errors, but not a single "failed" to be found, so I'm good for now. I might go back and remove more packages later. Thanks to both of you!
     
    cPanelLauren likes this.
  18. cPanelLauren

    cPanelLauren Forums Analyst II Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    6,161
    Likes Received:
    474
    Trophy Points:
    233
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    I'm glad to hear it @aztopdavid thanks for letting us know it worked for you as well :)
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice