Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Update System Software fails because of missing RPM-GPG-KEY-EPEL

Discussion in 'Workarounds and Optimization' started by tss, Aug 26, 2014.

  1. tss

    tss Member

    Aug 22, 2011
    Likes Received:
    Trophy Points:
    Running CENTOS 5.10 x86_64 vmware WHM 11.44.1 (build 17)

    Ran into this problem. Tried to do an update but got this error message:

    rpmts_HdrFromFdno: Header V4 DSA signature: NOKEY, key ID 217521f6
    Turns out, for some reason, yum couldn't find this GPG key, which should have been located at:
    It's the public GPG key for the EPEL repository.

    I had to download and install this manually to get the update to work. Here's how to do it:

    Go to to find the missing key.

    I first tried wget to retrieve the key:

    [~]# wget [url][/url]
    --2014-08-26 10:45:43--  [url][/url]
    Resolving,,, ...
    Connecting to||:443... connected.
    ERROR: certificate common name `*' doesn't match requested host name `'.
    To connect to insecurely, use `--no-check-certificate'.
    Unable to establish SSL connection.
    Don't you love stuff like this? I thought wildcards certificates were supposed to match any version of the domain, but apparently they don't match the base domain.

    Anyway, I created the file 217521F6.txt in nano and copied the text from the web browser, then moved and renamed the file:

    [~]# mv 217521F6.txt /etc/pki/rpm-gpg/RPM-GPG-KEY-EPEL
    Next, import the key:

    [~]# rpm --import /etc/pki/rpm-gpg/RPM-GPG-KEY-EPEL
    After that, run "Update System Software" again. It worked this time, and should work in the future.

    Hope this helps someone...
    #1 tss, Aug 26, 2014
    Last edited by a moderator: Aug 26, 2014
  2. cPanelMichael

    cPanelMichael Technical Support Community Manager Staff Member

    Apr 11, 2011
    Likes Received:
    Trophy Points:
    cPanel Access Level:
    Root Administrator
    Hello :)

    I am happy to see you were able to resolve the issue. Thank you for sharing your solution.
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice