SOLVED Update to version 76 failed due to cpanel-perl(CryptX) >= 5.22.1 dependency

GTMAN

Member
Mar 5, 2013
8
0
1
cPanel Access Level
Root Administrator
***** FATAL: Test install failed: error: Failed dependencies:
[2018-11-06 16:35:55 -0400] cpanel-perl(CryptX) >= 5.22.1 is needed by (installed) cpanel-letsencrypt-2.14-1.1.noarch
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,226
463
Hello @GTMAN,

We'll need some more information about your system to fully investigate the reported error. Can you open a support ticket so we can access the affected system to take a closer look? Once opened, post the ticket number here and I'll ensure it's handled right away.

Thank you.
 

Dave Smith

Active Member
Mar 20, 2016
44
12
8
Lisbon
cPanel Access Level
Root Administrator
Exactly the same issue on one of our servers. The rest updated fine. Have tried installing CryptX and rebooted but still the issue persists. Should I open a Support Ticket or monitor this thread?

Thanks.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,226
463
Exactly the same issue on one of our servers. The rest updated fine. Have tried installing CryptX and rebooted but still the issue persists. Should I open a Support Ticket or monitor this thread?
Hi Dave,

Can you confirm if you use Amazon Linux as the OS on the affected system?

Thank you.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,226
463
We do not use Amazon Linux. Currently running CENTOS 6.8 standard. All of our boxes are running the same OS. As I mentioned all but a single server updated successfully.
Hi Dave,

In that case, can you go ahead and open a support ticket so we can take a closer look? Let me know the ticket number once it's opened.

Thank you.
 
  • Like
Reactions: Dave Smith

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,226
463
Hi Dave,

Thanks, I can confirm it was successfully opened. You should receive a response shortly.

Thank you.
 
  • Like
Reactions: Dave Smith

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,226
463
Hello,

To update, internal case CPANEL-23793 is open to address an issue where cPanel updates fail with the following error message when outdated iterations of the cpanel-letsencrypt RPM are installed:

Code:
***** FATAL: Test install failed: error: Failed dependencies:
cpanel-perl(CryptX) >= 5.22.1 is needed by (installed) cpanel-letsencrypt-2.16-6.1.noarch
I'll monitor this case and update this thread with more information as it becomes available. In the meantime, the workaround is to manually reinstall the Let's Encrypt plugin using the following commands:

Code:
/scripts/uninstall_lets_encrypt_autossl_provider
/scripts/install_lets_encrypt_autossl_provider
Then, proceed with the cPanel update:

Code:
/scripts/upcp
Let us know if this doesn't work.

Thank you.
 
Last edited:

cPanelNick

Administrator
Staff member
Mar 9, 2015
3,481
35
208
cPanel Access Level
DataCenter Provider
Its possible the cpanel-plugins repo was removed manually so it cannot update the let's encrypt plugin and its stuck on a version with an old depedency

You can force the system to cleanly remove the repo and the plugin by running

/scripts/install_lets_encrypt_autossl_provider
/scripts/uninstall_lets_encrypt_autossl_provider

If you want to keep the let's encrypt plugin, skip the uninstall command.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,226
463
Hello Everyone,

To update, this issue appears to occur in cases where the cpanel-plugins.repo YUM repo was manually removed, or when /scripts/rpmup could not finish successfully during a cPanel update (due to RPM conflicts).

The official solution to this issue is to ensure the latest version of the Let's Encrypt plugin is properly installed (or uninstalled if you no longer want to use the plugin).

1. If you're facing this issue and want to continue using the Let's Encrypt plugin, reinstall it using the following commands:

Code:
/scripts/uninstall_lets_encrypt_autossl_provider
/scripts/install_lets_encrypt_autossl_provider
2. If you're facing this issue and no longer want to use the Let's Encrypt plugin, simply uninstall it using the following command:

Code:
/scripts/uninstall_lets_encrypt_autossl_provider
Once either of these steps are taken, run the cPanel update process again to ensure it completes successfully:

Code:
/scripts/upcp
Let us know if you have any questions.

Thanks!
 
  • Like
Reactions: frankbret