The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

update_sa_rules / Perl problem

Discussion in 'General Discussion' started by dfraser, Jul 16, 2008.

  1. dfraser

    dfraser Member

    Joined:
    May 25, 2006
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    I am getting this in the output of upcp....

    overload does not define $overload::VERSION--version check failed at /usr/lib/perl5/5.8.8/Exporter/Heavy.pm line 122.
    BEGIN failed--compilation aborted at /usr/lib/perl5/site_perl/5.8.8/Pod/Simple/LinkSection.pm line 15.
    Compilation failed in require at /usr/lib/perl5/site_perl/5.8.8/Pod/Simple.pm line 9.
    BEGIN failed--compilation aborted at /usr/lib/perl5/site_perl/5.8.8/Pod/Simple.pm line 9.
    Compilation failed in require at /usr/lib/perl5/5.8.8/Pod/Text.pm line 34.
    BEGIN failed--compilation aborted at /usr/lib/perl5/5.8.8/Pod/Text.pm line 34.
    Compilation failed in require at /usr/lib/perl5/5.8.8/Pod/Usage.pm line 436.
    BEGIN failed--compilation aborted at /usr/lib/perl5/5.8.8/Pod/Usage.pm line 443.
    Compilation failed in require at /scripts/update_sa_rules line 20.
    BEGIN failed--compilation aborted at /scripts/update_sa_rules line 20.

    I've looked at the Perl code in question and can't see what is wrong. None of the modules mentioned above have changed significantly and this overload::VERSION thing involves Exporter and apparently some automagical Perl behavior that AFAIK one should not have to worry about.
    There is a VERSION constant, but no VERSION routine, which AFAIK is auto loaded as part of the UNIVERSAL module. I'm not a Perl guru so I am lost at this point...

    I've poked at things but can't seem to resolve it or get the errors to change in any way. I've don't have the upcp logs for the past few weeks so I can't track down when this wasn't happening either...

    so any ideas?

    TIA
    doug
     
  2. jmcole

    jmcole Active Member

    Joined:
    Aug 17, 2004
    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    1
    we're having this same issue, anyone found a solution?
     
  3. mattmattt

    mattmattt Member

    Joined:
    Aug 25, 2004
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    my freebsd cpanel box has this problem also after an update.
     
  4. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    I recommend having our technical analysts look at this for you (see link in my signature).
     
  5. mina

    mina Member

    Joined:
    Mar 3, 2002
    Messages:
    24
    Likes Received:
    0
    Trophy Points:
    1
    This seems to be a common problem on the box with Perl 5.8.8.

    Any update?
     
  6. jmcole

    jmcole Active Member

    Joined:
    Aug 17, 2004
    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    1
    cPanel support staff fixed this issue on one of our serves by reinstalling perl, I would suggest putting in a support ticket for them to do this if you are not comfortable with this task.
     
  7. mina

    mina Member

    Joined:
    Mar 3, 2002
    Messages:
    24
    Likes Received:
    0
    Trophy Points:
    1
    Thank you, jmcole.
    I'll submit a support ticket.

    At the moment, 4 out of my 6 servers have this problem.
     
Loading...

Share This Page