Updated Autodiscovery to ON and now nothing loads

Mach3011

Member
Jun 28, 2021
5
0
1
USA
cPanel Access Level
Root Administrator
Can anyone help diagnose what I did. I was trying to enable autodiscovery and now WHM/Cpanel/website will not resolve. I can still access via SSH.

All I did was enable the autodiscovery option and click save. This is the message afterwards.

Code:
Updating tweak settings...

Your changes have been saved.

Restarting cPanel daemons...done.

Updating your system to reflect any changes...
Updating “Thunderbird and Outlook autodiscover and autoconfig support (enables service subdomain and SRV record creation)” from “Off” to “On”.
“Thunderbird and Outlook autodiscover and autoconfig support (enables service subdomain and SRV record creation)” was updated.
Processing post action for Thunderbird and Outlook autodiscover and autoconfig support (enables service subdomain and SRV record creation):
Creating service subdomain DNS entries in background. This process can take several minutes to complete.
“Thunderbird and Outlook autodiscover and autoconfig support (enables service subdomain and SRV record creation)” was updated.
Done.
Now the website is down, whm/cpanel is down, and email bouncing. Any ideas??

Hosted on AWS Lightsail, using GoDaddy nameservers and dns.

I feel like it somehow turned on internal dns maybe?
 
Last edited by a moderator:

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
6,810
892
313
cPanel Access Level
Root Administrator
Hey there! I'm sorry to hear about this issue with the system. For emergencies like this you'll often get a quicker response by submitting a ticket to our support team.

In this case, it sounds like the DNS for the domain was likely affected. If you check with a tool like intodns.com does that show any errors that can be fixed on the server?
 

Mach3011

Member
Jun 28, 2021
5
0
1
USA
cPanel Access Level
Root Administrator
Oh shoot I didn't even know support tickets was a thing! So I ended up making a whole new instance from a snapshot from midnight. Thank goodness for back ups. However, DNS still seemed fine, I checked it on a few sites and it pulled back the static ip. However, I couldn't ping or anything. The only thing I could do was ssh from the aws console page. I could not ssh locally or anything. I have no idea what turning that auto discover setting on did in the background, but it was invasive.
 

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
6,810
892
313
cPanel Access Level
Root Administrator
It really shouldn't do anything nearly so drastic. It just sets up the DNS records to allow email clients to try their automatic connection tricks.

We offer free support, 24x7 through the link in my signature, so never hesitate to reach out. As long as you can get us SSH access to the affected system, we can at least try and get you some details even if it ultimately isn't a cPanel issue.
 

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
6,810
892
313
cPanel Access Level
Root Administrator
I have docs on everything! You'll just need to go to WHM >> Service Manager and uncheck the two boxes next to DNS Server to disable that service. I would still expect WHM access to work with the IP address (https://x.x.x.x:2087) even if there is a DNS issue causing a problem for the server's hostname.

More details on that interface can be found here: Service Manager | cPanel & WHM Documentation
 

Mach3011

Member
Jun 28, 2021
5
0
1
USA
cPanel Access Level
Root Administrator
That's the catch! https://x.x.x.x:2087 timed out afterwords as well. The only way I could do anything is by going to the aws lightsail ssh terminal in their online interface. Made no sense at all for one simple change to a setting. I saved the instance if there is any debugging we could do to help in the future.