Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Updated to latest version but I'm suddenly a few version back...

Discussion in 'General Discussion' started by TheBorg, Sep 3, 2004.

  1. TheBorg

    TheBorg Registered

    Joined:
    Aug 26, 2004
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    151
    Got a new server running Redhat Enterprise 3.0 with CPanel. I'm used to FreeBSD with a nice command prompt so it feels like CPanel is doing things out of my control...

    I started with version WHM 9.4.0 cPanel 9.4.1-R64

    I ran de updater "Upgrade to Latest Version" and then it became something like WHM 9.7.x cPanel 9.7.x-Sxx
    Perl as well as the kernel and some other stuff got updated.

    Now the problems:
    I installed Image Magick for Perl. I used WHM to do this. After the update, it's gone. Why are these RPM's not reinstalled?

    Cron was disabled and didn't start after a reboot.
    Got that fixed but that's some important shit ain't it?

    So I login into WHM after a few hours. Guess what, I'm back to WHM 9.4.0 cPanel 9.4.1-S65

    What do I need to do to keep the latest version, and make sure I don't have to manually reinstall RPM's after a software upgrade???
     
  2. jester.ro

    jester.ro Well-Known Member
    PartnerNOC

    Joined:
    Feb 6, 2004
    Messages:
    304
    Likes Received:
    0
    Trophy Points:
    166
    Location:
    Bucharest, Romania
    cPanel Access Level:
    DataCenter Provider
    First of all, you said you've found you version to be
    WHM 9.7.x cPanel 9.7.x-Sxx

    I find that very unlikely :)

    Second, IN WHM, go to SERVER SETUP/Update config

    And set you update policy there.

    You probably have checked "Automatic Stable", and that's why this happened.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. TheBorg

    TheBorg Registered

    Joined:
    Aug 26, 2004
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    151
    You are correct. I changed the update policy after the update. My mistake, very stupid.

    However I think my hosts update server is offline. I can't update, while MySQL is completely FU.

    Can anyone tell if this is a problem on the update server or on my server?
    From de up2date log:
    [Sun Sep 5 07:40:11 2004] up2date updating login info
    [Sun Sep 5 07:40:11 2004] up2date logging into up2date server
    [Sun Sep 5 07:41:35 2004] up2date A protocol error occurred: Internal Server Error , attempt #5,
    [Sun Sep 5 07:41:35 2004] up2date updating login info
    [Sun Sep 5 07:41:35 2004] up2date logging into up2date server
    [Sun Sep 5 07:46:03 2004] up2date A protocol error occurred: Internal Server Error , attempt #1,
     
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice