The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Updating Apache Crashes Server

Discussion in 'EasyApache' started by checksoft, May 1, 2005.

  1. checksoft

    checksoft Well-Known Member

    Joined:
    Mar 16, 2002
    Messages:
    70
    Likes Received:
    0
    Trophy Points:
    6
    The Update Apache tool in WHM seems faulty. Items I had checked off before were unchecked. Why? So I rechecked the items and ran it only to get the dreaded "httpd has failed, please contact the sysadmin" message. It will not restart. Here's part of the log in /usr/local/apache/logs/error_log:

    Reply With Quote
    [Sun May 1 12:03:05 2005] [error] [client 68.142.250.49] File does not exist: /home/talkandm/public_html/forums/printthread.php
    [Sun May 1 12:03:05 2005] [error] [client 68.142.250.49] File does not exist: /home/talkandm/public_html/404.shtml
    [Sun May 1 12:06:07 2005] [notice] caught SIGTERM, shutting down
    [Sun May 1 12:06:11 2005] [notice] Apache/1.3.33 (Unix) mod_perl/1.26 mod_auth_passthrough/1.8 mod_log_bytes/1.2 mod_bwlimited/1.4$
    [Sun May 1 12:06:11 2005] [notice] suEXEC mechanism enabled (wrapper: /usr/local/apache/bin/suexec)
    [Sun May 1 12:06:11 2005] [notice] Accept mutex: sysvsem (Default: sysvsem)
    2005-05-01 12:06:11 1DSGxP-0000d5-Tz Rewrite of nobody@host.domain.com yielded unparseable address: malformed address$
    2005-05-01 12:06:11 1DSGxP-0000d5-Tz Rewrite of nobody@host.domain.com yielded unparseable address: malformed address$
    [Sun May 1 12:09:39 2005] [warn] pid file /usr/local/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
    [Sun May 1 12:09:39 2005] [notice] Apache/1.3.33 (Unix) mod_perl/1.26 mod_auth_passthrough/1.8 mod_log_bytes/1.2 mod_bwlimited/1.4$
    [Sun May 1 12:09:39 2005] [notice] suEXEC mechanism enabled (wrapper: /usr/local/apache/bin/suexec)
    [Sun May 1 12:09:39 2005] [notice] Accept mutex: sysvsem (Default: sysvsem)

    What's the sense of checking off what mods you want installed if WHM ignores them on the next update? How do you get around this?
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    You have to click the Load Previous Config button before you run a rebuild. that will then restore the settings that you had the last time you built apache.
     
  3. checksoft

    checksoft Well-Known Member

    Joined:
    Mar 16, 2002
    Messages:
    70
    Likes Received:
    0
    Trophy Points:
    6
    I cannot get back into WHM to do that. I get a ""connection refused" error. What now?
     
  4. checksoft

    checksoft Well-Known Member

    Joined:
    Mar 16, 2002
    Messages:
    70
    Likes Received:
    0
    Trophy Points:
    6
    I'll answer my own question...I used easyapache through SSH and chose Option 6. Apache is recompiling as I write, but it has already given me this error:

    Syntax error on line 539 of /usr/local/apache/conf/httpd.conf:
    ErrorLog not allowed here
    /etc/rc.d/init.d/httpd start: httpd could not be started

    I never put an ErrorLog there. Any geniuses out there? I need some heavy duty help.
     
  5. ehpmahesh

    ehpmahesh Well-Known Member

    Joined:
    Jul 3, 2004
    Messages:
    74
    Likes Received:
    0
    Trophy Points:
    6
    Check with the following command.
    httpd -t
    it will check your Apache configuration file. If there is any problem with configuration file it will give the error. After checking the error you can find out the solution. Check this one, may it will help you.
     
  6. checksoft

    checksoft Well-Known Member

    Joined:
    Mar 16, 2002
    Messages:
    70
    Likes Received:
    0
    Trophy Points:
    6
    root@host [~]# httpd configtest
    Syntax OK
    root@host [~]#

    I added

    NameVirtualHost xx.xxx.xxx.xxx

    as a single entry above

    VirtualHost xx.xxx.xxx.xxx

    in the httpd.conf
    and the error stopped.
     
Loading...

Share This Page