The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Updating Apache get errors

Discussion in 'EasyApache' started by `joshua`, Nov 29, 2005.

  1. `joshua`

    `joshua` Active Member

    Joined:
    Dec 23, 2004
    Messages:
    42
    Likes Received:
    0
    Trophy Points:
    6
    Hello Forum users,

    I understand this is not a offical support forum for Cpanel, And I thank each and everyone of you that has gavin me support and helped me along with some issues, But I am currnetly having a small one I donno if it a bugg in the release version but when I try to update apache via whm, I get these errors . if anyone might have any suggestions or a fix for this please let me know guys, here is what I get when trying to update :

    make -j 1 apache_1.3.34....... . . . . . . . . . . . . . Done

    make[2]: *** [target_static] Error 1
    make[1]: *** [build-std] Error 2
    make: *** [build] Error 2

    make apache_1.3.34...(install).... Done

    make[3]: *** [target_static] Error 1
    make[2]: *** [build-std] Error 2
    make[1]: *** [build] Error 2
    make: *** [install-all] Error 2
    /etc/rc.d/init.d/httpd start: httpd started
    Setting /home permissions to 0711......Done
    Setting permissions for.....josh...sysreset...fanzz......Done
    Untarring curl......Done
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    That's odd. Firstly, make sure that /home isn't anywhere near full. Secondly, clear out the cpapachebuild directly and then try again:

    rm -Rfv /home/cpapachebuild

    Be careful with that command :)
     
  3. `joshua`

    `joshua` Active Member

    Joined:
    Dec 23, 2004
    Messages:
    42
    Likes Received:
    0
    Trophy Points:
    6
    Hello chirpy,

    The command you provided me with, I tired it and then tried to rebuild and get the same extact errors as before. Any other suggestions or cause of this?. could this be a bugg within the release version?
     
  4. `joshua`

    `joshua` Active Member

    Joined:
    Dec 23, 2004
    Messages:
    42
    Likes Received:
    0
    Trophy Points:
    6
    Anyone with any other suggestions on this issue?,
     
  5. AndyReed

    AndyReed Well-Known Member
    PartnerNOC

    Joined:
    May 29, 2004
    Messages:
    2,222
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Minneapolis, MN
    Can you post few lines prior to the above error message?
     
  6. `joshua`

    `joshua` Active Member

    Joined:
    Dec 23, 2004
    Messages:
    42
    Likes Received:
    0
    Trophy Points:
    6
    Hello Andy,

    I have posted alot above this line down to the errors, I have pasted it below :

    buildapache configured from Web Host Manager
    Apache configured from Web Host Manager!
    Untarring expat...Done

    configure expat-1.95.6...(--prefix=/usr).... . . Done

    make -j 1 expat-1.95.6....... . . . . . . . . Done

    make expat-1.95.6...(install).... Done

    Untarring apache....
    Suexec Standard Patch
    patching file src/support/suexec.c
    patching file src/support/suexec.h
    Suexec MailMan Patch
    patching file src/support/suexec.c
    Fileprotect Suexec Standard Patch
    patching file src/support/suexec.c
    Hunk #1 succeeded at 224 (offset -44 lines).
    Hunk #3 succeeded at 556 (offset -44 lines).
    HTTPS var Standard Patch
    patching file src/support/suexec.c
    Hunk #1 succeeded at 131 (offset -43 lines).

    configure apache_1.3.34...(--enable-shared=max).... . . Done

    patching file src/include/httpd.h
    Hunk #1 succeeded at 272 (offset -44 lines).
    Untarring modssl....
    patching file pkg.sslmod/libssl.module

    configure mod_ssl-2.8.25-1.3.34...(--with-apache=../apache_1.3.34 --with-ssl=/usr --enable-module=expires --enable-shared=expires --add-module=../mod_frontpage.c --enable-module=rewrite --enable-shared=rewrite --enable-suexec --suexec-logfile=/usr/local/apache/logs/suexec_log --suexec-caller=nobody --suexec-uidmin=100 --suexec-gidmin=100 --suexec-docroot=/ --suexec-userdir=public_html).... . . . . . . . . Done

    configure apache_1.3.34...(--enable-module=ssl --enable-module=expires --enable-shared=expires --add-module=../mod_frontpage.c --enable-module=rewrite --enable-shared=rewrite --enable-suexec --suexec-logfile=/usr/local/apache/logs/suexec_log --suexec-caller=nobody --suexec-uidmin=100 --suexec-gidmin=100 --suexec-docroot=/ --suexec-userdir=public_html).... . . . Done

    make -j 1 apache_1.3.34....... . . . . . . . . . . . . . Done

    make[2]: *** [target_static] Error 1
    make[1]: *** [build-std] Error 2
    make: *** [build] Error 2

    make apache_1.3.34...(install).... Done

    make[3]: *** [target_static] Error 1
    make[2]: *** [build-std] Error 2
    make[1]: *** [build] Error 2
    make: *** [install-all] Error 2
    /etc/rc.d/init.d/httpd start: httpd started
     
  7. AndyReed

    AndyReed Well-Known Member
    PartnerNOC

    Joined:
    May 29, 2004
    Messages:
    2,222
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Minneapolis, MN
    Did you remove the /home/cpapachebuild directory before re-compiling Apache?
    Did you update your RPMs?

    Did you get the same error message when trying to re-compile Apache at the prompt: /scripts/easyapache?

    Check for errors in the following log files:
    tail -n 60 /home/cpapachebuild/buildapache/build-log/apache_1.3.34.make.install.build.0
    tail -n 60 /home/cpapachebuild/buildapache/build-log/apache_1.3.34.make -j 1.default.build.0
     
  8. `joshua`

    `joshua` Active Member

    Joined:
    Dec 23, 2004
    Messages:
    42
    Likes Received:
    0
    Trophy Points:
    6
    Hello Andy,

    Yes I have removed /home/cpapachebuild and yes rpm is to date, and yes it gives same errors when running scripts/easyapache. and below is output of the tail :

    tail -n 60 /home/cpapachebuild/buildapache/build-log/apache_1.3.34.make.install.build.0
    BEGIN make install

    make[1]: Entering directory `/home/cpapachebuild/buildapache/apache_1.3.34'
    ===> src
    make[2]: Entering directory `/home/cpapachebuild/buildapache/apache_1.3.34'
    make[3]: Entering directory `/home/cpapachebuild/buildapache/apache_1.3.34/src'
    ===> src/regex
    make[4]: Nothing to be done for `all'.
    <=== src/regex
    ===> src/os/unix
    make[4]: Nothing to be done for `all'.
    <=== src/os/unix
    ===> src/ap
    make[4]: Nothing to be done for `all'.
    <=== src/ap
    ===> src/main
    make[4]: Nothing to be done for `all'.
    <=== src/main
    ===> src/lib
    <=== src/lib
    ===> src/modules
    ===> src/modules/standard
    make[5]: Nothing to be done for `all'.
    <=== src/modules/standard
    ===> src/modules/ssl
    make[5]: Nothing to be done for `all'.
    <=== src/modules/ssl
    ===> src/modules/extra
    make[5]: Nothing to be done for `all'.
    <=== src/modules/extra
    <=== src/modules
    gcc -c -I./os/unix -I./include -DLINUX=22 -DHAVE_SET_DUMPABLE -I/usr/include/gdbm -DMOD_SSL=208125 -DUSE_HSREGEX -DEAPI `./apaci` modules.c
    gcc -c -I./os/unix -I./include -DLINUX=22 -DHAVE_SET_DUMPABLE -I/usr/include/gdbm -DMOD_SSL=208125 -DUSE_HSREGEX -DEAPI `./apaci` buildmark.c
    gcc -DLINUX=22 -DHAVE_SET_DUMPABLE -I/usr/include/gdbm -DMOD_SSL=208125 -DUSE_HSREGEX -DEAPI `./apaci` -L/usr/lib -rdynamic \
    -o httpd buildmark.o modules.o modules/standard/libstandard.a modules/ssl/libssl.a modules/extra/libextra.a main/libmain.a ./os/unix/libos.a ap/libap.a regex/libregex.a -lm -lcrypt -lgdbm -lssl -lcrypto -lexpat -ldl
    make[3]: Leaving directory `/home/cpapachebuild/buildapache/apache_1.3.34/src'
    make[2]: Leaving directory `/home/cpapachebuild/buildapache/apache_1.3.34'
    make[1]: Leaving directory `/home/cpapachebuild/buildapache/apache_1.3.34'
     
  9. flavio

    flavio Member

    Joined:
    Mar 7, 2004
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    ??????

    do you get to solve the problem of the Apache?
     
  10. flavio

    flavio Member

    Joined:
    Mar 7, 2004
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    ??????

    ??????????????
     
  11. gfmorris

    gfmorris Member

    Joined:
    Jun 6, 2003
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Huntsville, AL, USA
    Anyone solved this? I have this issue myself.

    GFM
     
  12. AndyReed

    AndyReed Well-Known Member
    PartnerNOC

    Joined:
    May 29, 2004
    Messages:
    2,222
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Minneapolis, MN
    I am sorry, but it is really hard to say what's goin'on with your Apache modules without looking into your server.
     
  13. gfmorris

    gfmorris Member

    Joined:
    Jun 6, 2003
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Huntsville, AL, USA
    Yeah, I can understand that.

    The issues here seem to stem from Apache failing to compile. I dropped into /home/cpapachebuild/buildapache/ and got it to compile. Still not getting easyapache to work for me, though...

    GFM
     
  14. gfmorris

    gfmorris Member

    Joined:
    Jun 6, 2003
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Huntsville, AL, USA
    My issue ended up being multi-part: I had a horribly outdated kernel, which kept up2date [I'm on RHEL 3] from working properly. Since up2date wouldn't work right, I had outdated libraries, and that made cPanel's scripts foul up as well.

    If you're having similar issues, start with the OS kernel and go out...

    GFM
     
Loading...

Share This Page