DevilBear

Member
Oct 20, 2003
15
2
153
Hello,

I'm trying to install a package that returns:

libc.so.6(GLIBC_2.15) is needed by pcloudcc-2.0.1-2.i386
libc.so.6(GLIBC_2.17) is needed by pcloudcc-2.0.1-2.i386

Is it possible to update glibc on CentOS 6 cPanel server without breaking things?
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,884
2,254
463
Hello,

You can use the "yum update" command to ensure glibc is updated to the most recent version provided by CentOS. Updating the version of glibc beyond what's offered by CentOS 6 is not recommended. Instead, you'd need to consider setting up a new server with CentOS 7, installing cPanel, and then migrating your accounts to CentOS 7 if you require the version of glibc offered in newer CentOS versions.

Thank you.