mahdy_sharifi

Well-Known Member
Feb 26, 2012
220
1
68
cPanel Access Level
Root Administrator
when i want update server with Yum , I get following error :

Code:
--> Finished Dependency Resolution
Error: Package: perl-Git-1.7.1-8.el6.noarch (installed)
Requires: git = 1.7.1-8.el6
Removing: git-1.7.1-8.el6.x86_64 (installed)
git = 1.7.1-8.el6
Updated By: git-1.7.1-9.el6_9.x86_64 (cloudlinux-x86_64-server-6)
git = 1.7.1-9.el6_9
Available: git-1.7.1-2.el6.1.x86_64 (cloudlinux-x86_64-server-6)
git = 1.7.1-2.el6.1
Available: git-1.7.1-3.el6_4.1.x86_64 (cloudlinux-x86_64-server-6)
git = 1.7.1-3.el6_4.1
Available: git-1.7.1-4.el6_7.1.x86_64 (cloudlinux-x86_64-server-6)
git = 1.7.1-4.el6_7.1
Error: Package: git-1.7.1-9.el6_9.x86_64 (cloudlinux-x86_64-server-6)
Requires: perl-Git = 1.7.1-9.el6_9
Installed: perl-Git-1.7.1-8.el6.noarch (installed)
perl-Git = 1.7.1-8.el6
You could try using --skip-broken to work around the problem
** Found 93 pre-existing rpmdb problem(s), 'yum check' output follows:

I see in /etc/yum.conf perl exclude from update , why this setting done from Cpanel , we not allow to upte Perl ?

Thanks
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,224
463
Hello,

The entry for "perl*" is only added to the "exclude=" line if the system's Perl installation was altered from it's default state (this is more common on older systems). You should be able to remove it from the "exclude=" line on a CloudLinux system per the following CloudLinux thread:

Git Update Failing

Thank you.