Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Updating PHP Version

Discussion in 'EasyApache' started by Israel_Paya, Oct 2, 2017.

  1. Israel_Paya

    Israel_Paya Active Member

    Joined:
    Sep 18, 2015
    Messages:
    41
    Likes Received:
    3
    Trophy Points:
    8
    Location:
    Spain
    cPanel Access Level:
    Root Administrator
    My sever is actually running with PHP 5.4.39. Most of the websites I have built in the hostings in the server are WordPress and I am experiencing problems with the PHP version lately. Some templates require the PHP version to be 7.0. Is there a way I can update the php version in my server without compromising the websites in the server? I am using SuPhP 5.
    Or is there a way I can increase or select the PHP version per hosting?

    Sorry for my questions. I am not an experience person.

    Thank you so much.
     

    Attached Files:

  2. vacancy

    vacancy Well-Known Member

    Joined:
    Sep 20, 2012
    Messages:
    140
    Likes Received:
    14
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
  3. Israel_Paya

    Israel_Paya Active Member

    Joined:
    Sep 18, 2015
    Messages:
    41
    Likes Received:
    3
    Trophy Points:
    8
    Location:
    Spain
    cPanel Access Level:
    Root Administrator
    Thank you for your quick reply. Considering that all websites in the hostings in the server work with PHP 5.4.39, would this affect them? Thank you.
     
  4. vacancy

    vacancy Well-Known Member

    Joined:
    Sep 20, 2012
    Messages:
    140
    Likes Received:
    14
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    I do not think it's going to be a problem.

    Most of the settings will be automatically converted, the main php version will be 5.4, you can manually define different php versions on the site you want.
     
  5. Israel_Paya

    Israel_Paya Active Member

    Joined:
    Sep 18, 2015
    Messages:
    41
    Likes Received:
    3
    Trophy Points:
    8
    Location:
    Spain
    cPanel Access Level:
    Root Administrator
    Great! thank you so much.
     
  6. Israel_Paya

    Israel_Paya Active Member

    Joined:
    Sep 18, 2015
    Messages:
    41
    Likes Received:
    3
    Trophy Points:
    8
    Location:
    Spain
    cPanel Access Level:
    Root Administrator
    I am afraid doing it by myself. Do you know someone who could do that for me? I would be ready to pay for it, of course. Thank you.
     
  7. vacancy

    vacancy Well-Known Member

    Joined:
    Sep 20, 2012
    Messages:
    140
    Likes Received:
    14
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
  8. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    38,658
    Likes Received:
    1,425
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    You can also open a support ticket using the link in my signature if you require assistance with the conversion to EasyApache 4.

    Thank you.
     
  9. Israel_Paya

    Israel_Paya Active Member

    Joined:
    Sep 18, 2015
    Messages:
    41
    Likes Received:
    3
    Trophy Points:
    8
    Location:
    Spain
    cPanel Access Level:
    Root Administrator
    Hello,

    I contacted a System Administrator service and they will do that by myself. I hope everything to go right. I very much appreciate your assistance, indeed.
     
    cPanelMichael likes this.
Loading...

Share This Page