Updating to Apache 1.3.37

Kelmas

Well-Known Member
Nov 6, 2006
121
0
166
Lithuania
I have enabled CURRENT updates. For unkown reason I have Apache 1.3.36 installed while the server I have shared hosting account at runs the same CURRENT release with Apache 1.3.37.

How should I update Apache to 1.3.37 on my server?

I am using Red Hat Fedora Core 4 + cPanel 10.9.0.
 

AndyReed

Well-Known Member
PartnerNOC
May 29, 2004
2,221
4
193
Minneapolis, MN
How should I update Apache to 1.3.37 on my server?
Login to WHM and find "Apache Update" in the left pane. You also can update Apache using this command at the prompt: /scripts/easyapache
 

chirpy

Well-Known Member
Verifed Vendor
Jun 15, 2002
13,465
30
473
Go on, have a guess
It will be because cPanel only build v1.3.37 in the current release of easyapache. The version of cPanel you are running doesn't generally affect the version of apache you're running, that's done manually by upgrading in WHM or through /scripts/easyapache.
 

AndyReed

Well-Known Member
PartnerNOC
May 29, 2004
2,221
4
193
Minneapolis, MN
But the problem is that PHP have downgraded from 4.4.4 to 4.4.3. How to go back to 4.4.4?
You can update Php to v4.4.4 by re-compiling Php again, without Apache, in the WHM >> Software >> Apache Update
Select the checkbox next to the option: "Skip Apache Build if up to date"
Hope this helps!
 

Kelmas

Well-Known Member
Nov 6, 2006
121
0
166
Lithuania
Thanks, that worked :)

But there's one more issue. WHM shows correct Apache version number while client's cPanel shows the old one. PHP version is shown correctly. Should I restart cpanel service?
 
Last edited:

Kelmas

Well-Known Member
Nov 6, 2006
121
0
166
Lithuania
Sure! You can restart the cPanel.
Didn't help... I see version 1.3.37 in WHM and clients still see 1.3.36 in cPanel. Also, after recompiling PHP 4.4.4 with phpSuExec no PHP version is shown in cPanel. And before when it was without phpSuExec, PHP version showed correctly...

Bugs or what? :confused:

EDIT:
PHP version is now shown, but Apache version in cPanel client's interface is still incorrect...
 
Last edited: