Caleb Anderson

Registered
Jul 24, 2018
4
0
1
Dallas, Texas
cPanel Access Level
Root Administrator
EasyApache 4 Migration
To learn more about EasyApache 4 Migration Tool, please read our documentation here.
Pre-flight check result.
Cpanel Migrate Blocker (Cpanel)
Cpanel evaluates known issues such as network connectivity

  • Blocker: A fatal error was encountered while getting information from the server's configured repositories: Error: File contains no section headers. file: file:///etc/yum.repos.d/xrdp.repo, line: 1 ' [xrdp]\n' : Executed /usr/bin/yum -v repolist
  • Blocker: A fatal error was encountered when trying to call “/usr/bin/yum -q list bash” : Illegal seek ( )
  • Warning: “Cpanel::Easy::PHP5::MailHeaders” ignored since it does not have an RPM.
  • Warning: “Cpanel::Easy::Apache::Fileprotect” ignored since it does not have an RPM.
  • Warning: “Cpanel::Easy::Apache::Access” ignored since it does not have an RPM.
  • Warning: Current profile has the following MPMs: ea-apache24-mod_mpm_prefork
  • Warning: Adding the missing package, ea-apache24-mod_suexec, to the EasyApache 4 profile.
This action will disable EasyApache 3 and enable EasyApache 4 on this server.

You cannot migrate to EasyApache 4 because of existing blockers.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,884
2,243
463
  • Blocker: A fatal error was encountered while getting information from the server's configured repositories: Error: File contains no section headers. file: file:///etc/yum.repos.d/xrdp.repo, line: 1 ' [xrdp]\n' : Executed /usr/bin/yum -v repolist
  • Blocker: A fatal error was encountered when trying to call “/usr/bin/yum -q list bash” : Illegal seek ( )
Hello Caleb,

It looks like your system's package manager (YUM) is unable to update. YUM is required to be in working order to allow the EasyApache 4 conversion to succeed. The error message suggests one of your YUM repo files is corrupted or missing required information. Do you have any custom YUM repo files configured in the /etc/yum.repos.d/ directory? Do you notice any error messages when running the "yum clean all" and "yum repolist" commands?

Thank you.
 

Caleb Anderson

Registered
Jul 24, 2018
4
0
1
Dallas, Texas
cPanel Access Level
Root Administrator
[email protected] [~]# yum clean all
Loaded plugins: fastestmirror
Error: File contains no section headers.
file: file:///etc/yum.repos.d/xrdp.repo, line: 1
' [xrdp]\n'
[email protected] [~]#

[email protected] [~]# yum clean all
Loaded plugins: fastestmirror
Error: File contains no section headers.
file: file:///etc/yum.repos.d/xrdp.repo, line: 1
' [xrdp]\n'
[email protected] [~]#
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,884
2,243
463
Hello Caleb,

It looks like you are using custom YUM repo files that do not include the required information. This is generally something your hosting provider or system administrator should address if you are not comfortable managing YUM on your own. That said, feel free to open a support ticket so we can take a closer look at your YUM repo files to help facilitate the migration to EasyApache 4. You can post the ticket number here and we will link this thread to the ticket.

Thank you.
 

Caleb Anderson

Registered
Jul 24, 2018
4
0
1
Dallas, Texas
cPanel Access Level
Root Administrator
I am the system administrator as this is a dedicated server with godaddy and not a shared server. i dont know much about how to fix the issue. is there anything or any steps that you could walk me through to fix this issue.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,884
2,243
463
Hello Caleb,

Can you open a support ticket so we can take a closer look at your YUM repo files to help facilitate the migration to EasyApache 4? You can post the ticket number here and we will link this thread to the ticket.

Thank you.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,884
2,243
463
Hello,

To update, this was solved by repairing a typo in the /etc/yum.repos.d/xrdp.repo file associated with the third-party YUM repo.

Thank you.