Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Upgrade exits with errors

Discussion in 'General Discussion' started by inteldigital, May 13, 2018.

  1. inteldigital

    inteldigital Active Member

    Joined:
    Apr 5, 2018
    Messages:
    38
    Likes Received:
    8
    Trophy Points:
    8
    Location:
    England
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hi I am having an issue upgrading, also every RPM check that happens throws up some errors that are similar. Here's the error log from the upgrade:

    Code:
    [2018-05-13 00:58:18 +0100] file /usr/share/mysql/danish/errmsg.sys from install of MySQL55-server-5.5.59-1.cp1162.x86_64 conflicts with file from package mariadb-libs-2:5.5.52-1.el7.cloudlinux.x86_64
    [2018-05-13 00:58:18 +0100] file /usr/share/mysql/dutch/errmsg.sys from install of MySQL55-server-5.5.59-1.cp1162.x86_64 conflicts with file from package mariadb-libs-2:5.5.52-1.el7.cloudlinux.x86_64
    [2018-05-13 00:58:18 +0100] file /usr/share/mysql/english/errmsg.sys from install of MySQL55-server-5.5.59-1.cp1162.x86_64 conflicts with file from package mariadb-libs-2:5.5.52-1.el7.cloudlinux.x86_64
    [2018-05-13 00:58:18 +0100] file /usr/share/mysql/estonian/errmsg.sys from install of MySQL55-server-5.5.59-1.cp1162.x86_64 conflicts with file from package mariadb-libs-2:5.5.52-1.el7.cloudlinux.x86_64
    [2018-05-13 00:58:18 +0100] file /usr/share/mysql/french/errmsg.sys from install of MySQL55-server-5.5.59-1.cp1162.x86_64 conflicts with file from package mariadb-libs-2:5.5.52-1.el7.cloudlinux.x86_64
    [2018-05-13 00:58:18 +0100] file /usr/share/mysql/german/errmsg.sys from install of MySQL55-server-5.5.59-1.cp1162.x86_64 conflicts with file from package mariadb-libs-2:5.5.52-1.el7.cloudlinux.x86_64
    [2018-05-13 00:58:18 +0100] file /usr/share/mysql/greek/errmsg.sys from install of MySQL55-server-5.5.59-1.cp1162.x86_64 conflicts with file from package mariadb-libs-2:5.5.52-1.el7.cloudlinux.x86_64
    [2018-05-13 00:58:18 +0100] file /usr/share/mysql/hungarian/errmsg.sys from install of MySQL55-server-5.5.59-1.cp1162.x86_64 conflicts with file from package mariadb-libs-2:5.5.52-1.el7.cloudlinux.x86_64
    [2018-05-13 00:58:18 +0100] file /usr/share/mysql/italian/errmsg.sys from install of MySQL55-server-5.5.59-1.cp1162.x86_64 conflicts with file from package mariadb-libs-2:5.5.52-1.el7.cloudlinux.x86_64
    [2018-05-13 00:58:18 +0100] file /usr/share/mysql/japanese/errmsg.sys from install of MySQL55-server-5.5.59-1.cp1162.x86_64 conflicts with file from package mariadb-libs-2:5.5.52-1.el7.cloudlinux.x86_64
    [2018-05-13 00:58:18 +0100] file /usr/share/mysql/korean/errmsg.sys from install of MySQL55-server-5.5.59-1.cp1162.x86_64 conflicts with file from package mariadb-libs-2:5.5.52-1.el7.cloudlinux.x86_64
    [2018-05-13 00:58:18 +0100] file /usr/share/mysql/norwegian-ny/errmsg.sys from install of MySQL55-server-5.5.59-1.cp1162.x86_64 conflicts with file from package mariadb-libs-2:5.5.52-1.el7.cloudlinux.x86_64
    [2018-05-13 00:58:18 +0100] file /usr/share/mysql/norwegian/errmsg.sys from install of MySQL55-server-5.5.59-1.cp1162.x86_64 conflicts with file from package mariadb-libs-2:5.5.52-1.el7.cloudlinux.x86_64
    [2018-05-13 00:58:18 +0100] file /usr/share/mysql/polish/errmsg.sys from install of MySQL55-server-5.5.59-1.cp1162.x86_64 conflicts with file from package mariadb-libs-2:5.5.52-1.el7.cloudlinux.x86_64
    [2018-05-13 00:58:18 +0100] file /usr/share/mysql/portuguese/errmsg.sys from install of MySQL55-server-5.5.59-1.cp1162.x86_64 conflicts with file from package mariadb-libs-2:5.5.52-1.el7.cloudlinux.x86_64
    [2018-05-13 00:58:18 +0100] file /usr/share/mysql/romanian/errmsg.sys from install of MySQL55-server-5.5.59-1.cp1162.x86_64 conflicts with file from package mariadb-libs-2:5.5.52-1.el7.cloudlinux.x86_64
    [2018-05-13 00:58:18 +0100] file /usr/share/mysql/russian/errmsg.sys from install of MySQL55-server-5.5.59-1.cp1162.x86_64 conflicts with file from package mariadb-libs-2:5.5.52-1.el7.cloudlinux.x86_64
    [2018-05-13 00:58:18 +0100] file /usr/share/mysql/serbian/errmsg.sys from install of MySQL55-server-5.5.59-1.cp1162.x86_64 conflicts with file from package mariadb-libs-2:5.5.52-1.el7.cloudlinux.x86_64
    [2018-05-13 00:58:18 +0100] file /usr/share/mysql/slovak/errmsg.sys from install of MySQL55-server-5.5.59-1.cp1162.x86_64 conflicts with file from package mariadb-libs-2:5.5.52-1.el7.cloudlinux.x86_64
    [2018-05-13 00:58:18 +0100] file /usr/share/mysql/spanish/errmsg.sys from install of MySQL55-server-5.5.59-1.cp1162.x86_64 conflicts with file from package mariadb-libs-2:5.5.52-1.el7.cloudlinux.x86_64
    [2018-05-13 00:58:18 +0100] file /usr/share/mysql/swedish/errmsg.sys from install of MySQL55-server-5.5.59-1.cp1162.x86_64 conflicts with file from package mariadb-libs-2:5.5.52-1.el7.cloudlinux.x86_64
    [2018-05-13 00:58:18 +0100] file /usr/share/mysql/ukrainian/errmsg.sys from install of MySQL55-server-5.5.59-1.cp1162.x86_64 conflicts with file from package mariadb-libs-2:5.5.52-1.el7.cloudlinux.x86_64
    [2018-05-13 00:58:18 +0100] see https://go.cpanel.net/rpmcheckfailed for more information
    [2018-05-13 00:58:18 +0100] The Administrator will be notified to review this output when this script completes
    => Log closed Sun May 13 00:58:18 2018

    And the code from nightly RPM checks:

    Code:
    MySQL55-client-5.5.58-1.cp1162    Missing   
    MySQL55-devel-5.5.58-1.cp1162    Missing   
    MySQL55-server-5.5.58-1.cp1162    Missing   
    MySQL55-shared-5.5.58-1.cp1162    Missing   
    MySQL55-test-5.5.58-1.cp1162    Missing
     
  2. cPanelLauren

    cPanelLauren Forums Analyst
    Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    921
    Likes Received:
    65
    Trophy Points:
    103
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    HI @inteldigital

    Can you show me the output of the following:

    Code:
    rpm -qa |egrep -i 'mysql|mariadb'
     
  3. inteldigital

    inteldigital Active Member

    Joined:
    Apr 5, 2018
    Messages:
    38
    Likes Received:
    8
    Trophy Points:
    8
    Location:
    England
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hi @cPanelLauren

    Code:
    ea-php51-php-mysql5.5-5.1.6-1.el7.cloudlinux.x86_64
    perl-DBD-MySQL-4.023-5.el7.x86_64
    cpanel-mariadb-native-client-1.0.1-6.cp1154.x86_64
    alt-python27-MySQL-mariadb101-1.2.5-1.el7.cloudlinux.2.x86_64
    ea-php51-php-mysql5.6-5.1.6-1.el7.cloudlinux.x86_64
    ea-php51-php-mariadb10-5.1.6-1.el7.cloudlinux.x86_64
    alt-python27-MySQL-mysql5.0-1.2.5-1.el7.cloudlinux.2.x86_64
    ea-php72-php-mysqlnd-7.2.4-3.el7.cloudlinux.x86_64
    cpanel-perl-524-MySQL-Diff-0.50-1.cp1162.x86_64
    ea-php52-php-mysql5.0-5.2.17-2.el7.cloudlinux.x86_64
    mariadb-libs-5.5.52-1.el7.cloudlinux.x86_64
    ea-php51-php-mysql5.0-5.1.6-1.el7.cloudlinux.x86_64
    ea-php52-php-mysql5.6-5.2.17-2.el7.cloudlinux.x86_64
    compat-MySQL51-shared-5.1.73-1.cp1150.x86_64
    compat-MySQL50-shared-5.0.96-4.cp1136.x86_64
    alt-python27-MySQL-meta-1-4.el7.x86_64
    cpanel-mysql-libs-5.1.73-1.cp1156.x86_64
    ea-php52-php-mysql5.1-5.2.17-2.el7.cloudlinux.x86_64
    ea-php71-php-mysqlnd-7.1.16-3.el7.cloudlinux.x86_64
    alt-python27-MySQL-mysql5.5-1.2.5-1.el7.cloudlinux.2.x86_64
    ea-php51-php-mariadb101-5.1.6-1.el7.cloudlinux.x86_64
    alt-python27-MySQL-mysql5.1-1.2.5-1.el7.cloudlinux.2.x86_64
    cpanel-mariadb-native-client-devel-1.0.1-6.cp1154.x86_64
    alt-python27-MySQL-common-1.2.5-1.el7.cloudlinux.2.x86_64
    alt-python27-MySQL-mysql5.6-1.2.5-1.el7.cloudlinux.2.x86_64
    alt-python27-MySQL-percona5.7-1.2.5-1.el7.cloudlinux.3.x86_64
    mariadb-5.5.52-1.el7.cloudlinux.x86_64
    alt-python27-MySQL-percona5.6-1.2.5-1.el7.cloudlinux.2.x86_64
    mariadb-server-5.5.52-1.el7.cloudlinux.x86_64
    alt-python27-MySQL-mariadb102-1.2.5-1.el7.cloudlinux.3.x86_64
    ea-php70-php-mysqlnd-7.0.29-3.el7.cloudlinux.x86_64
    ea-php54-php-mysqlnd-5.4.45-54.el7.cloudlinux.x86_64
    alt-python27-MySQL-percona5.5-1.2.5-1.el7.cloudlinux.2.x86_64
    ea-php51-php-mysql5.1-5.1.6-1.el7.cloudlinux.x86_64
    alt-python27-MySQL-mysql5.7-1.2.5-1.el7.cloudlinux.2.x86_64
    cpanel-mysql-5.1.73-1.cp1156.x86_64
    cpanel-perl-524-DBD-mysql-4.042-1.cp1168.x86_64
    ea-php56-php-mysqlnd-5.6.35-3.el7.cloudlinux.x86_64
    ea-php55-php-mysqlnd-5.5.38-37.el7.cloudlinux.x86_64
    ea-php53-php-mysqlnd-5.3.29-24.el7.cloudlinux.3.x86_64
    ea-php52-php-mariadb101-5.2.17-2.el7.cloudlinux.x86_64
    ea-php52-php-mysql5.7-5.2.17-2.el7.cloudlinux.x86_64
    ea-php52-php-mariadb10-5.2.17-2.el7.cloudlinux.x86_64
    ea-php52-php-mysql5.5-5.2.17-2.el7.cloudlinux.x86_64
    ea-php51-php-mysql5.7-5.1.6-1.el7.cloudlinux.x86_64
    alt-python27-MySQL-mariadb10-1.2.5-1.el7.cloudlinux.2.x86_64
     
  4. cPanelLauren

    cPanelLauren Forums Analyst
    Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    921
    Likes Received:
    65
    Trophy Points:
    103
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    Hi @inteldigital

    It looks like you have MariaDB and the system thinks you should be installing MySQL 5.5.58 can you tell me what's in /var/cpanel/rpm.versions.d/local.versions ?

    Code:
    cat /var/cpanel/rpm.versions.d/local.versions
     
  5. inteldigital

    inteldigital Active Member

    Joined:
    Apr 5, 2018
    Messages:
    38
    Likes Received:
    8
    Trophy Points:
    8
    Location:
    England
    cPanel Access Level:
    Root Administrator
    Twitter:
    @cPanelLauren

    Code:
    [root@amethyst ~]# cat /var/cpanel/rpm.versions.d/local.versions
    ---
    file_format:
      version: 2
    target_settings:
      MariaDB101: installed
      clamav: installed
     
  6. cPanelLauren

    cPanelLauren Forums Analyst
    Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    921
    Likes Received:
    65
    Trophy Points:
    103
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    Hi @inteldigital

    What about here:

    Code:
    grep mysql-version= /var/cpanel/cpanel.config
     
  7. inteldigital

    inteldigital Active Member

    Joined:
    Apr 5, 2018
    Messages:
    38
    Likes Received:
    8
    Trophy Points:
    8
    Location:
    England
    cPanel Access Level:
    Root Administrator
    Twitter:
  8. cPanelLauren

    cPanelLauren Forums Analyst
    Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    921
    Likes Received:
    65
    Trophy Points:
    103
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    Hi @inteldigital

    The weird part in this is mariadb 5.5 doesn't exist and I see in local versions:

    Code:
    [root@amethyst ~]# cat /var/cpanel/rpm.versions.d/local.versions
    ---
    file_format:
      version: 2
    target_settings:
      MariaDB101: installed
      clamav: installed
    It shows you using MariaDB 10.1

    When I look up mariadb packages on a CL server I do get these:

    Code:
    cl-MariaDB55-debuginfo.x86_64 : Debug information for package cl-MariaDB55
    cl-MariaDB55.x86_64 : A community developed branch of MySQL
    cl-MariaDB55-bench.x86_64 : MariaDB benchmark scripts and data
    cl-MariaDB55-devel.x86_64 : Files for development of MariaDB/MySQL applications
    cl-MariaDB55-embedded.x86_64 : MariaDB as an embeddable library
    cl-MariaDB55-embedded-devel.x86_64 : Development files for MariaDB as an embeddable library
    cl-MariaDB55-libs.x86_64 : The shared libraries required for MariaDB/MySQL clients
    cl-MariaDB55-server.x86_64 : The MariaDB server and related files
    cl-MariaDB55-test.x86_64 : The test suite distributed with MariaD

    What version of MariaDB/MySQL are you actually using on the server?
     
  9. inteldigital

    inteldigital Active Member

    Joined:
    Apr 5, 2018
    Messages:
    38
    Likes Received:
    8
    Trophy Points:
    8
    Location:
    England
    cPanel Access Level:
    Root Administrator
    Twitter:
    @cPanelLauren Thanks Lauren. I did try and upgrade my SQL to MariaDB a while back, which is when I encountered this issue and it halted the upgrade progress, also halting the upgrade of the cPanel software too!

    Here's what it says on the upgrade MySQL/MariaDB screen

    upload_2018-5-16_1-28-3.png
     
  10. cPanelLauren

    cPanelLauren Forums Analyst
    Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    921
    Likes Received:
    65
    Trophy Points:
    103
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    Hi @inteldigital

    Could you open a ticket so we can take a closer look? I don't feel comfortable giving you advice on how to upgrade from this version to a supported version without one of our analysts being able to access the server and see the configuration.

    Thanks!
     
  11. inteldigital

    inteldigital Active Member

    Joined:
    Apr 5, 2018
    Messages:
    38
    Likes Received:
    8
    Trophy Points:
    8
    Location:
    England
    cPanel Access Level:
    Root Administrator
    Twitter:
  12. cPanelLauren

    cPanelLauren Forums Analyst
    Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    921
    Likes Received:
    65
    Trophy Points:
    103
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    Thanks, @inteldigital I feel a lot more confident we'll be able to get it properly sorted through a ticket. When you do open the ticket be sure to reply here with the ticket ID so we can update this thread with the outcome.


    Thank you!
     
  13. inteldigital

    inteldigital Active Member

    Joined:
    Apr 5, 2018
    Messages:
    38
    Likes Received:
    8
    Trophy Points:
    8
    Location:
    England
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hi @cPanelLauren the issue was resolved. Ticket ID was 9567837
     
  14. cPanelLauren

    cPanelLauren Forums Analyst
    Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    921
    Likes Received:
    65
    Trophy Points:
    103
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    Hi @inteldigital

    I am glad we had you open a ticket for this, it looks like we manually moved you from MariaDB 5.5 to MySQL5.5 so you could follow a supported update path, they also fixed some issues with RPMs on the system and you were able to update successfully. It looks like you were also able to move to MariaDB 10.2 successfully in the end as well!

    I'm glad it is all sorted now!

    Thanks!
     
    inteldigital likes this.
Loading...

Share This Page