Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Upgrade Failure Message for cPanel

Discussion in 'General Discussion' started by IRZQ88, Dec 29, 2017.

Tags:
  1. IRZQ88

    IRZQ88 Member

    Joined:
    Sep 18, 2016
    Messages:
    17
    Likes Received:
    2
    Trophy Points:
    3
    Location:
    Indonesia
    cPanel Access Level:
    Root Administrator
    Dear All,

    I've a problem with upcp script. The server always email me that the upgrade is not successful. But the thing is when i'm trying upgrade manually and force to reinstall the upgrade, there is no message of a failure.

    Here is the log that i get from the email:

    Code:
    [2017-12-29 20:37:44 +0700] [/usr/local/cpanel/scripts/migrate_local_ini_to_php_ini] Processing ea-php56 …
    [2017-12-29 20:37:44 +0700] [/usr/local/cpanel/scripts/migrate_local_ini_to_php_ini] No local.ini.
    [2017-12-29 20:37:44 +0700] [/usr/local/cpanel/scripts/migrate_local_ini_to_php_ini] … done!
    [2017-12-29 20:37:44 +0700] [/usr/local/cpanel/scripts/migrate_local_ini_to_php_ini] Processing ea-php70 …
    [2017-12-29 20:37:44 +0700] [/usr/local/cpanel/scripts/migrate_local_ini_to_php_ini] No local.ini.
    [2017-12-29 20:37:44 +0700] [/usr/local/cpanel/scripts/migrate_local_ini_to_php_ini] … done!
    [2017-12-29 20:37:44 +0700] - Finished command `/usr/local/cpanel/scripts/migrate_local_ini_to_php_ini --run --verbose` in 0.058 seconds
    [2017-12-29 20:37:44 +0700] 93% complete
    [2017-12-29 20:37:44 +0700] - Finished in 0.009 seconds
    [2017-12-29 20:37:44 +0700] Processing: Ensuring an "Active" MySQL profile is set
    [2017-12-29 20:37:44 +0700] - Processing command `/usr/local/cpanel/scripts/check_mysql`
    [2017-12-29 20:37:44 +0700] [/usr/local/cpanel/scripts/check_mysql] “check_mysql” will complete in the background (process ID 10898).
    [2017-12-29 20:37:44 +0700] - Finished command `/usr/local/cpanel/scripts/check_mysql` in 0.059 seconds
    [2017-12-29 20:37:44 +0700] 94% complete
    [2017-12-29 20:37:44 +0700] Processing: Checking CloudLinux installation
    [2017-12-29 20:37:44 +0700] - Processing command `/usr/local/cpanel/bin/cloudlinux_update`
    [2017-12-29 20:37:44 +0700] - Finished command `/usr/local/cpanel/bin/cloudlinux_update` in 0.036 seconds
    [2017-12-29 20:37:44 +0700] Processing: Updating plugins data cache
    [2017-12-29 20:37:44 +0700] - Processing command `/usr/local/cpanel/bin/refresh_plugin_cache`
    [2017-12-29 20:37:44 +0700] - Finished command `/usr/local/cpanel/bin/refresh_plugin_cache` in 0.008 seconds
    [2017-12-29 20:37:44 +0700] 95% complete
    => Log closed Fri Dec 29 20:37:44 2017
    ----------------------------------------------------------------------------------------------------
    => Log opened from cPanel Update (upcp) - Slave (9211) at Fri Dec 29 20:37:44 2017
    [2017-12-29 20:37:44 +0700] E Post Maintenance ended, however it did not exit cleanly (256). Please check the logs for an indication of what happened
    Please help me on this issue. Thank you.
     
  2. rpvw

    rpvw Well-Known Member

    Joined:
    Jul 18, 2013
    Messages:
    582
    Likes Received:
    177
    Trophy Points:
    43
    Location:
    Spain
    cPanel Access Level:
    Root Administrator
    Could you run the following code in a terminal and let us know what output you get
    Code:
    awk '$4=="E"' /var/cpanel/updatelogs/update.xxxxxxxxxx.log
    (Replace the xxxxxxxxx with the number of the latest log file in /var/cpanel/updatelogs/)
     
  3. IRZQ88

    IRZQ88 Member

    Joined:
    Sep 18, 2016
    Messages:
    17
    Likes Received:
    2
    Trophy Points:
    3
    Location:
    Indonesia
    cPanel Access Level:
    Root Administrator
    Okay. Here are the results:

    Code:
    [2017-12-29 20:37:40 +0700] E    [/usr/local/cpanel/scripts/restartsrv_eximstats] The “/usr/local/cpanel/scripts/restartsrv_eximstats” command (process 10847) reported error number 255 when it ended.
    [2017-12-29 20:37:44 +0700] E Post Maintenance ended, however it did not exit cleanly (256). Please check the logs for an indication of what happened
    
    Please assist me on finding the solution... Thank you.
     
  4. rpvw

    rpvw Well-Known Member

    Joined:
    Jul 18, 2013
    Messages:
    582
    Likes Received:
    177
    Trophy Points:
    43
    Location:
    Spain
    cPanel Access Level:
    Root Administrator
    Try running /usr/local/cpanel/scripts/restartsrv_eximstats in a terminal and let us know the output
     
  5. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    41,516
    Likes Received:
    1,616
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
  6. IRZQ88

    IRZQ88 Member

    Joined:
    Sep 18, 2016
    Messages:
    17
    Likes Received:
    2
    Trophy Points:
    3
    Location:
    Indonesia
    cPanel Access Level:
    Root Administrator
    Sorry for the late reply. I think I've got the solution for this after running this command:

    Code:
    /usr/local/cpanel/scripts/restartsrv_eximstats
    Thanks rpvw and Michael for the help! :)
     
Loading...

Share This Page