The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Upgrade from 4.4.4 to php5.2? Possible?

Discussion in 'General Discussion' started by TurXaliM, Nov 7, 2006.

  1. TurXaliM

    TurXaliM Registered

    Joined:
    Oct 1, 2006
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Hello;

    Upgrade from 4.4.4 to php5.2? Possible? Because now until 5.1.6...
    4.4.4 and 5.1.6 there are the vulnerabilitys...
     
  2. networxhosting

    networxhosting Well-Known Member
    PartnerNOC

    Joined:
    Apr 22, 2003
    Messages:
    80
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Hamilton, Ontario, CANADA
    Upgrading is just a matter of compiling and installing 5.20, however the problem isn't whether you can upgrade or not it's whether you will break sites with the upgrade. I am pretty sure you will so I haven't been brave enough to tried it. Is 5.20 an option in the newest easyapache script?

    IF you really know what you are doing you could goto Hardened-PHP and get the patch for the htmlentities overflow and apply it to the php 4.4.4 source. I don't know how easy that would be to implement into easyapache though.
     
    #2 networxhosting, Nov 7, 2006
    Last edited: Nov 7, 2006
Loading...

Share This Page