Upgrade ImageMagick to version 7.1 on Centos 7 server

veronicabend

Well-Known Member
Feb 25, 2005
76
2
158
What is the correct way to upgrade image magick on a centos 7 server with cpanel/whm?

I checked installed versions and they are old:

Code:
convert -version
Version: ImageMagick 6.7.8-9 2016-06-16 Q16 http://www.imagemagick.org
Copyright: Copyright (C) 1999-2012 ImageMagick Studio LLC
Features: OpenMP
Current version at imagemagick.org is 7.08

I tried using yum and it says no packages are marked for update.

There is an rpm at Download @ ImageMagick for Centos 7.1, my server has CentOS 7.5 so that would apply.

I just want to get it updated the right way and not mess it up.

Thanks.
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,295
1,273
313
Houston
Hi @veronicabend

If you ran
Code:
yum check-update ImageMagick
and got no results then there's no update for the package. Furthermore cPanel initiates a yum update during maintenance updates and pending you don't have it excluded from yum updates should be updated automatically.

As far as what's available in the repository the CentOS base for your version of CentOS has the latest version they have available. The same is present on my server:

Code:
# rpm -qa |grep ImageMagick
ImageMagick-6.7.8.9-15.el7_2.x86_64
It may be that the version isn't stable yet or CentOS base hasn't added it yet but none the less if you want to use yum you'll need to wait.


Thanks!
 

Derekn

Member
Mar 25, 2017
16
0
1
cPanel Access Level
Website Owner
Hi
Since we cannot use yum to update to imageimagick 7. How do i install or update it manually? Because my website need imagemagick 7 otherwise it will display imagick function deprecated. I searched online with many solutions but it doesnot work with cpanel because the command is different

Thank you
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,295
1,273
313
Houston
Hello,

imagemagick is an OS provided RPM and not something cPanel manages. You might check their site here: ImageMagick for more information if you need that specific version and it's not available.