SOLVED Upgrade ionCube loader for php7.0?

AGuyInFL

Member
Jul 20, 2015
14
0
1
US
cPanel Access Level
Website Owner
I just upgraded to EA4 and I noticed that php7.0 comes with ionCube Loader 6 but php7.1 comes with ionCube Loader 10

I'd like to use ionCube Loader 10 for my php7.0 as well.

Is there a way to change / upgrade the ionCube Loader for the php7.0?

If there's, then how? (Detailed steps would be appreciated).
 

AGuyInFL

Member
Jul 20, 2015
14
0
1
US
cPanel Access Level
Website Owner
I guess version 10 minimum requirement says php 7.1, so seems unsupported, you may run into issues
What is the latest iconCube loader for php7.0? Do you know?

The problem is I bought a script and everything works fine except the sign up page goes to an error 500 page. I contacted the tech support for that script and the guy said that the problem could be an outdated ionCube loader (the script works with php7.0 only). I don't question what he said, I bought from them before, so I am pretty sure he knows what he's talking about. So, I need to somehow upgrade that ionCube loader for php7.0 to the latest one.

I tried to install it from Loader Download - PHP Encoder, protection, installer and performance tools from ionCube but somehow it never finishes it. It does say that the ionCube loader I am using is outdated, but it would not install a new one. Not sure why.
 

amdbuilder

Member
PartnerNOC
Feb 5, 2013
14
1
3
Durham, NC
cPanel Access Level
DataCenter Provider
Twitter
Looking at the ionCube loader changelog it would appear the 10.0.x branch does support PHP 7.0.x and PHP 7.1.x. That being said you may want to stick with the 6.x.x branch for PHP 7.0.x as it will likely be more stable.

The last 6.x.x release was 6.1.0 on 5/24/2017, and 10.0.3 on 9/26/2017.

You might want to ask him what version of ionCube did he encode the script to target.
 
  • Like
Reactions: AGuyInFL

AGuyInFL

Member
Jul 20, 2015
14
0
1
US
cPanel Access Level
Website Owner
Looking at the ionCube loader changelog it would appear the 10.0.x branch does support PHP 7.0.x and PHP 7.1.x. That being said you may want to stick with the 6.x.x branch for PHP 7.0.x as it will likely be more stable.

The last 6.x.x release was 6.1.0 on 5/24/2017, and 10.0.3 on 9/26/2017.

You might want to ask him what version of ionCube did he encode the script to target.
I suppose I can just wait. Sooner or later Apache will have new updates and who knows maybe php7.0 will have a newer (and more stable) ionCube.

PS The guy insists that it should work with my current ionCube. Not sure what the deal is. Meantime I will run the script on php5.6.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,219
463
The problem is I bought a script and everything works fine except the sign up page goes to an error 500 page.
Hello,

It's possible the error message is unrelated to the version of IonCube Loaders utilized by your website. You can check the "Errors" option in cPanel when you encounter the "500" error code to see what the specific error message is.

Thank you.
 
  • Like
Reactions: AGuyInFL

AGuyInFL

Member
Jul 20, 2015
14
0
1
US
cPanel Access Level
Website Owner
Sure enough php7.0 with ionCube10 is now part of EasyApache4 (I guess it was installed after I ran an update a couple days ago). Nice.
 

rogerw

Member
Feb 21, 2012
23
4
53
cPanel Access Level
Website Owner
I migrated two of the servers to EA4 and observe there is no ionCube. The cPanel documentation says there is (https://documentation.cpanel.net/display/EA4/PHP+Loader:+ionCube+5), but alas, there is not.

Specifically, the above linked resource states:

"To install or uninstall the ionCube 5 in EasyApache 4, use WHM's EasyApache 4 interface (WHM >> Home >> Software >> EasyApache 4)."​

However, that's not the case - There's no option to install using WHM (even when I use the search feature in "PHP extentions")

It goes on to state:

"Alternately, you can run the following command on the command line:

yum install ea-php<version>-php-ioncube5

In the example above, <version> represents the version of PHP for which you wish to install ionCube. If you wish to use ionCube 5 with PHP version 5.5, your command may resemble the following example: yum install ea-php55-php-ioncube5"​

Would it be safe to try the command even when WHM does not have the option?

Does anyone have a solution handy? I specifically need ionCube 5 (which runs perfectly using EA3 install options).
 

rpvw

Well-Known Member
Jul 18, 2013
1,101
465
113
UK
cPanel Access Level
Root Administrator
Just a note to remind users of CloudLinux alt-php that IonCube is supported in the following php versions from the stable repos since 6th September 2017

alt-php44-ioncube-loader-10.0.1-1
alt-php51-ioncube-loader-10.0.1-1
alt-php52-ioncube-loader-10.0.1-1
alt-php53-ioncube-loader-10.0.1-1
alt-php54-ioncube-loader-10.0.1-1
alt-php55-ioncube-loader-10.0.1-1
alt-php56-ioncube-loader-10.0.1-1
alt-php70-ioncube-loader-10.0.1-1
alt-php71-ioncube-loader-10.0.1-1

The following are available in beta from testing repos as at 2 November 2017

alt-php44-ioncube-loader-10.0.4-1
alt-php51-ioncube-loader-10.0.4-1
alt-php52-ioncube-loader-10.0.4-1
alt-php53-ioncube-loader-10.0.4-1
alt-php54-ioncube-loader-10.0.4-1
alt-php55-ioncube-loader-10.0.4-1
alt-php56-ioncube-loader-10.0.4-1
alt-php70-ioncube-loader-10.0.4-1
alt-php71-ioncube-loader-10.0.4-1
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,219
463
cPanel currently has no EA4 support for IonCube in PHP 7.1 or PHP 7.2 - I found that on this cPanel resource:
PHP Options - EasyApache 4 - cPanel Documentation
Note that IonCube 10 for PHP 7.1 is available. You can install it via the EasyApache 4 interface in WHM or with the following command:

Code:
yum install ea-php71-php-ioncube10
Support for Ioncube with PHP 7.2 is not yet published to the EA4 production repo.

Thank you.