The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Upgrade ModSecurity Rules

Discussion in 'Security' started by Piolon, Feb 10, 2008.

  1. Piolon

    Piolon Well-Known Member

    Joined:
    Feb 20, 2007
    Messages:
    48
    Likes Received:
    0
    Trophy Points:
    6
    I need to upgrade my ModSecurity rules

    My server has installed...
    WHM 11.15.0
    Apache 1.3.37
    ModSecurity 1.9.1-2.6
    Default ModSecurity Rules

    My questions are...
    What Apache version recommend me?
    What ModSecurity version ?

    And for this moment...
    What ModSecurity rules recommend me to apply?

    Thanks any answer...
     
  2. ChadE

    ChadE Active Member

    Joined:
    Mar 14, 2005
    Messages:
    32
    Likes Received:
    0
    Trophy Points:
    6
    Personally, I use Apache 2.2.8 (with mod_security 2.1.5 - switching to 2.5 when it comes out as stable). The core rules generally work well with all of the got_root modsec2 rules but FireFox periodically triggers a couple rules. I've got a list of rules to be disabled on a script-by-script (filename) basis depending on if you use phpBB, vBulletin or any forum software.
     
  3. nightfall_sg

    nightfall_sg Active Member

    Joined:
    Apr 15, 2004
    Messages:
    38
    Likes Received:
    0
    Trophy Points:
    6
    cPanel Access Level:
    Root Administrator
    Forgive me if this sounds silly, but how do I check what version of Apache and Modsecurity I got running on my cpanel?

     
  4. mohit

    mohit Well-Known Member

    Joined:
    Jul 12, 2005
    Messages:
    553
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Sticky On Internet
    nightfall_sg
    you can go to "APACHE STATUS" in root whm and "mod security" under Add on section on root whm.
     
  5. nightfall_sg

    nightfall_sg Active Member

    Joined:
    Apr 15, 2004
    Messages:
    38
    Likes Received:
    0
    Trophy Points:
    6
    cPanel Access Level:
    Root Administrator
    Thanks. I tried.

    I can see my apache is 2.2.8 in Apache Status, not in Mod Security link under Add on section it just shows a simply log page for mod security and an option to edit the configuration file. No sign of the mod security version anywhere there.

     
  6. dprophit

    dprophit Member

    Joined:
    Apr 1, 2002
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    Got Root Auto Updates

    It would be NICE if cpanel would take either apache 1.x or 2.x updates from modsecurity.org and applied them to mod_security if enabled.:mad:
     
    #6 dprophit, Mar 15, 2008
    Last edited: Mar 15, 2008
Loading...

Share This Page