The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Upgrade MySQL

Discussion in 'General Discussion' started by IberHosting, Sep 16, 2005.

  1. IberHosting

    IberHosting Well-Known Member

    Joined:
    Jun 1, 2005
    Messages:
    124
    Likes Received:
    0
    Trophy Points:
    16
    Hello,

    Im running mysql 4.0

    Do you suggest me to upgrade from 4.0 to 4.1 in WHM?


    Thanks,

    Antonio
     
  2. IberHosting

    IberHosting Well-Known Member

    Joined:
    Jun 1, 2005
    Messages:
    124
    Likes Received:
    0
    Trophy Points:
    16
    Hello,

    Finally ive jumped to 4.1, but now in all php pages im getting a 500 Internal Server Error.

    I need to recompile Apache after a MySQL upgrade?

    Thanks,

    Antonio
     
  3. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Yes, you do. That's why the option says:

     
  4. MMarko

    MMarko Well-Known Member

    Joined:
    Apr 18, 2005
    Messages:
    316
    Likes Received:
    0
    Trophy Points:
    16
    I've updated mySQL with rpms and didn't have to recompile apache. Everything works fine.
     
  5. Cygnus_X1

    Cygnus_X1 Active Member

    Joined:
    Feb 22, 2006
    Messages:
    31
    Likes Received:
    0
    Trophy Points:
    6
    I know this comment is like 9 months after the last one, but I wanted to thank Chirpy for his tips and advice on this issue, as I encountered the same thing after upgrading my MySQL server from 4.0.27 to 4.1.18. Rebuilding apache was the correct answer.

    Appreciate it, Chirpy!
     
  6. jackie46

    jackie46 BANNED

    Joined:
    Jul 25, 2005
    Messages:
    537
    Likes Received:
    0
    Trophy Points:
    0
    Why dont you follow directions? You may think you dont need to recompile Apache just because you think its working but in reality you do. Sooner or later you will have nothing but problems. The proper update procedure is;

    Set WHM to 4.1
    Run /scripts/eximup --force
    Recompile Apache
     
  7. gemby

    gemby Well-Known Member
    PartnerNOC

    Joined:
    Feb 16, 2002
    Messages:
    182
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Pula, Croatia
    cPanel Access Level:
    DataCenter Provider
    You mean /scripts/mysqlup not /scripts/eximup ?

    Exim has nothing with it.
     
  8. jackie46

    jackie46 BANNED

    Joined:
    Jul 25, 2005
    Messages:
    537
    Likes Received:
    0
    Trophy Points:
    0
    Yes, i typo on my part!
     
Loading...

Share This Page