The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Upgrade OpenSSH

Discussion in 'General Discussion' started by yoohost, Sep 13, 2008.

  1. yoohost

    yoohost Member

    Joined:
    Sep 2, 2004
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    So Got an alert from PCI Scanner, saying the OpenSSH needs to be updated.
    I says it needs to be upgraded to version 5.0 or higher.

    Question is, will it break anything if I compile it from source?
    Or does cPanel plan on releasing a newer version soon?

    Thanks for your time.
     
  2. hostmedic

    hostmedic Well-Known Member

    Joined:
    Apr 30, 2003
    Messages:
    559
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Washington Court House, Ohio, United States
    cPanel Access Level:
    DataCenter Provider
    should not break

    It should not break anything -
    use yum or such - should work just fine.

    :)
     
  3. yoohost

    yoohost Member

    Joined:
    Sep 2, 2004
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    Yum says it's running the latest version. But it's not.
    That's why I am looking to compile it. Any other thoughts/suggestions?
     
  4. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    If you're running a supported OS (e.g. CentOS/RHEL v3 or above) then there is no need to upgrade openSSH as RedHat backports security and bug fixes into known stable versions. If that's the case here, it's a failure of PCI Scanner.
     
Loading...

Share This Page