The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

upgrade phpBB problem

Discussion in 'General Discussion' started by sonik, Sep 26, 2004.

  1. sonik

    sonik Registered

    Joined:
    Feb 2, 2004
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    I upgraded to cpanel 9.7.7-release 15 and then upgraded an existing phpBB installation (2.0.8) to 2.0.10. But the footer of each web file indicates it's still version 2.0.8. How do I find out if it's .8 or .10?
     
  2. sonik

    sonik Registered

    Joined:
    Feb 2, 2004
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    anyone?

    ..
     
  3. SarcNBit

    SarcNBit Well-Known Member

    Joined:
    Oct 14, 2003
    Messages:
    1,010
    Likes Received:
    3
    Trophy Points:
    38
    Open your /admin/admin_board.php file

    At the top of the file look inside the copyright block and see what file version it is.

    2.0.8 = $Id: admin_board.php,v 1.51.2.6 2003/06/10 00:37:12 psotfx Exp $

    2.0.10 = $Id: admin_board.php,v 1.51.2.8 2004/07/15 18:02:44 acydburn Exp $

    The numbers at the bottom of the page are pulled from a db entry and can be easily changed. The file versions are what matter.
     
  4. sonik

    sonik Registered

    Joined:
    Feb 2, 2004
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Thanks, looks like it is .10
     
  5. SarcNBit

    SarcNBit Well-Known Member

    Joined:
    Oct 14, 2003
    Messages:
    1,010
    Likes Received:
    3
    Trophy Points:
    38
    You should be able to change your db value by running the following SQL statement:

    UPDATE phpbb_config SET config_value='.0.10' WHERE config_name='version';

    That assumes your $table_prefix value is set to 'phpbb_'. Check your config.php file and adjust the table value accordingly.

    Feel free to change the '.0.10' to whatever value you please. That is what will appear after the v2 in the footer of your forum.
     
  6. voth

    voth Member

    Joined:
    Nov 16, 2004
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    Looks like the same kind of problem with 2.0.10 to 2.0.11

    I logged into WHM selected the account I wanted to upgrade phpBB did the install. Completed. Went back to check the version, it listed it as 2.0.10.

    Looked in the admin_board.php file like was described in this thread. Can anyone verify that this it indeed phpBB 2.0.11

     
  7. sonik

    sonik Registered

    Joined:
    Feb 2, 2004
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Yeah, that's 2.0.11
     
  8. toygeek

    toygeek Member

    Joined:
    Apr 19, 2003
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    How?

    How are you guys getting the upgrades to work? I have a customer who is trying to upgrade but it produces a message "We are upgrading in /home/tbeardmo/public_html/BBS... Upgrade script is missing. Upgrade failed, you may have reached your disk quota!"

    Disk quota is fine. I don't know what script to look for to fix this. Any suggestions?
     
  9. racomnet

    racomnet BANNED

    Joined:
    Oct 6, 2004
    Messages:
    68
    Likes Received:
    0
    Trophy Points:
    0
    hello

    I upgraded the phpBB with an update from linux console, and it worked great. For one of my customer I upgrated from Cpanel, and it changed the forum to the default template . Next time I will think twice before upgrading from Cpanel :mad:
    WHM 9.9.8 cPanel 9.9.8-R160
     
  10. peterquast

    peterquast Member

    Joined:
    Apr 19, 2002
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    How did you run the update via SSH ?

    what was the command you used ?

    AND, do you think there is a way to do that globally accross the entire server, ie upgrade all NOT SECURE PHPbb ?
     
Loading...

Share This Page