upgrade to Java Runtime Environment (JRE) version 1.8

sergiomarcelo

Registered
Mar 16, 2017
3
0
1
Porto Alegre
cPanel Access Level
Root Administrator
Hello guys,

I need to upgrade java 1.6 to Java Runtime Environment (JRE) version 1.8

... To run Solr this version of java is a prerequisite.

And there is an incompatibility with EasyApache 3.

Can anyone give me a light?

Thank you!

Sérgio

--

Java version 1.6.0_41
CentOS 6 (64bit)
Easy Apache v3.34.12
Apache 2.2
PHP 5.6
 

sergiomarcelo

Registered
Mar 16, 2017
3
0
1
Porto Alegre
cPanel Access Level
Root Administrator
Hi Michael,
I do not have Tomcat running.
I just need to update the java version for JRE 1.8
I tried to update manually, but there were problems, like the loss of the server's php.ini reference, etc.
It was passed by the advanced support team that this version was not compatible like easy apache - cpanel, and for this I look for help.
 

Nirjonadda

Well-Known Member
May 8, 2013
724
27
78
cPanel Access Level
Root Administrator
Hi Michael,
I do not have Tomcat running.
I just need to update the java version for JRE 1.8
I tried to update manually, but there were problems, like the loss of the server's php.ini reference, etc.
It was passed by the advanced support team that this version was not compatible like easy apache - cpanel, and for this I look for help.
Install Java Runtime 1.8

Code:
yum install java-1.8.0
or If you need a java compiler and other developer tools:

Code:
yum install java-1.8.0-openjdk-devel
 

sergiomarcelo

Registered
Mar 16, 2017
3
0
1
Porto Alegre
cPanel Access Level
Root Administrator
Thank you and sorry for taking time to respond.

Below all the commands used:
Code:
Java -version

# 1.6

Yum install java-1.8.0-openjdk

# How to upgrade java is to be able to install solr ...

Cd / opt
Wget http://www.us.apache.org/dist/lucene/solr/6.4.2/solr-6.4.2.tgz
Tar zxvf solr-6.4.2.tgz
Cp solr-6-4-2 / bin / install_solr_service.sh
Rm -rf solr-6-4-2
./install_solr_service.sh solr-6-4-2.tgz
Chkconfig solr on
Su-solr -c "/ opt / solt / bin / solr create_core -c moodle"

# Error: Your current version of java is too old to run this version of solr. We found version 1.6.0_41, using command 'java'
Please install latest version of java 8 or be JAVA_HOME properly.
As I installed more than one version of java on the server, on different paths, I ended up configuring JAVA_HOME for the java-1.8.0 version installed, but still continued to display the above error.

In contact with hostdime, they said that this version of java could have conflict with easyapache 3. In the end I had to uninstall and go back to version 1.6.0-41.

But I believe that I must have a correct way to update Java to run with our current system.

Thanks for listening.
 
Last edited by a moderator:

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,910
2,215
363
In contact with hostdime, they said that this version of java could have conflict with easyapache 3. In the end I had to uninstall and go back to version 1.6.0-41.

But I believe that I must have a correct way to update Java to run with our current system.
Hello,

Did you relay to HostDime that you were not using Tomcat? Also, is there any reason you prefer to use EasyApache 3 over EasyApache 4, assuming you do not require Tomcat?

Thank you.