The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Upgrade to MariaDB Failed (Home >> Software >> MariaDB/MySQL Upgrade)

Discussion in 'Database Discussions' started by LUN, Sep 7, 2015.

  1. LUN

    LUN Member

    Joined:
    Aug 19, 2015
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    LA
    cPanel Access Level:
    Website Owner
    Hi,

    https://documentation.cpanel.net/display/CKB/How+to+Replace+MySQL+with+MariaDB

    I did exactly what is being told there Home >> Software >> MariaDB/MySQL Upgrade.
    I was trying to migrate to MariaDB.


    I got error that upgrade failed and that there is some problem at /etc/my.cnf
    I have previously modified this file and the thing that I have added was


    max_connections = 500

    So I removed the above line and run the upgrade again and even that failed. (see the attached screenshot).
     

    Attached Files:

  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,786
    Likes Received:
    665
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    Could you verify if you used "WHM Home >> Software >> MariaDB/MySQL Upgrade" or if you used the unsupported custom workaround first? Do you notice any error messages in /var/lib/mysql/$hostname.err when the upgrade fails or when restarting MySQL?

    Thank you.
     
  3. LUN

    LUN Member

    Joined:
    Aug 19, 2015
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    LA
    cPanel Access Level:
    Website Owner
    Hi,
    Yes I have used "WHM Home >> Software >> MariaDB/MySQL Upgrade" and not the unsupported method.
    MySQL doesn't start.

    When I type mysql in terminal I get this.
    ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2)

    And for error messages I get this.
    cat: /var/lib/mysql/.err: No such file or directory

    Thanks for helping me.
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,786
    Likes Received:
    665
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Please don't use "cat" for error logs, as it will output the entire log. Try using a command such as "tail -200 /var/lib/mysql/$hostname.err" to see the last 200 lines from the log file. Note that $hostname is referring to the hostname of your server.

    Thank you.
     
  5. LUN

    LUN Member

    Joined:
    Aug 19, 2015
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    LA
    cPanel Access Level:
    Website Owner
    I just wanted to update here, as I have managed to solve this.
    Hear is what I did. First I restarted server. Then manually started mysql (service mysql start).
    Than I cancelled the existing update and again migrated to mysql followed by rebuilding php and Apache. After that again run the migration tool (and pray to god that it will not break) to MariaDB. This should fix the problem.

    Note : Before upgrading make sure that /etc/my.cnf file is not modified and that it has all the system default settings. I got this error become I have previously added max_connections = 500 to it.
     
  6. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,786
    Likes Received:
    665
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
Loading...

Share This Page