supcp

Registered
Dec 7, 2018
4
0
1
EU
cPanel Access Level
Website Owner
Hello, i'm currently using passenger throuh the EasyApache4 module.

As i see the current passenger version used is 5.3.7, but i need to update it to passenger 6.0.2.

Which is the procedure you suggest so i can do this without breaking anything?

Thanks in advance for your help
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,218
463
Hello @supcp,

Support for Passenger 6.x is not yet offered with cPanel & WHM and there's no supported method or workaround for the newer version. Our feature request website is the best way to express support for and track the implementation of a new version:

Submit A Feature Request

Thank you.
 

supcp

Registered
Dec 7, 2018
4
0
1
EU
cPanel Access Level
Website Owner
Thanks. So in case i need to manually installed outside Cpanel, is there anything i should consider to avoid cPanel/WHM breaking something?
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,218
463
Thanks. So in case i need to manually installed outside Cpanel, is there anything i should consider to avoid cPanel/WHM breaking something?
Hello @supcp,

We provide guidance on how to build custom EasyApache 4 RPMs on the link below:

Tutorial - Building Custom Packages For EasyApache 4

Assistance building a custom EasyApache 4 RPM falls outside our scope of support, however we do provide a list of companies offering system administration services should you need assistance with building the custom RPM:

System Administration Services | cPanel Forums

Keep in mind a custom RPM will potentially break features (e.g. cPanel's Application Manager interface) that rely on and are tested against the supported version.

Thank you.