Upgrade WHM from 10.8.2 C52 to C56 error

isputra

Well-Known Member
May 3, 2003
575
0
166
Mbelitar
Today i try to update whm from 10.8.2 c52 to c56

When the update script start to proccess the update, i have error message :

-----------------------------------
Updating /scripts ...
Sync Source: http://httpupdate.cpanel.net/CURRENT/scripts
Testing connection speed...(this could take a while)....Done
Ping:51.401 Testing connection speed to 198.66.78.12 using wget...(184330 bytes/s)...Done
Ping:51.493 Invalid Url at /scripts/cPScript/MirrorSearch.pm line 145
cPScript::MirrorSearch::_testmirrorspeed('undef') called at /scripts/cPScript/MirrorSearch.pm line 109
cPScript::MirrorSearch::_fetchgoodhosts('httpupdate.cpanel.net', 10, 5, 'HASH(0x81fdc24)', 'HASH(0x81fdba0)', 0) called at /scripts/cPScript/MirrorSearch.pm line 68
cPScript::MirrorSearch::findfastest('days', 10, 'key', 'httpupdate.cpanel.net', 'count', 5, 'urls', 'ARRAY(0x827b52c)') called at /scripts/cPScript/HttpRequest.pm line 224
cPScript::HttpRequest::_getAddressList('httpupdate.cpanel.net') called at /scripts/cPScript/HttpRequest.pm line 52
cPScript::HttpRequest::request('cPScript::HttpRequest=HASH(0x8296204)', 'exitOn404', 0, 'host', 'httpupdate.cpanel.net', 'url', '/cpanelsync/CURRENT/scripts/.cpanelsync.lock', 'protocol', 0, ...) called at /scripts/cpanelsync line 54
Done updating /scripts
-------------------------------------------

And the update script run untill finished. But at the end of update proccess, i have this error message :

---------------------------------------------
cPanel Layer 2 Install Complete
Testing connection speed...(this could take a while)....Done
Ping:51.401 Testing connection speed to 198.66.78.12 using wget...(190480 bytes/s)...Done
Ping:51.493 (internal death) Tue May 2 07:26:11 2006 [11753] error: Invalid Url at /usr/local/cpanel/Cpanel/MirrorSearch.pm line 145
Cpanel::MirrorSearch::_testmirrorspeed(undef) called at /usr/local/cpanel/Cpanel/MirrorSearch.pm line 109
Cpanel::MirrorSearch::_fetchgoodhosts('httpupdate.cpanel.net', 10, 5, 'HASH(0x8debf80)', 'HASH(0x8debf50)', 0) called at /usr/local/cpanel/Cpanel/MirrorSearch.pm line 68
Cpanel::MirrorSearch::findfastest('days', 10, 'key', 'httpupdate.cpanel.net', 'count', 5, 'urls', 'ARRAY(0x8dec2b0)') called at /usr/local/cpanel/Cpanel/HttpRequest.pm line 224
Cpanel::HttpRequest::_getAddressList('httpupdate.cpanel.net') called at /usr/local/cpanel/Cpanel/HttpRequest.pm line 52
Cpanel::HttpRequest::request('Cpanel::HttpRequest=HASH(0x8fc34ac)', 'host', 'httpupdate.cpanel.net', 'url', '/cpanelsync/addons/scripts/nthemes.rc', 'protocol', 0) called at whostmgr/bin/whostmgr2.pl line 6703
main::getaddonversions('scripts') called at whostmgr/bin/whostmgr2.pl line 6733
main::updateaddons() called at whostmgr/bin/whostmgr2.pl line 84
Carp::confess('Invalid Url') called at /usr/local/cpanel/Cpanel/MirrorSearch.pm line 145
Cpanel::MirrorSearch::_testmirrorspeed(undef) called at /usr/local/cpanel/Cpanel/MirrorSearch.pm line 109
Cpanel::MirrorSearch::_fetchgoodhosts('httpupdate.cpanel.net', 10, 5, 'HASH(0x8debf80)', 'HASH(0x8debf50)', 0) called at /usr/local/cpanel/Cpanel/MirrorSearch.pm line 68
Cpanel::MirrorSearch::findfastest('days', 10, 'key', 'httpupdate.cpanel.net', 'count', 5, 'urls', 'ARRAY(0x8dec2b0)') called at /usr/local/cpanel/Cpanel/HttpRequest.pm line 224
Cpanel::HttpRequest::_getAddressList('httpupdate.cpanel.net') called at /usr/local/cpanel/Cpanel/HttpRequest.pm line 52
Cpanel::HttpRequest::request('Cpanel::HttpRequest=HASH(0x8fc34ac)', 'host', 'httpupdate.cpanel.net', 'url', '/cpanelsync/addons/scripts/nthemes.rc', 'protocol', 0) called at whostmgr/bin/whostmgr2.pl line 6703
main::getaddonversions('scripts') called at whostmgr/bin/whostmgr2.pl line 6733
main::updateaddons() called at whostmgr/bin/whostmgr2.pl line 84
[a fatal error or timeout occurred while processing this directive]Invalid Url at /usr/local/cpanel/Cpanel/MirrorSearch.pm line 145
Cpanel::MirrorSearch::_testmirrorspeed(undef) called at /usr/local/cpanel/Cpanel/MirrorSearch.pm line 109
Cpanel::MirrorSearch::_fetchgoodhosts('httpupdate.cpanel.net', 10, 5, 'HASH(0x8debf80)', 'HASH(0x8debf50)', 0) called at /usr/local/cpanel/Cpanel/MirrorSearch.pm line 68
Cpanel::MirrorSearch::findfastest('days', 10, 'key', 'httpupdate.cpanel.net', 'count', 5, 'urls', 'ARRAY(0x8dec2b0)') called at /usr/local/cpanel/Cpanel/HttpRequest.pm line 224
Cpanel::HttpRequest::_getAddressList('httpupdate.cpanel.net') called at /usr/local/cpanel/Cpanel/HttpRequest.pm line 52
Cpanel::HttpRequest::request('Cpanel::HttpRequest=HASH(0x8fc34ac)', 'host', 'httpupdate.cpanel.net', 'url', '/cpanelsync/addons/scripts/nthemes.rc', 'protocol', 0) called at whostmgr/bin/whostmgr2.pl line 6703
main::getaddonversions('scripts') called at whostmgr/bin/whostmgr2.pl line 6733
main::updateaddons() called at whostmgr/bin/whostmgr2.pl line 84
------------------------------------------

So, what's happen with the update script ?

I tried using shell and from WHM have the same result. And the version of WHM still shows WHM 10.8.0 cPanel 10.8.2-C52

Thanks.
 

exo

Member
Oct 2, 2003
14
0
151
Similar error trying to upgrade from C52 to R57.
 

exo

Member
Oct 2, 2003
14
0
151
The error where it stops:


---------------------
initfpsuexec: using apache 1.x support
Testing connection speed...(this could take a while)....Done
Ping:3.273 Testing connection speed to 198.66.78.12 using wget...(2210000 bytes/s)...Done
Ping:3.485 Invalid Url at /scripts/cPScript/MirrorSearch.pm line 145
cPScript::MirrorSearch::_testmirrorspeed('undef') called at /scripts/cPScript/MirrorSearch.pm line 109
cPScript::MirrorSearch::_fetchgoodhosts('layer2.cpanel.net', 10, 5, 'HASH(0x9a21db4)', 'HASH(0x9a21d30)', 0) called at /scripts/cPScript/MirrorSearch.pm line 68
cPScript::MirrorSearch::findfastest('days', 10, 'key', 'layer2.cpanel.net', 'count', 5, 'urls', 'ARRAY(0x9a59000)') called at /scripts/cPScript/HttpRequest.pm line 224
cPScript::HttpRequest::_getAddressList('layer2.cpanel.net') called at /scripts/cPScript/HttpRequest.pm line 52
cPScript::HttpRequest::request('cPScript::HttpRequest=HASH(0x9a8a6f8)', 'host', 'layer2.cpanel.net', 'url', '/installer/', 'protocol', 0) called at /scripts/upcp line 328
---------------------


but there are some previous errors:

--------------------
Ftp Quota Check v1.0
Doing a manual update...
Cpanel updates are coming from layer2.cpanel.net
Ftp Setup Script Version 6.0
Fetching version information from http://updates.cpanel.net/ftpinstall/version (RELEASE)....Testing connection speed...(this could take a while)....Done
Ping:3.932 Testing connection speed to 198.66.78.12 using wget...(2130000 bytes/s)...Done
Ping:7.611 Unable to retrieve version info: Bad file descriptor at /scripts/cPpkgversions.pm line 50.
Exim Setup Script Version 20.0
Fetching version information from http://updates.cpanel.net/eximinstall/version (RELEASE)....Testing connection speed...(this could take a while)....Done
Ping:3.932 Testing connection speed to 198.66.78.12 using wget...(2280000 bytes/s)...Done
Ping:7.611 Unable to retrieve version info: Bad file descriptor at /scripts/cPpkgversions.pm line 50.
---------------------

and

---------------------
bandmin Setup Script Version 1.0
Fetching version information from http://updates.cpanel.net/bandmininstall/version (RELEASE)....Testing connection speed...(this could take a while)....Done
Ping:3.932 Testing connection speed to 198.66.78.12 using wget...(2240000 bytes/s)...Done
Ping:7.611 Unable to retrieve version info: Bad file descriptor at /scripts/cPpkgversions.pm line 50.
---------------------
 

Spiral

BANNED
Jun 24, 2005
2,018
8
193
I'm having the same problem with the exact same identical error message!

I am currently on EDGE release 10.8.2-E45 and can no longer upgrade!

Apparently whatever change Cpanel last made has kill upgrades
across the board for all releases it looks like.

So if the upgrade system is now broke, my question is how do we
get an upgrade to fix the upgrade system? :rolleyes:

EDIT: Just saw cpanelben's post above .... thanks!
 
Last edited:

BenThomas

Well-Known Member
Feb 12, 2004
598
0
166
Houston, Texas USA
cPanel Access Level
Root Administrator
The problem you have all experienced is the combination of several factors, one of which being an update server of ours that died last night. Systems that were affected were those that had previously been using that update server (one of many) preferentially, as it was the fastest mirror for your server.

Essentially, only portions of the update fail due to this scenario, but overall the update process detects the error and dies as it should. This will prevent your server from being partially updated were it counts. I'm still working on a fix, and once it's finished an update will be published today. This will resolve the issue for good during upcp's automatic run.

Sorry for the inconvenience.
 

exo

Member
Oct 2, 2003
14
0
151
Thanks for the fix. It worked in the server that was failing.
 

BryanSD

Member
Apr 10, 2006
9
0
151
Relief...

Oh...this is much better. Thanks for the fix! I was going nuts before finding this thread and fix.
 

Snowman30

Well-Known Member
PartnerNOC
Apr 7, 2002
679
0
316
cPanel Access Level
DataCenter Provider
Glad i found this post mind you ive done a dozen upcp's tonight so far and only one server had this issue

and weirdly that server was updating from 10.8.1 R113
 
Last edited:

chirpy

Well-Known Member
Verifed Vendor
Jun 15, 2002
13,437
31
473
Go on, have a guess
Had the same issue and simply uploaded MirrorSearch.pm from an upgraded server - this thread wasn't around at the time :)