The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Upgrade WHM to 11.48.0.7 from 11.46.2.4 with MariaDB installed

Discussion in 'Database Discussions' started by kodyxgen, Feb 4, 2015.

  1. kodyxgen

    kodyxgen Member

    Joined:
    Jul 9, 2013
    Messages:
    20
    Likes Received:
    1
    Trophy Points:
    3
    cPanel Access Level:
    Root Administrator
    Hi,
    i have try to upgrade today WHM to latest version but i got error, so i am thinking that there are some manual steps to take before upgrading a 11.46X with MariaDB installed to 11.48.
    Can someone post a good way to do this.

    i think others WHM users running on MariaDB5 will find this interesting.

    Thank you.
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    648
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
  3. kodyxgen

    kodyxgen Member

    Joined:
    Jul 9, 2013
    Messages:
    20
    Likes Received:
    1
    Trophy Points:
    3
    cPanel Access Level:
    Root Administrator
    Hi,

    i get this.
    Running `/usr/local/cpanel/scripts/updatenow --upcp --log=/var/cpanel/updatelogs/update.1423087784.log` failed, exited with code 2 (signal = 0)

    - - - Updated - - -

    Hi again and from the log file i get this:
    Code:
    [20150205.160954] E 
    [20150205.160954] E The system failed to execute yum with the arguments “-y -c /etc/yum.conf install giflib libxslt-devel zsh” because of an error: The “/usr/bin/yum” command (process 706604) reported the “EPERM” (1) error when it ended. : 
    [20150205.160954] Error Downloading Packages:
    [20150205.160954]   libgpg-error-devel-1.7-4.el6.x86_64: Error communicating with server. The message was:
    [20150205.160954] No route to host
    [20150205.160954]   zsh-4.3.10-9.el6.x86_64: Error communicating with server. The message was:
    [20150205.160954] No route to host
    [20150205.160954]   libxslt-devel-1.1.26-2.el6_3.1.x86_64: Error communicating with server. The message was:
    [20150205.160954] No route to host
    [20150205.160954]   libgcrypt-devel-1.4.5-11.el6_4.x86_64: Error communicating with server. The message was:
    [20150205.160954] No route to host
    [20150205.160954]   giflib-4.1.6-3.1.el6.x86_64: Error communicating with server. The message was:
    [20150205.160954] No route to host
    [20150205.160954]   checkyum version 22.3
    [20150205.160956] E Sysup: Needed system RPMs were not installed: giflib, libxslt-devel, zsh
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    648
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    That looks like an issue with your system package manager. Please ensure you have no firewall rules blocking connections to the YUM mirrors, and that your /etc/resolv.conf file uses valid resolvers.

    Thank you.
     
  5. kodyxgen

    kodyxgen Member

    Joined:
    Jul 9, 2013
    Messages:
    20
    Likes Received:
    1
    Trophy Points:
    3
    cPanel Access Level:
    Root Administrator
    Hi,
    i stoped the firewall and checked the resolv.conf i have nameserver 8.8.8.8 and nameserver 213.186.33.99
    but i im getting the same error, i really don't know then what is the problem.
     
  6. kodyxgen

    kodyxgen Member

    Joined:
    Jul 9, 2013
    Messages:
    20
    Likes Received:
    1
    Trophy Points:
    3
    cPanel Access Level:
    Root Administrator
    Hi,
    back with the solution :). After some search on the internet i found out that the problem is in:
    /var/cache/yum/x86_64/6/cloudlinux-x86_64-server-6/mirrorlist.txt
    from what i read if there is a cl-mirror.qwords.net we have to comment it out, but since i did not have it i checked them all and after commenting this #https://cl-mirror.pidginhost.com/XMLRPC/ out all was perfect.
    So i started the upgrade process once more and i did not get an error in the first 30 seconds. :)
     
  7. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    648
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
  8. mthomas92868

    mthomas92868 Registered

    Joined:
    Feb 10, 2015
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Orange, California, United Sta
    cPanel Access Level:
    Root Administrator
    I'm having the same issue the only difference is, I dunno have the file path to modify the file, i have disabled my firewall and tried still no luck also tried manual install no luck either

    Code:
    ----------------------------------------------------------------------------------------------------
    => Log opened from cPanel Update (upcp) - Slave (902056) at Tue Feb 10 11:46:09 2015
    [20150210.114609]   Detected cron=0 (manual flag passed on command line)
    [20150210.114609]   Running Standardized hooks
    [20150210.114609]   mtime on upcp is 1417576403 (Tue Dec  2 19:13:23 2014)
    ----------------------------------------------------------------------------------------------------
    => Log opened from /usr/local/cpanel/scripts/updatenow (902059) at Tue Feb 10 11:46:10 2015
    [20150210.114610]   Detected version '11.46.2.4' from version file.
    [20150210.114610]   Running version '11.46.2.4' of updatenow.
    [20150210.114610]   Using mirror '208.109.109.239' for host 'httpupdate.cpanel.net'.
    [20150210.114610]   Target version set to '11.48.0.11'
    [20150210.114610]   Switching to 11.48.0.11 to determine if we can reach that version without failure.
    [20150210.114610]   Retrieving and staging /cpanelsync/11.48.0.11/cpanel/scripts/updatenow.static.bz2
    [20150210.114610]   Using mirror '208.109.109.239' for host 'httpupdate.cpanel.net'.
    [20150210.114610]   Set permissions on /usr/local/cpanel/scripts/updatenow.static-cpanelsync to 0700
    [20150210.114610]   Become an updatenow.static for version: 11.48.0.11
    => Log closed Tue Feb 10 11:46:10 2015
    ----------------------------------------------------------------------------------------------------
    => Log opened from /usr/local/cpanel/scripts/updatenow.static-cpanelsync (902059) at Tue Feb 10 11:46:11 2015
    [20150210.114611]   Detected version '11.46.2.4' from version file.
    [20150210.114611]   Running version '11.48.0.11' of updatenow.
    [20150210.114611]   Using mirror '208.109.109.239' for host 'httpupdate.cpanel.net'.
    [20150210.114611]   Target version set to '11.48.0.11'
    [20150210.114611]   Checking license
    [20150210.114611]   License file check complete
    [20150210.114611]   Checking that the RPM DB is OK...
    [20150210.114611]   glibc-2.12-1.149.el6.x86_64
    [20150210.114611]   OK: RPM DB is responding to queries
    [20150210.114611]   Testing if rpm_is_working RPM is installed
    [20150210.114611]   package rpm_is_working is not installed
    [20150210.114611]   Testing if it's possible to install a simple RPM
    [20150210.114611]   Preparing...                ##################################################
    [20150210.114611]   rpm_is_working              ##################################################
    [20150210.114611]   Switching to version '11.48.0.11' of updatenow to perform sync.
    [20150210.114612]   checkyum version 22.3
    [20150210.114613]   Loaded plugins: fastestmirror
    [20150210.114613]   Setting up Install Process
    [20150210.114613]   Loading mirror speeds from cached hostfile
    [20150210.114613]   No package giflib available.
    [20150210.114613]   No package libxslt-devel available.
    [20150210.114614]   No package zsh available.
    [20150210.114614] E Error: Nothing to do
    [20150210.114614] E The system failed to execute yum with the arguments “-y -c /etc/yum.conf install giflib libxslt-devel zsh” because of an error: The “/usr/bin/yum” command (process 902185) reported the “EPERM” (1) error when it ended. : Error: Nothing to do
    [20150210.114614]   checkyum version 22.3
    [20150210.114615] E Sysup: Needed system RPMs were not installed: giflib, libxslt-devel, zsh
    => Log closed Tue Feb 10 11:46:15 2015
    [20150210.114615] E Running `/usr/local/cpanel/scripts/updatenow --upcp --log=/var/cpanel/updatelogs/update.1423597569.log` failed, exited with code 2 (signal = 0)
    => Log closed Tue Feb 10 11:46:15 2015
     
  9. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    648
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Feel free to open a support ticket using the link in my signature so we can take a closer look. You can post the ticket number here so we can update this thread with the outcome.

    Thank you.
     
  10. bestr

    bestr Registered

    Joined:
    Jul 16, 2015
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    New York
    cPanel Access Level:
    Website Owner
    Having similar issue:
    Code:
    ----------------------------------------------------------------------------------------------------
    => Log opened from cPanel Update (upcp) - Slave (284874) at Thu Jul 16 18:27:29 2015
    [20150716.182729]   Detected cron=0 (manual flag passed on command line)
    [20150716.182729]   Running Standardized hooks
    [20150716.182729]   mtime on upcp is 1417576403 (Wed Dec  3 05:13:23 2014)
    ----------------------------------------------------------------------------------------------------
    => Log opened from /usr/local/cpanel/scripts/updatenow (284876) at Thu Jul 16 18:27:30 2015
    [20150716.182730]   Detected version '11.46.3.6' from version file.
    [20150716.182730]   Running version '11.46.3.6' of updatenow.
    [20150716.182730]   Using mirror '74.200.65.162' for host 'httpupdate.cpanel.net'.
    [20150716.182730]   Target version set to '11.50.0.25'
    [20150716.182730]   Target version set to '11.48.4.4'
    [20150716.182730]   Upgrade requested to a version more than 1 LTS away. Will upgrade to next LTS first (11.48.4.4).
    [20150716.182730]   Switching to 11.48.4.4 to determine if we can reach that version without failure.
    [20150716.182730]   Retrieving and staging /cpanelsync/11.48.4.4/cpanel/scripts/updatenow.static.bz2
    [20150716.182730]   Using mirror '74.200.65.162' for host 'httpupdate.cpanel.net'.
    [20150716.182731]   Set permissions on /usr/local/cpanel/scripts/updatenow.static-cpanelsync to 0700
    [20150716.182731]   Become an updatenow.static for version: 11.48.4.4
    => Log closed Thu Jul 16 18:27:31 2015
    ----------------------------------------------------------------------------------------------------
    => Log opened from /usr/local/cpanel/scripts/updatenow.static-cpanelsync (284876) at Thu Jul 16 18:27:32 2015
    [20150716.182732]   Detected version '11.46.3.6' from version file.
    [20150716.182732]   Running version '11.48.4.4' of updatenow.
    [20150716.182732]   Using mirror '74.200.65.162' for host 'httpupdate.cpanel.net'.
    [20150716.182732]   Target version set to '11.50.0.25'
    [20150716.182732]   Target version set to '11.48.4.4'
    [20150716.182732]   Upgrade requested to a version more than 1 LTS away. Will upgrade to next LTS first (11.48.4.4).
    [20150716.182732]   Checking license
    [20150716.182731]   License file check complete
    [20150716.182731]   Checking that the RPM DB is OK...
    [20150716.182731]   glibc-2.12-1.149.el6_6.7.x86_64
    [20150716.182731]   OK: RPM DB is responding to queries
    [20150716.182731]   Testing if rpm_is_working RPM is installed
    [20150716.182731]   package rpm_is_working is not installed
    [20150716.182731]   Testing if it's possible to install a simple RPM
    [20150716.182731]   Preparing...                ##################################################
    [20150716.182731]   rpm_is_working              ##################################################
    [20150716.182731]   Switching to version '11.48.4.4' of updatenow to perform sync.
    [20150716.182732]   checkyum version 22.3
    [20150716.182733]   Loaded plugins: fastestmirror, rhnplugin
    [20150716.182734]   Profilename:my.host.here.com
    [20150716.182734] E This system is not registered with CLN.
    [20150716.182734]   Setting up Install Process
    [20150716.182734]   Loading mirror speeds from cached hostfile
    [20150716.182734]   No package giflib available.
    [20150716.182735]   No package libxslt-devel available.
    [20150716.182735]   No package zsh available.
    [20150716.182735] E Error: Nothing to do
    [20150716.182735] E The system failed to execute yum with the arguments “-y -c /etc/yum.conf install giflib libxslt-devel zsh” because of an error: The “/usr/bin/yum” command (process 284960) reported the “EPERM” (1) error when it ended. : This system is not registered with CLN.
    [20150716.182735] CLN support will be disabled.
    [20150716.182735] Error: Nothing to do
    [20150716.182735]   checkyum version 22.3
    [20150716.182737] E Sysup: Needed system RPMs were not installed: giflib, libxslt-devel, zsh
    [20150716.182737] ***** FATAL: Cannot proceed. Needed system RPMs were not installed.
    [20150716.182737]   The Administrator will be notified to review this output when this script completes
    [20150716.182737] E Detected events which require user notification during updatenow. Will send iContact the log
    => Log closed Thu Jul 16 18:27:37 2015
    [20150716.182737] E Running `/usr/local/cpanel/scripts/updatenow --upcp --log=/var/cpanel/updatelogs/update.1437060449.log` failed, exited with code 18 (signal = 0)
    => Log closed Thu Jul 16 18:27:37 2015
     
  11. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    648
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    Your system package manager (YUM) can not update packages due to the error referenced in this quote. Make sure you have a valid Cloud Linux license and you have not blocked Cloud Linux IP addresses in your firewall.

    Thank you.
     
Loading...

Share This Page