Upgraded to php 5.4.7 via easyapache... Now have SQLite extension issue

Gordon Rankin

Member
Sep 28, 2012
6
0
1
London, United Kingdom, United Kingdom
cPanel Access Level
Root Administrator
I have used Eayapache via cPanel WHM to rebuild Apache with PHP 5.4.7 (upgrading from 5.3.17)

All went well during the rebuild. However my error logs now show the following message :-

[Fri Sep 28 10:55:59 2012] [notice] suEXEC mechanism enabled (wrapper: /usr/local/apache/bin/suexec)
[Fri Sep 28 10:55:59 2012] [notice] Apache/2.2.23 (Unix) mod_ssl/2.2.23 OpenSSL/0.9.8e-fips-rhel5 mod_bwlimited/1.4 mod_fcgid/2.3.6 configured -- resuming normal operations
PHP Warning: PHP Startup: SQLite: Unable to initialize module
Module compiled with module API=20090626
PHP compiled with module API=20100525
These options need to match
in Unknown on line 0
[Fri Sep 28 10:56:04 2012] [warn] [client xxx.xxx.xxx.xxx] (104)Connection reset by peer: mod_fcgid: error reading data from FastCGI server
[Fri Sep 28 10:56:04 2012] [error] [client xxx.xxx.xxx.xxx] Premature end of script headers: index.php
PHP Warning: PHP Startup: SQLite: Unable to initialize module
Module compiled with module API=20090626
PHP compiled with module API=20100525
These options need to match
in Unknown on line 0
[Fri Sep 28 10:56:07 2012] [error] mod_fcgid: process /usr/local/cpanel/cgi-sys/php5(16507) exit(communication error), get unexpected signal 11
And of course my webapp now does not open.

From this I assume that sqlite is still set/compiled to use the previous version of PHP. Therefore I have tried to reinstall sqlite via cpanel but got a PHPIZE failed error message.

I tried reinstalling manually via yum ( yum reinstall sqlite ) but still no joy.

I orignally had the same problem with the memcache extension however simply reinstalling via cpanel recitified this.

Any idea how I can get my site working again?

edit delete flag
 

cPanelTristan

Quality Assurance Analyst
Staff member
Oct 2, 2010
7,607
40
248
somewhere over the rainbow
cPanel Access Level
Root Administrator
If you already have an sqlite.so extension configured in /usr/local/lib/php.ini file, check the extension_dir set there and remove the sqlite.so file in that extension directory. After doing that, recompile using EasyApache again and ensure SQLITE it checked in the PHP Exhaustive Options List.

Also, please ensure you do not have anything configured for sqlite in /var/cpanel/easy/apache/rawopts location in an all_php5 file.

It's possible if you previously compiled in SQLITE using pecl or PEAR that it isn't compatible with the PHP 5.4 you are using.