rvbalraj

Member
Aug 28, 2006
19
0
151
Hi,

We have Redhat EL4 hosting servr on that Cpanel has installed. Apache Server version: "Apache/1.3.39 (Unix)"
is installed on that server. I would to upgrade the Apache version 2. So I have tried to upgrade the apache version via WHM.

But when I upgrade I am getting following messae.

"Cpanel::Easy::ModSec' requires the option 'Cpanel::Easy::Apache::UniqueId' to be on and not "skipped".

... Profile validation failed."

Please help me to resolve this issue.

Thanks and Regards,
Balraj.R.V
 

jayh38

Well-Known Member
Mar 3, 2006
1,213
0
166
When you get to the last dialog box prior to building, you will see the box for "UniqueId". As the message states, UniqueId is needed for modsecurity.
 

rvbalraj

Member
Aug 28, 2006
19
0
151
Thanks.

Hi Jay,

Thanks for your immediate reply. Now I have unchecked the "UniqueId" field and then build it but configuring the apache properly but when its make apache its shows error like

/usr/local/apache/build file is already exists and can't create the directory.