Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SOLVED Upgrading EasyApache 3 to 4 Error

Discussion in 'EasyApache' started by Kathleen Zagala, Dec 2, 2016.

  1. Kathleen Zagala

    Kathleen Zagala Registered

    Joined:
    Dec 2, 2016
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Texas
    cPanel Access Level:
    Reseller Owner
    I have been trying to upgrade and I get this error and don't know what to do to correct it.
    Code:
    Installing profile “/etc/cpanel/ea4/profiles/custom/ea3_state_at_migration-1480729459.json”.
    An error occurred while installing profile “STDOUT output went to filehandle! at /usr/local/cpanel/Cpanel/SafeRun/Object.pm line 360.
            Cpanel::SafeRun::Object::stdout_r(Cpanel::SafeRun::Object=HASH(0x170d8390)) called at /usr/local/cpanel/Cpanel/SafeRun/Object.pm line 380
            Cpanel::SafeRun::Object::stdout(Cpanel::SafeRun::Object=HASH(0x170d8390)) called at /usr/local/cpanel/Cpanel/SafeRun/Object.pm line 345
            Cpanel::SafeRun::Object::_extra_error_args_for_die_if_error(Cpanel::SafeRun::Object=HASH(0x170d8390)) called at /usr/local/cpanel/Cpanel/ChildErrorStringifier.pm line 143
            Cpanel::ChildErrorStringifier::die_if_error(Cpanel::SafeRun::Object=HASH(0x170d8390)) called at /usr/local/cpanel/Cpanel/SafeRun/Object.pm line 339
            Cpanel::SafeRun::Object::new_or_die("Cpanel::SafeRun::Object", "program", "yum", "args", ARRAY(0x170d6930), "stdin", "install ea-php54-php-mcrypt\x{a}install ea-php56-php-common\x{a}insta"..., "stdout", IO::Callback=GLOB(0x170d6990), ...) called at /usr/local/cpanel/Cpanel/PackMan.pm line 380
            Cpanel::PackMan::resolve_multi_op_ns(Cpanel::PackMan=HASH(0x170cb0c0), ARRAY(0x17145760), "ea") called at /scripts/migrate_ea3_to_ea4 line 613
            scripts::migrate_ea3_to_ea4::__ANON__() called at /usr/local/cpanel/3rdparty/perl/522/lib64/perl5/cpanel_lib/Try/Tiny.pm line 80
            eval {...} called at /usr/local/cpanel/3rdparty/perl/522/lib64/perl5/cpanel_lib/Try/Tiny.pm line 71
            Try::Tiny::try(CODE(0x1659f0f0), Try::Tiny::Catch=REF(0x16e06e08)) called at /scripts/migrate_ea3_to_ea4 line 618
            scripts::migrate_ea3_to_ea4::install_profile(HASH(0x166b41c0)) called at /scripts/migrate_ea3_to_ea4 line 940
            scripts::migrate_ea3_to_ea4::script("--run") called at /scripts/migrate_ea3_to_ea4 line 953
    ”.
    
    STDOUT output went to filehandle! at /usr/local/cpanel/Cpanel/SafeRun/Object.pm line 360.
            Cpanel::SafeRun::Object::stdout_r(Cpanel::SafeRun::Object=HASH(0x170d8390)) called at /usr/local/cpanel/Cpanel/SafeRun/Object.pm line 380
            Cpanel::SafeRun::Object::stdout(Cpanel::SafeRun::Object=HASH(0x170d8390)) called at /usr/local/cpanel/Cpanel/SafeRun/Object.pm line 345
            Cpanel::SafeRun::Object::_extra_error_args_for_die_if_error(Cpanel::SafeRun::Object=HASH(0x170d8390)) called at /usr/local/cpanel/Cpanel/ChildErrorStringifier.pm line 143
            Cpanel::ChildErrorStringifier::die_if_error(Cpanel::SafeRun::Object=HASH(0x170d8390)) called at /usr/local/cpanel/Cpanel/SafeRun/Object.pm line 339
            Cpanel::SafeRun::Object::new_or_die("Cpanel::SafeRun::Object", "program", "yum", "args", ARRAY(0x170d6930), "stdin", "install ea-php54-php-mcrypt\x{a}install ea-php56-php-common\x{a}insta"..., "stdout", IO::Callback=GLOB(0x170d6990), ...) called at /usr/local/cpanel/Cpanel/PackMan.pm line 380
            Cpanel::PackMan::resolve_multi_op_ns(Cpanel::PackMan=HASH(0x170cb0c0), ARRAY(0x17145760), "ea") called at /scripts/migrate_ea3_to_ea4 line 613
            scripts::migrate_ea3_to_ea4::__ANON__() called at /usr/local/cpanel/3rdparty/perl/522/lib64/perl5/cpanel_lib/Try/Tiny.pm line 80
            eval {...} called at /usr/local/cpanel/3rdparty/perl/522/lib64/perl5/cpanel_lib/Try/Tiny.pm line 71
            Try::Tiny::try(CODE(0x1659f0f0), Try::Tiny::Catch=REF(0x16e06e08)) called at /scripts/migrate_ea3_to_ea4 line 618
            scripts::migrate_ea3_to_ea4::install_profile(HASH(0x166b41c0)) called at /scripts/migrate_ea3_to_ea4 line 940
            scripts::migrate_ea3_to_ea4::script("--run") called at /scripts/migrate_ea3_to_ea4 line 953
    
    
    Please select from the following options:
    
    1) Revert to EasyApache 3
    2) Abort.
    3) Install the cPanel Default profile.
    
    
    Any help is appecated
     
    #1 Kathleen Zagala, Dec 2, 2016
    Last edited by a moderator: Dec 2, 2016
  2. SysSachin

    SysSachin Well-Known Member

    Joined:
    Aug 23, 2015
    Messages:
    568
    Likes Received:
    40
    Trophy Points:
    28
    Location:
    India
    cPanel Access Level:
    Root Administrator
    Twitter:
  3. Kathleen Zagala

    Kathleen Zagala Registered

    Joined:
    Dec 2, 2016
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Texas
    cPanel Access Level:
    Reseller Owner
    Those are the instructions I used when I got the error.
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    38,658
    Likes Received:
    1,425
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    Could you open a support ticket using the link in my signature so we can take a closer look? You can post the ticket number here so we can update this thread with the outcome.

    Thank you.
     
  5. slinky

    slinky Well-Known Member

    Joined:
    Jul 26, 2007
    Messages:
    71
    Likes Received:
    1
    Trophy Points:
    58
    As an FYI, I've got errors too. Will need to open up a ticket for this among other things as well. Took down the server and had to try to reinstall to get that uninstall message back and then uninstalled EA 4, or at least whatever was upgraded.

    Code:
    No package ea-php54-php-opcache available. at /usr/local/cpanel/Cpanel/PackM                     an.pm line 602.
    
    Complete!
    Installing profile â/etc/cpanel/ea4/profiles/custom/ea3_state_at_migration-14836                     88026.jsonâ
               An error occurred while installing profile â> > > > > > > > > > > > >                      > > > > > > > > > > > > > > > > > > > > > > > > > > > > > No package ea-php54-p                     hp-opcache available. at /usr/local/cpanel/Cpanel/PackMan.pm line 602.
    â
    
    > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > >                      > > No package ea-php54-php-opcache available. at /usr/local/cpanel/Cpanel/PackM                     an.pm line 602.
    
    
     
  6. slinky

    slinky Well-Known Member

    Joined:
    Jul 26, 2007
    Messages:
    71
    Likes Received:
    1
    Trophy Points:
    58
    Thanks to ticket support I was able to solve this problem. It may be unique to each person's server. I was missing a file for some reason and the installer failed. Cpanel was able to get this working.
     
  7. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    38,658
    Likes Received:
    1,425
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    I'm happy to see the issue is now resolved. Thank you for updating us with the outcome.
     
Loading...

Share This Page