johneve

Member
Apr 4, 2007
7
0
151
Hi Folks,

I want to upgrade my glib 2.4.7 to the latest version 2.14. How can I do this? I tried it with building it from source, everything builds and installs fine, but configure still says I have glib 2.4.7. How can I change this?

checking for GLIB - version >= 2.0.0...
*** 'pkg-config --modversion glib-2.0' returned 2.14.0, but GLIB (2.4.7)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files

Thanks!
 

johneve

Member
Apr 4, 2007
7
0
151
Nevermind, allready found a solution

Chances are you've installed glib and set your PATH
correctly, but your LD_LIBRARY_PATH is still wrong. If this
variable is set you should do something like
LD_LIBRARY_PATH=/usr/local/lib:$LD_LIBRARY_PATH
export LD_LIBRARY_PATH
otherwise try (this works for me):
LD_LIBRARY_PATH=/usr/local/lib:/lib:/usr/lib:/usr/X11R6/lib
export LD_LIBRARY_PATH

You want to place the /usr/local/lib (or whereever your glib/gtk
libraries are) *before* the rest of the LD_LIBRARY_PATH so
that the newly installed libraries are detected first ...

This usually solves this stuff for me
--> R