psrsathish

Active Member
Jul 19, 2006
31
0
156
India.
We've WHM 11.38.0 (build 13), Apache2.0, PHP 5.3.25 and MySQL 5.0.96-community in Centos5.9. Now we are in the plan of upgrading mysql to 5.1, Apache to 2.2 and PHP to 5.4. Please let me know whether we can start upgrading these applications straightaway by upgrading mysql to 5.1 followed by apache and php recompilation with the latest version through easyapache. Or do we need to run the upcp in a first place and then we need to continue with upgrading mysql to 5.1 and apache to 2.2 and php to 5.4 through easyapache?

Please let me know the hierarchy from where we need to start from like first upcp, Mysql upgrade and then apache php recompilation OR first Mysql upgrade and then apache php recompilation and at last UPCP? which one we need to follow.
 

triantech

Well-Known Member
Jul 1, 2014
143
1
18
Kochi, India, India
cPanel Access Level
Root Administrator
Hello :)

- Firstly upgrade MySQL, since you will always need to recompile PHP/Apache using EasyApache after MySQL is upgraded.
- Once MySQL is upgraded, recompile PHP/Apache, here you can upgrade Apache and PHP.
- Once the above 2 are complete, run cpanel update ( upcp )

So this will be your hierarchy,

MySQL -> Apache/PHP -> upcp

Hope this helps
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,908
2,217
463
Hello :)

Yes, the previous post is accurate. Note that cPanel version 11.44 requires MySQL version 5.5 or higher.

Thank you.
 

psrsathish

Active Member
Jul 19, 2006
31
0
156
India.
Dear Michael,

As I said the current running version of WHM in my server is WHM 11.38.0 (build 13) so If I run the update(upcp) means then it will be upgraded to 11.44? If not then it will upgrade to which version.

Thank You!
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,908
2,217
463
It depends on which build tier you have selected under "Update Preferences" in WHM. If you would like to upgrade to cPanel version 11.44, ensure you upgrade to MySQL 5.5 first.

Thank you.
 

psrsathish

Active Member
Jul 19, 2006
31
0
156
India.
I've selected Stable in update preference so it be at 11.42.1.25 after the UPCP right?. So I can just upgrade the MySQL to 5.1 In think so.

Thank You