The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Upgrading PHP with buildapache.sea

Discussion in 'EasyApache' started by mpope2, Jun 25, 2002.

  1. mpope2

    mpope2 Well-Known Member

    Joined:
    Feb 8, 2002
    Messages:
    73
    Likes Received:
    0
    Trophy Points:
    6
    Hello,

    I have recently installed the buildapache.sea upgrade and was under the impression that this would also upgrade php to version 4.2.1 . For some reason, it has not upgraded php on my box. (An old version still remains).

    This is very important, for a number of reasons I need to get PHP upgraded to the latest version. Please let me know what I should do.

    I am running red hat 7.1

    Thanks!
     
  2. itf

    itf Well-Known Member

    Joined:
    May 9, 2002
    Messages:
    624
    Likes Received:
    0
    Trophy Points:
    16
    Did you receive any error during installation of Buildapache.sea?

    try to reinstall buildapache.sea.
     
  3. mpope2

    mpope2 Well-Known Member

    Joined:
    Feb 8, 2002
    Messages:
    73
    Likes Received:
    0
    Trophy Points:
    6
    Nope, no errors that I could see. However when you install buildapache.sea a million lines fly by, so I suppose there could have been some errors in there.

    I have installed it multiple times, and it never upgrades the php. I installed it on a different server and the upgrade went through fine.

    Any ideas?
     
  4. itf

    itf Well-Known Member

    Joined:
    May 9, 2002
    Messages:
    624
    Likes Received:
    0
    Trophy Points:
    16
    Are these two lines available in /usr/local/apache/conf/httpd.conf ?

    LoadModule php4_module libexec/libphp4.so

    AddModule mod_php4.c


    restart Apache then check PHP version in WHM -& Sever Status -& Apache Status
     
  5. mpope2

    mpope2 Well-Known Member

    Joined:
    Feb 8, 2002
    Messages:
    73
    Likes Received:
    0
    Trophy Points:
    6
    Yes, both of those lines are in httpd.conf . Restart apache, check PHP version in Apache Status: PHP/(oldversion)

    The old php version is working properly, I just need to upgrade it to the new version.
     
  6. shaun

    shaun Well-Known Member

    Joined:
    Nov 9, 2001
    Messages:
    698
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    San Clemente, Ca
    lsattr /usr/bin/php
    lsattr /usr/local/apache/libexec/libphp4.so

    show me what those return. Also at the very end of the buildapache.sea what does it say. Paste the last 4 or 5 lines for me.
     
  7. mpope2

    mpope2 Well-Known Member

    Joined:
    Feb 8, 2002
    Messages:
    73
    Likes Received:
    0
    Trophy Points:
    6
    lsattr /usr/bin/php
    outputs:
    -------------- /usr/bin/php

    lsattr /usr/local/apache/libexec/libphp4.so
    outputs:
    -------------- /usr/local/apache/libexec/libphp4.so

    I cannot remember what the last 4-5 lines of the buildapache.sea are, and do not want to run that thing right now. I will run it a little later when the load declines and post the results. Please let me know if the above tells you anything! :)

    Thanks for your help!
     
  8. Curious Too

    Curious Too Well-Known Member

    Joined:
    Aug 31, 2001
    Messages:
    427
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    This happened to me before -- I had one machine that had problems with curl so the php installation died when it got to that point -- some sort of failed dependency error.
     
  9. itf

    itf Well-Known Member

    Joined:
    May 9, 2002
    Messages:
    624
    Likes Received:
    0
    Trophy Points:
    16
    it's better to reinstall glibc then reinstall buildapache.sea it should solve the problem
    First query which packages are installed by this command

    rpm -qa | grep 'glibc'

    in a sample RH 7.3 box it shows:
    glibc-2.2.5-34
    glibc-common-2.2.5-34
    glibc-devel-2.2.5-34
    glibc-kernheaders-2.4-7.14

    Download and copy the latest version of above packages in a same folder

    Use this command to reinstall packages and all of its dependencies

    rpm -Uvh --replacepkgs glibc*.rpm
     
  10. mpope2

    mpope2 Well-Known Member

    Joined:
    Feb 8, 2002
    Messages:
    73
    Likes Received:
    0
    Trophy Points:
    6
    I've got:
    glibc-common-2.2.4-24
    glibc-2.2.4-24
    glibc-devel-2.2.4-24

    Should I download these three and reinstall them, or should I try to get the latest version 2.2.5-34 ? This is a redhat 7.1 box. And should I get the glibc-kernheaders-2.4-7.14? It is not currently on the box.

    Thanks!
     
  11. itf

    itf Well-Known Member

    Joined:
    May 9, 2002
    Messages:
    624
    Likes Received:
    0
    Trophy Points:
    16
    [quote:2e179a6c26][i:2e179a6c26]Originally posted by mpope2[/i:2e179a6c26]


    I've got:
    glibc-common-2.2.4-24
    glibc-2.2.4-24
    glibc-devel-2.2.4-24

    Should I download these three and reinstall them, or should I try to get the latest version 2.2.5-34 ? This is a redhat 7.1 box. And should I get the glibc-kernheaders-2.4-7.14? It is not currently on the box.

    Thanks![/quote:2e179a6c26]
    use this command and the result will be those packages that you should get and reinstall for your current Redhat

    rpm -qa | grep 'glibc'

    cpanel automaticly updates glibc to the latest version the latest version for RedHat 7.1 is glibc-2.2.4-24
    no you should not install glibc-kernheaders in RedHat 7.1

    then use this command

    rpm -Uvh --replacepkgs glibc*.rpm
     
  12. mpope2

    mpope2 Well-Known Member

    Joined:
    Feb 8, 2002
    Messages:
    73
    Likes Received:
    0
    Trophy Points:
    6
    Re-installed glibc rpm's, re-installed buildapache.sea , stopped httpd, started httpd,

    php -v: 4.0.4pl1 :(

    Didn't work, so here are the last 4-5 lines of buildapache.sea:


    checking for pam_start in -lpam... yes
    checking for crypt in -lcrypt... (cached) yes
    configure: error: This c-client library is build with SSL support.

    Add --with-imap-ssl&=DIR& to your configure line. Check config.log for details.
    make: *** No targets specified and no makefile found. Stop.
    make: *** No rule to make target `install'. Stop.

    Any ideas?
     
  13. itf

    itf Well-Known Member

    Joined:
    May 9, 2002
    Messages:
    624
    Likes Received:
    0
    Trophy Points:
    16
    [quote:d067af4e42][i:d067af4e42]Originally posted by mpope2[/i:d067af4e42]

    Re-installed glibc rpm's, re-installed buildapache.sea , stopped httpd, started httpd,

    php -v: 4.0.4pl1 :(

    Didn't work, so here are the last 4-5 lines of buildapache.sea:


    checking for pam_start in -lpam... yes
    checking for crypt in -lcrypt... (cached) yes
    configure: error: This c-client library is build with SSL support.

    Add --with-imap-ssl&=DIR& to your configure line. Check config.log for details.
    make: *** No targets specified and no makefile found. Stop.
    make: *** No rule to make target `install'. Stop.

    Any ideas?

    [/quote:d067af4e42]
    Which options did you select during installation 1) Beginner or 2) Advanced?
     
  14. mpope2

    mpope2 Well-Known Member

    Joined:
    Feb 8, 2002
    Messages:
    73
    Likes Received:
    0
    Trophy Points:
    6
    Tried it on beginner twice, did not select any options (there were none to select). Reinstalled the glibc libraries, then did it once in advanced mode, when the menu came up, I did not change any of the options. (There wer some preselected, etc.)

    Thanks!
     
  15. shaun

    shaun Well-Known Member

    Joined:
    Nov 9, 2001
    Messages:
    698
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    San Clemente, Ca
    if you want, send me your logons and ip i will take a lock

    shaun.murphy@ochosting.com
     
  16. mpope2

    mpope2 Well-Known Member

    Joined:
    Feb 8, 2002
    Messages:
    73
    Likes Received:
    0
    Trophy Points:
    6
    Sure, I'll get those sent over a little later today. The server is to busy right now to really do anything on it...

    Thanks!
     
  17. mpope2

    mpope2 Well-Known Member

    Joined:
    Feb 8, 2002
    Messages:
    73
    Likes Received:
    0
    Trophy Points:
    6
    Shaun,

    Let me know if you got my email. ;)

    Since this server is running 4.0.4 , I am thinking a temp fix would be to change php.ini to read &file_uploads = Off& as per the recommendation near the bottom of the page here:
    http://security.e-matters.de/advisories/012002.html

    That will at least make it a little more secure for the time being. Anyone see any problems with this?
     
  18. moronhead

    moronhead Well-Known Member

    Joined:
    Aug 12, 2001
    Messages:
    706
    Likes Received:
    0
    Trophy Points:
    16
    mpope, you could also download and recompile the latest PHP 4.2.1 from www.php.net yourself and that will upgrade you in no time with all the security patches.
     
  19. mpope2

    mpope2 Well-Known Member

    Joined:
    Feb 8, 2002
    Messages:
    73
    Likes Received:
    0
    Trophy Points:
    6
    Yeah, I will try to do that if we cannot figure anything else out, but I'd much rather figure out what is wrong with the server so that I can use the buildapache.sea in the future.
     
  20. shaun

    shaun Well-Known Member

    Joined:
    Nov 9, 2001
    Messages:
    698
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    San Clemente, Ca
    I have figured out what was wrong it looks like it may be a bug in the buildapache.sea. I am investigating this as we speak i will let you know what i find.

    Shaun... Master Private Eye! ;) :p
     
Loading...

Share This Page