Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Upgrading ProFTPD

Discussion in 'General Discussion' started by keyDet79, Jun 6, 2003.

  1. keyDet79

    keyDet79 Well-Known Member

    Joined:
    May 11, 2003
    Messages:
    54
    Likes Received:
    0
    Trophy Points:
    156
    Location:
    Netherlands
    I am trying to upgrade ProFTPD (we need to install it with MySQL modules) and have downloaded the RPM: http://ftp.cpanel.net/pub/sysup/8.0/proftpd/proftpd-1.2.6tls-15_linuxprivs.i386.rpm

    When I try to install it I get the following error:

    ---
    root@srv [/usr/src/proftpd]# rpm -Uvh proftpd-1.2.6tls-15_linuxprivs.i386.rpm
    error: Failed dependencies: libsafe.so.1.3 is needed by proftpd-1.2.6tls-15_linuxprivs
    ---

    I also downloaded http://ftp.cpanel.net/pub/sysup/generic/libsafe/libsafe-1.3-7.i386.rpm - but it gives the same error. The file libsafe.so.1.3 is in my /lib dir though, copying it to /usr/lib and /usr/local/lib did not help either. I have also tried the --force argument, no luck.

    How can I install the latest proftpd with MySQL modules? We need to install ProFTPD with this configuration:

    ./configure --prefix=/usr --sysconfdir=/etc --with-modules=mod_sql:mod_sql_mysql --with-includes=/usr/include/mysql --with-libraries=/usr/lib/mysql

    The server is Redhat 8 btw, Thanks.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
    #1 keyDet79, Jun 6, 2003
    Last edited: Jun 6, 2003
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice