upgrading to 11.25 kills my skins, my languages, my modules and many other things

apogee

Well-Known Member
Nov 8, 2004
122
11
168
Europe
cPanel Access Level
DataCenter Provider
hi,

just upgraded one server to 11.25, I thought even in the advance that would be a wrong decision and it was so, just a nightmare.

I used a very own skin, tooks me 3 weeks to develop it, now its broken, it don't display the buttons for help, home and so on on the startpage, also all icons are postponed to the text but the index site are the least-bad thing. Now also english are the default language on all accounts, very bad, the hotline just begann to ring. If I go depper into cpanel, say I select "change language" I got a loop. Nice :mad: Every subpage, also don't show my custom header, it also don't show everithing which I changed in the original theme (it was based on the x3 default theme).

ok so I thought I can fix this with the branding editor but this editor just say:
PHP:
can't write into /var/cpanel/userhomes/cpanel/.cpanel/nvdata.cache: Permission denied at /usr/local/cpanel/Cpanel/NVData.pm line 60
	Carp::croak('can\'t write into /var/cpanel/userhomes/cpanel/.cpanel/nvdata.ca...') called at /usr/lib/perl5/site_perl/5.6.2/i686-linux/Storable.pm line 76
	Storable::logcroak('can\'t write into /var/cpanel/userhomes/cpanel/.cpanel/nvdata.ca...') called at /usr/lib/perl5/site_perl/5.6.2/i686-linux/Storable.pm line 248
	Storable::_store('CODE(0x8f51e14)', 'HASH(0x8c9a45c)', '/var/cpanel/userhomes/cpanel/.cpanel/nvdata.cache', 1) called at /usr/lib/perl5/site_perl/5.6.2/i686-linux/Storable.pm line 236
	Storable::lock_nstore('HASH(0x8c9a45c)', '/var/cpanel/userhomes/cpanel/.cpanel/nvdata.cache') called at /usr/local/cpanel/Cpanel/NVData.pm line 60
	Cpanel::NVData::_savecache() called at /usr/local/cpanel/Cpanel/NVData.pm line 149
	Cpanel::NVData::_loadcache(1) called at /usr/local/cpanel/Cpanel/NVData.pm line 180
	Cpanel::NVData::_get(undef) called at /usr/local/cpanel/Cpanel/ExpVar.pm line 156
	Cpanel::ExpVar::expvar('$NVDATA{\'x3_litegraphics\'}') called at cpanel line 1412
	main::execiftag('<cpanelif $NVDATA{\'x3_litegraphics\'}>') called at cpanel line 4010
	main::dotag_finished_headers('<cpanelif $NVDATA{\'x3_litegraphics\'}>', 0) called at cpanel line 3835
	main::cpanel_parseblock('<!-- START stdmheader.html -->^J<cpanelif $NVDATA{\'x3_litegraphi...') called at cpanel line 3811
	main::cpanel_parse('GLOB(0xa2ba88c)') called at cpanel line 2126
	main::doinclude('/usr/local/cpanel/base/frontend/x3/branding/stdmheader.html', 0, 1) called at /usr/local/cpanel/Cpanel/Branding.pm line 48
	Cpanel::Branding::Branding_include('stdmheader.html') called at (eval 55) line 1
	eval 'Cpanel::Branding::Branding_include(@{$argref});' called at cpanel line 918
	main::real_exectag('<cpanelif $NVDATA{\'x3_litegraphics\'}>') called at cpanel line 3982
	main::dotag_finished_headers('<cpanelif $NVDATA{\'x3_litegraphics\'}>', 0) called at cpanel line 3835
	main::cpanel_parseblock('<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "...') called at cpanel line 3811
	main::cpanel_parse('GLOB(0x91f8c94)') called at cpanel line 2126
	main::doinclude('/usr/local/cpanel/base/frontend/x3/branding/stdheader.html', 0, 1) called at /usr/local/cpanel/Cpanel/Branding.pm line 48
	Cpanel::Branding::Branding_include('stdheader.html') called at (eval 5) line 1
	eval 'Cpanel::Branding::Branding_include(@{$argref});' called at cpanel line 918
	main::real_exectag('<cpanelif $NVDATA{\'x3_litegraphics\'}>') called at cpanel line 3982
	main::dotag_finished_headers('<cpanelif $NVDATA{\'x3_litegraphics\'}>', 0) called at cpanel line 3835
	main::cpanel_parseblock('<cpanel Branding="include(stdheader.html)">^J^J') called at cpanel line 3811
	main::cpanel_parse('GLOB(0x91f69d0)') called at cpanel line 2126
	main::doinclude('stdbheader.html', 2) called at cpanel line 989
	eval {...} called at cpanel line 989
	main::real_exectag('<cpanelif $NVDATA{\'x3_litegraphics\'}>') called at cpanel line 3982
	main::dotag_finished_headers('<cpanelif $NVDATA{\'x3_litegraphics\'}>', 0) called at cpanel line 3865
	main::cpanel_parseblock('<cpanel setvar="headerimg=../../images/tools.gif">^J<cpanel setva...') called at cpanel line 3811
	main::cpanel_parse('GLOB(0x8f63b50)') called at cpanel line 5289
	main::run_standard_mode() called at cpanel line 383
my language file which my also tooks weeks to made it perfekt is also gone and now I've a very bad langauge with tons of faults in spelling. If I change to my language 30% are still english. I want my langage file / translations back! How can I recover my languages?


I've also dedicated server customers, all of them which made the update have the same bugs, this is a BAD update, I tought it was testet befor but don't looks so.

In the PDF changelog I can't find anything which give me a note why my skin and lang files are fuc****ed up! :mad: :mad:

My own written modules, which tooks me also months, are also all death :mad:

Very bad job cpanel!!! :mad:

How can I rollback to kick this ***** cpanel version out of my servers?
 

cPanelDon

cPanel Quality Assurance Analyst
Staff member
Nov 5, 2008
2,545
12
268
Houston, Texas, U.S.A.
cPanel Access Level
DataCenter Provider
Twitter
hi,

just upgraded one server to 11.25, I thought even in the advance that would be a wrong decision and it was so, just a nightmare.

I used a very own skin, tooks me 3 weeks to develop it, now its broken, it don't display the buttons for help, home and so on on the startpage, also all icons are postponed to the text but the index site are the least-bad thing. Now also english are the default language on all accounts, very bad, the hotline just begann to ring. If I go depper into cpanel, say I select "change language" I got a loop. Nice :mad: Every subpage, also don't show my custom header, it also don't show everithing which I changed in the original theme (it was based on the x3 default theme).

ok so I thought I can fix this with the branding editor but this editor just say:
PHP:
can't write into /var/cpanel/userhomes/cpanel/.cpanel/nvdata.cache: Permission denied at /usr/local/cpanel/Cpanel/NVData.pm line 60
	Carp::croak('can\'t write into /var/cpanel/userhomes/cpanel/.cpanel/nvdata.ca...') called at /usr/lib/perl5/site_perl/5.6.2/i686-linux/Storable.pm line 76
	Storable::logcroak('can\'t write into /var/cpanel/userhomes/cpanel/.cpanel/nvdata.ca...') called at /usr/lib/perl5/site_perl/5.6.2/i686-linux/Storable.pm line 248
	Storable::_store('CODE(0x8f51e14)', 'HASH(0x8c9a45c)', '/var/cpanel/userhomes/cpanel/.cpanel/nvdata.cache', 1) called at /usr/lib/perl5/site_perl/5.6.2/i686-linux/Storable.pm line 236
	Storable::lock_nstore('HASH(0x8c9a45c)', '/var/cpanel/userhomes/cpanel/.cpanel/nvdata.cache') called at /usr/local/cpanel/Cpanel/NVData.pm line 60
	Cpanel::NVData::_savecache() called at /usr/local/cpanel/Cpanel/NVData.pm line 149
	Cpanel::NVData::_loadcache(1) called at /usr/local/cpanel/Cpanel/NVData.pm line 180
	Cpanel::NVData::_get(undef) called at /usr/local/cpanel/Cpanel/ExpVar.pm line 156
	Cpanel::ExpVar::expvar('$NVDATA{\'x3_litegraphics\'}') called at cpanel line 1412
	main::execiftag('<cpanelif $NVDATA{\'x3_litegraphics\'}>') called at cpanel line 4010
	main::dotag_finished_headers('<cpanelif $NVDATA{\'x3_litegraphics\'}>', 0) called at cpanel line 3835
	main::cpanel_parseblock('<!-- START stdmheader.html -->^J<cpanelif $NVDATA{\'x3_litegraphi...') called at cpanel line 3811
	main::cpanel_parse('GLOB(0xa2ba88c)') called at cpanel line 2126
	main::doinclude('/usr/local/cpanel/base/frontend/x3/branding/stdmheader.html', 0, 1) called at /usr/local/cpanel/Cpanel/Branding.pm line 48
	Cpanel::Branding::Branding_include('stdmheader.html') called at (eval 55) line 1
	eval 'Cpanel::Branding::Branding_include(@{$argref});' called at cpanel line 918
	main::real_exectag('<cpanelif $NVDATA{\'x3_litegraphics\'}>') called at cpanel line 3982
	main::dotag_finished_headers('<cpanelif $NVDATA{\'x3_litegraphics\'}>', 0) called at cpanel line 3835
	main::cpanel_parseblock('<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "...') called at cpanel line 3811
	main::cpanel_parse('GLOB(0x91f8c94)') called at cpanel line 2126
	main::doinclude('/usr/local/cpanel/base/frontend/x3/branding/stdheader.html', 0, 1) called at /usr/local/cpanel/Cpanel/Branding.pm line 48
	Cpanel::Branding::Branding_include('stdheader.html') called at (eval 5) line 1
	eval 'Cpanel::Branding::Branding_include(@{$argref});' called at cpanel line 918
	main::real_exectag('<cpanelif $NVDATA{\'x3_litegraphics\'}>') called at cpanel line 3982
	main::dotag_finished_headers('<cpanelif $NVDATA{\'x3_litegraphics\'}>', 0) called at cpanel line 3835
	main::cpanel_parseblock('<cpanel Branding="include(stdheader.html)">^J^J') called at cpanel line 3811
	main::cpanel_parse('GLOB(0x91f69d0)') called at cpanel line 2126
	main::doinclude('stdbheader.html', 2) called at cpanel line 989
	eval {...} called at cpanel line 989
	main::real_exectag('<cpanelif $NVDATA{\'x3_litegraphics\'}>') called at cpanel line 3982
	main::dotag_finished_headers('<cpanelif $NVDATA{\'x3_litegraphics\'}>', 0) called at cpanel line 3865
	main::cpanel_parseblock('<cpanel setvar="headerimg=../../images/tools.gif">^J<cpanel setva...') called at cpanel line 3811
	main::cpanel_parse('GLOB(0x8f63b50)') called at cpanel line 5289
	main::run_standard_mode() called at cpanel line 383
my language file which my also tooks weeks to made it perfekt is also gone and now I've a very bad langauge with tons of faults in spelling. If I change to my language 30% are still english. I want my langage file / translations back! How can I recover my languages?


I've also dedicated server customers, all of them which made the update have the same bugs, this is a BAD update, I tought it was testet befor but don't looks so.

In the PDF changelog I can't find anything which give me a note why my skin and lang files are fuc****ed up! :mad: :mad:

My own written modules, which tooks me also months, are also all death :mad:

Very bad job cpanel!!! :mad:

How can I rollback to kick this ***** cpanel version out of my servers?
To determine a proper resolution I believe this requires thorough inspection and investigation; please submit a support request so that we may fully investigate the reported symptoms and examine the system directly to determine the source of the difficulty. If needed, the link in my forums signature may be used to initiate a ticket submission; when available, please PM me referencing your new ticket ID so I may follow-up internally.
 

ChrisFirth

Active Member
PartnerNOC
Apr 10, 2008
35
0
56
cPanel Access Level
DataCenter Provider
We have a similar issue, although it just seems to be the text on the page that is broken.

As an example, here is a screenshot from the X3 skin (we don't use that skin, so it has not been edited from the default one):



The buttons seem to show the same on our own skin we have as well. I thought the issue was to do with out skin, but I find it odd that its happening on the X3 skin too.

I have tried running /scripts/upcp --force but that didn't seem to resolve the issue either.

Has anyone come across this before?
 

cPanelDon

cPanel Quality Assurance Analyst
Staff member
Nov 5, 2008
2,545
12
268
Houston, Texas, U.S.A.
cPanel Access Level
DataCenter Provider
Twitter
We have a similar issue, although it just seems to be the text on the page that is broken.

As an example, here is a screenshot from the X3 skin (we don't use that skin, so it has not been edited from the default one):



The buttons seem to show the same on our own skin we have as well. I thought the issue was to do with out skin, but I find it odd that its happening on the X3 skin too.

I have tried running /scripts/upcp --force but that didn't seem to resolve the issue either.

Has anyone come across this before?
Please submit a support request so that we can take a take a closer look at the surrounding circumstances and investigate further. When available, please PM me referencing this post and your new ticket ID number so that I may follow-up internally.
 

Gino Viroli

Well-Known Member
Oct 2, 2007
91
10
58
cPanel Access Level
Root Administrator
hi,

just upgraded one server to 11.25, I thought even in the advance that would be a wrong decision and it was so, just a nightmare...

My own written modules, which tooks me also months, are also all death :mad:
Enjoy cPanel!
It' s always the same story. I 'm expreiencing exactly your issues, my branding is just screwed up since the new 11.25 upgrade (it's funny that is called STABLE, I really wonder what STABLE means in cP engineers' brains?!!) They just seem to love to screw up everything, everytime they do aN upgarde, I think it's simple nosense!
Now it will take me a week to fixin the fricking branding!!!!!! :mad::mad::mad:

My dream is a server with a version of cPanel that I won't upgrade for at least 5 years!
And plz don't tell us about security pitfalls!!!
My servers are not the big CIA servers, just need to run websites!!!!!


I have to point out, I tried other control panels like Plesk, and after that horrible experience, I decided to stick my ass to cPanel and suffer (but I can't always suffer in silence). :)
 
Last edited:
Thread starter Similar threads Forum Replies Date
J User Experience 5