The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Upgrading to Apache SpamAssassin 3.3.1

Discussion in 'EasyApache' started by crazyaboutlinux, Dec 30, 2010.

  1. crazyaboutlinux

    crazyaboutlinux Well-Known Member

    Joined:
    Nov 3, 2007
    Messages:
    938
    Likes Received:
    0
    Trophy Points:
    16
    Released version, 3.3.1

    And current version on our server is

    SpamAssassin version 3.2.4
    running on Perl version 5.8.8

    How do i upgraded to Released version, 3.3.1 & how do i keep automatic up to date ??

    I tried following commands to upgrade to latest Released version, 3.3.1 but those are didn't worked
    /scripts/perlinstaller Mail::SpamAssassin
    /scripts/perlinstaller --force Mail::SpamAssassin
    cpan> install Mail::SpamAssassin

    Also tried
    sudo cpan Mail::SpamAssassin

    We are using
    WHM 11.26.20
    CENTOS 5.5 x86_64 standard
     
    #1 crazyaboutlinux, Dec 30, 2010
    Last edited: Dec 30, 2010
  2. cPanelDon

    cPanelDon cPanel Quality Assurance Analyst
    Staff Member

    Joined:
    Nov 5, 2008
    Messages:
    2,557
    Likes Received:
    7
    Trophy Points:
    38
    Location:
    Houston, Texas, U.S.A.
    cPanel Access Level:
    DataCenter Provider
    Twitter:
    re: Upgrading to SpamAssassin 3.3.1

    Please note that the thread you posted in is several years old, and as such the information may not be relevant or applicable to the latest versions of cPanel & WHM.

    SpamAssassin version 3.3.1 is available in cPanel & WHM version 11.28.
     
  3. crazyaboutlinux

    crazyaboutlinux Well-Known Member

    Joined:
    Nov 3, 2007
    Messages:
    938
    Likes Received:
    0
    Trophy Points:
    16
    re: Upgrading to SpamAssassin 3.3.1

    Thanks David Ill take care of it

    can you please let me know how do i upgrade SpamAssassin version from 3.2.4 to latest 3.3.1 from cPanel/WHM ?
     
  4. cPanelDon

    cPanelDon cPanel Quality Assurance Analyst
    Staff Member

    Joined:
    Nov 5, 2008
    Messages:
    2,557
    Likes Received:
    7
    Trophy Points:
    38
    Location:
    Houston, Texas, U.S.A.
    cPanel Access Level:
    DataCenter Provider
    Twitter:
    re: Upgrading to SpamAssassin 3.3.1

    To receive SpamAssassin 3.3.1 you will need to upgrade cPanel & WHM from version 11.26 to version 11.28, which involves switching the cPanel update tier from STABLE to RELEASE or waiting until the STABLE tier receives the new version. The following web site shows the cPanel & WHM version available in each update tier: Latest cPanel/WHM Builds
     
  5. crazyaboutlinux

    crazyaboutlinux Well-Known Member

    Joined:
    Nov 3, 2007
    Messages:
    938
    Likes Received:
    0
    Trophy Points:
    16
    re: Upgrading to SpamAssassin 3.3.1

    Is it possible to keep cPanel/WHM version to 11.26 & upgrade SpamAssassin version to 3.3.1 ??

    Is there any other way to upgrade SpamAssasin version 3.3.1 ??
     
  6. cPanelDon

    cPanelDon cPanel Quality Assurance Analyst
    Staff Member

    Joined:
    Nov 5, 2008
    Messages:
    2,557
    Likes Received:
    7
    Trophy Points:
    38
    Location:
    Houston, Texas, U.S.A.
    cPanel Access Level:
    DataCenter Provider
    Twitter:
    Friendly Moderator Note

    I have moved the posts into a new thread as to prevent confusion with the original 5-year-old topic from 2005 discussing spamd failures.

    Please take care to post using a new thread, rather than reviving ancient topics, when inquiring about recent developments such as a new SpamAssassin release. Your understanding is greatly appreciated.
     
  7. crazyaboutlinux

    crazyaboutlinux Well-Known Member

    Joined:
    Nov 3, 2007
    Messages:
    938
    Likes Received:
    0
    Trophy Points:
    16
    Re: Friendly Moderator Note

    Yes, I can understand & thank you so much for moving this thread into a new thread.

    Is it possible to keep cPanel/WHM version to 11.26 & upgrade SpamAssassin version to 3.3.1 ??

    Is there any other way to upgrade SpamAssasin version 3.3.1 ??
     
  8. cPanelDon

    cPanelDon cPanel Quality Assurance Analyst
    Staff Member

    Joined:
    Nov 5, 2008
    Messages:
    2,557
    Likes Received:
    7
    Trophy Points:
    38
    Location:
    Houston, Texas, U.S.A.
    cPanel Access Level:
    DataCenter Provider
    Twitter:
    Re: Upgrading to SpamAssassin 3.3.1

    I highly recommend to simply wait for STABLE to receive cPanel 11.28 or opt-in to upgrade now by switching from STABLE to RELEASE. It is possible to manually upgrade SpamAssassin via CPAN or by manually installing the Perl module from source, but prematurely upgrading only this component will likely cause a compatibility problem as SpamAssassin 3.3.1 is not supported in cPanel 11.26; however, the latest SpamAssassin release is fully supported as of cPanel & WHM version 11.28, which is why I recommend upgrading or waiting until you determine the time is right to do so.

    Is there a specific concern you have about cPanel & WHM 11.28 that results in not wanting to upgrade?

    I recommend reviewing the following resources to help become more familiar with the new release:
     
    #8 cPanelDon, Jan 1, 2011
    Last edited: Jan 1, 2011
  9. crazyaboutlinux

    crazyaboutlinux Well-Known Member

    Joined:
    Nov 3, 2007
    Messages:
    938
    Likes Received:
    0
    Trophy Points:
    16
    Re: Upgrading to SpamAssassin 3.3.1

    Hi David,

    Thank you for giving details information.

    Is there a specific concern you have about cPanel & WHM 11.28 that results in not wanting to upgrade?

    >> Yes, Many of our clients are use /var/cpanel/maxemails & this files doesn't allowing to use in cPanel & WHM 11.28 that's why i do not want to move

    A Related discussion is going on here 11.28 max emails per domain changed drastically
     
    #9 crazyaboutlinux, Jan 1, 2011
    Last edited: Jan 1, 2011
  10. cPanelDon

    cPanelDon cPanel Quality Assurance Analyst
    Staff Member

    Joined:
    Nov 5, 2008
    Messages:
    2,557
    Likes Received:
    7
    Trophy Points:
    38
    Location:
    Houston, Texas, U.S.A.
    cPanel Access Level:
    DataCenter Provider
    Twitter:
    Re: Upgrading to SpamAssassin 3.3.1

    I'm happy to let you know that the ability to set the max e-mails per hour limit on a per-domain basis is restored and available in the latest maintenance updates for cPanel & WHM 11.28 as a result of the feedback received in the following feature request thread: http://forums.cpanel.net/showthread.php?t=172377

    Please note that the per-domain limits are now set in the individual cPanel users file of each account, as detailed in the aforementioned feature request thread.
     
  11. jayz7

    jayz7 Registered

    Joined:
    Jan 3, 2011
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Re: Upgrading to SpamAssassin 3.3.1

    Is it possible to download an update file for it and use that file to update SpamAssassin like in most antiviruses?
     
  12. cPanelDon

    cPanelDon cPanel Quality Assurance Analyst
    Staff Member

    Joined:
    Nov 5, 2008
    Messages:
    2,557
    Likes Received:
    7
    Trophy Points:
    38
    Location:
    Houston, Texas, U.S.A.
    cPanel Access Level:
    DataCenter Provider
    Twitter:
    Re: Upgrading to SpamAssassin 3.3.1

    I'm not aware of a mechanism like that for SpamAssassin. Please note that SpamAssassin is updated automatically as part of the upgrade to cPanel & WHM 11.28.
     
Loading...

Share This Page