The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Upgrading to mariadb 10

Discussion in 'Database Discussions' started by Nurs1927, Aug 26, 2016.

  1. Nurs1927

    Nurs1927 Active Member

    Joined:
    Nov 22, 2015
    Messages:
    34
    Likes Received:
    2
    Trophy Points:
    8
    Location:
    Spain
    cPanel Access Level:
    Root Administrator
    After upgrading from Mysql 5.5.50-cll to MariaDb 10.0 all works fine, but I have some questions.

    1.- When upgrading finished, the system recommended rebuild with EasyApache 3.
    I did it, and I view this message
    mysql of the system was disabled by 'mysql'

    In the easy Apache options I can view this warnings in red text.
    mysql_of_system.png

    It is necessary to disable this options in new apache rebuild? What mysql options it is necessary select?

    2.- In CPANEL phpMyadmin, appears the 5.5.50-cll of mysql version. Why?
    phpmyadmin_withmariadb.png

    In WHM phpMyAdmin appears the correct version os MariaDB
    mysql_mariadb.png
     
    #1 Nurs1927, Aug 26, 2016
    Last edited: Aug 26, 2016
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,811
    Likes Received:
    671
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello,

    MySQL of the System is not compatible with MySQL 5.6 or later or MariaDB 10 or later. If you install either of these, the system will disable MySQL of the System and use mysqlnd, the MySQL Native Driver, instead. This is documented at:

    PHP Module: MySQL of the System - EasyApache - cPanel Documentation

    I'm unable to reproduce this issue. Does the problem persist after restarting cPanel using "/scripts/restartsrv_cpsrvd"? Can you reproduce it with a new test account?

    Thank you.
     
  3. Nurs1927

    Nurs1927 Active Member

    Joined:
    Nov 22, 2015
    Messages:
    34
    Likes Received:
    2
    Trophy Points:
    8
    Location:
    Spain
    cPanel Access Level:
    Root Administrator
    Thanks. The, only select the third option in my image. True?

    Thank you, but now is SOLVED. It seems that it was cache issue of my browser. Clean the browse cache and solved.
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,811
    Likes Received:
    671
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    You can select the first and third options, as long as you do not enable "MySQL of The System". I'm happy to see the issue is now resolved. Thank you for updating us with the outcome.
     
    Nurs1927 likes this.
  5. Nurs1927

    Nurs1927 Active Member

    Joined:
    Nov 22, 2015
    Messages:
    34
    Likes Received:
    2
    Trophy Points:
    8
    Location:
    Spain
    cPanel Access Level:
    Root Administrator
    Thanks and many thanks for your work with MariaDb update.
    The update It is easy, fast and without problems.
     
    cPanelMichael likes this.
Loading...

Share This Page