Upgrading to PHP 7 - What Are Potential Issues?

quietFinn

Well-Known Member
Feb 4, 2006
1,222
87
178
Finland
cPanel Access Level
Root Administrator
It totally depends on what you are running in your website(s). For example if you have WordPress (latest version) you will not have any issues. But then again, even if you have the latest WordPress you may have WP extensions that do not like PHP7.x.
 
  • Like
Reactions: cPanelLauren

jazee

Well-Known Member
Jan 12, 2015
119
3
68
cPanel Access Level
Root Administrator
Yes, aware of the potential WP plugin issues but less worried related to other stuff since PHP 7 has been out a long time and I use minimal plugins and they are pretty major (not obscure) ones.

So ya, that's why I asked as I figure by polling other users I can get a feel for how common the issues are (non Wordpress) and what they are.

Just to be safe, I'll probably spin up a separate server with separate Cpanel license, transfer the accounts in question, override the DNS by editng my LMHOSTS file temporarily to point the domains to the test server and test that way after doing a test upgrade. Still, would be nice to get an idea what I'm probably in for.
 

Jcats

Well-Known Member
PartnerNOC
May 25, 2011
806
156
168
New Jersey
cPanel Access Level
DataCenter Provider
You could also just take advantage of MultiPHP Manager or if on CloudLinux "Select PHP Version". This instantly changes the PHP version so you could upgrade the account to 7, test it out, if any issues arise, just downgrade back to 5.
 
  • Like
Reactions: cPanelLauren

kdean

Well-Known Member
Oct 19, 2012
367
59
78
Orlando, FL
cPanel Access Level
Root Administrator
Wordpress plugins were mentioned but also take into consideration your theme as well. If it hasn't been updated in a while it may have some issues. For the most part 5.6 to 7.0 didn't present a lot of issues for me as long as plugins/theme were up-to-date. In case you're running a legacy version of wordpress (sometimes it happens if there's un-updated theme incompatibilities), PHP 7.1+ requires Wordpress 4.7 or later. Although it's best to go to at least 7.2 or 7.3 if possible. There's some known issues that aren't immediately obvious with PHP 7.1 that I can't for the life of me recall at the moment. 7.1 only has security support through December so another reason to skip over 7.0/1.
 
Last edited: