The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Upgrading WHM PHP not Apache Server PHP

Discussion in 'EasyApache' started by PuReWebDev, Dec 13, 2006.

  1. PuReWebDev

    PuReWebDev Well-Known Member

    Joined:
    May 18, 2004
    Messages:
    47
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Orlando, FL.
    I'm trying to upgrade the version of php that comes with whm. You use this version anytime you access phpmyadmin from cpanel or whm. I'm not referring to the system wide php that everyone uses on port 80 (e.g. the one you build with easyapache).

    The path to the php.ini that whm uses is /usr/local/cpanel/3rdparty/etc/php.ini
    I don't know what webserver whm is running on ports 2086 & 2087, but i need to make a change to it. Where can i find that config file, or if someone could advise on how to upgrade the version of php in /usr/local/cpanel/3rdparty/etc/php.ini , that would be helpful.

    I've searched up and down here in the forums, but everything references the system wide php.

    thanks,
    PuReWebDev
     
  2. katmai

    katmai Well-Known Member

    Joined:
    Mar 13, 2006
    Messages:
    526
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Brno, Czech Republic
    what do you .. care bout it ? :)
     
  3. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,458
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    /scripts/makecpphp
     
  4. PuReWebDev

    PuReWebDev Well-Known Member

    Joined:
    May 18, 2004
    Messages:
    47
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Orlando, FL.
    thanks, I was able to configure the cpanel php the way I needed it.


    PuReWebDev
     
Loading...

Share This Page