Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

uploading issue upload_max_filesize

Discussion in 'General Discussion' started by crazyaboutlinux, Mar 18, 2011.

  1. crazyaboutlinux

    crazyaboutlinux Well-Known Member

    Joined:
    Nov 3, 2007
    Messages:
    941
    Likes Received:
    0
    Trophy Points:
    66
    one of our client is trying to upload file through word press & getting the following error

    Upload failed! The uploaded file exceeds the upload_max_filesize directive in php.ini
     
  2. LinuxTechie

    LinuxTechie Well-Known Member

    Joined:
    Jan 22, 2011
    Messages:
    502
    Likes Received:
    5
    Trophy Points:
    68
    cPanel Access Level:
    Root Administrator
    Hey,

    You can increase the value of the parameter in php.ini of the server or in custom php.ini of the domain.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. crazyaboutlinux

    crazyaboutlinux Well-Known Member

    Joined:
    Nov 3, 2007
    Messages:
    941
    Likes Received:
    0
    Trophy Points:
    66
    as i don't know how to
     
  4. LinuxTechie

    LinuxTechie Well-Known Member

    Joined:
    Jan 22, 2011
    Messages:
    502
    Likes Received:
    5
    Trophy Points:
    68
    cPanel Access Level:
    Root Administrator
    Hey!

    >> Take a backup of the file php.ini ; The command php --ini will return the location of the php.ini
    >> Open the php.ini using the editor vi and search for the parameter and increase the value.
    >> Restart apache.

    If you wants to increase the parameter only for one domain you can increase it in .htaccess/custom php.ini according to the handler used.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,609
    Likes Received:
    32
    Trophy Points:
    238
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Does the user have their own php.ini file on the account? If so, then open up the php.ini file, look for upload_max_filesize and then increase it. This would be if you are using suPHP, which you can tell in WHM > Apache Configuration > PHP and SuExec Configuration area.

    If you want to change the global setting for the server itself, you can edit /usr/local/lib/php.ini file and edit the size for upload_max_filesize there to have a larger value.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice