The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

uploads not working.

Discussion in 'General Discussion' started by pacificw, Oct 19, 2007.

  1. pacificw

    pacificw Well-Known Member

    Joined:
    Aug 26, 2007
    Messages:
    65
    Likes Received:
    0
    Trophy Points:
    6
    need help again please folks.

    I did my normal updates for cPanel last night and needed to do a bit of modifying to
    my SMF forum (installed through Fantastico) and since upgrading cpanel software, I
    no longer can upload a theme to my forum. I also updated Apache using EA3. I'm
    running both PHP 4 & PHP 5. I'm thinking it's a setting in PHP perhaps that got changed, but I'm not sure.

    Anyone have any ideas? Or should I post this on fantastico's site also?

    side note: I can upload the theme manually through FTP but not through the SMF theme upload area.

    TIA

    fuggi
     
    #1 pacificw, Oct 19, 2007
    Last edited: Oct 19, 2007
  2. mtindor

    mtindor Well-Known Member

    Joined:
    Sep 14, 2004
    Messages:
    1,281
    Likes Received:
    37
    Trophy Points:
    48
    Location:
    inside a catfish
    cPanel Access Level:
    Root Administrator
    You should try an upload, note the specific error that occurs when you try to upload. Then you should immediately check your /usr/local/apache/logs/error_log, /usr/local/apache/logs/suphp.log, and /usr/local/apache/domlogs/<yourdomainname> log files and check for errors relating to that. Then paste those errors.

    My guess is that it is going to be either a directory permission problem (probably not, but could be) or a PHP setting in your php.ini file (if your running PHP4 on that site, the PHP.INI is in /usr/php4/lib/php.ini - if you're running PHP5 on that site, the PHP.INI file is /usr/local/lib/php.ini (or /usr/local/Zend/etc/php.ini if you are running Zend).

    There are settings in PHP.INI that might cause this, such as:
    file_uploads = on (can be on or off)
    upload_max_filesize = 2M (could be your theme is larger than the allowed upload size)

    Mike
     
Loading...

Share This Page