[UPS-177] Service Failures after CentOS 7.7 update

valtechnical

Registered
Oct 4, 2019
1
0
1
Philippines
cPanel Access Level
Website Owner
We followed Workaround 2 and it brought up our critical services. However, cphulkd will not start regardless of whether we edit the configuration for the service or not. Has anyone else found a workaround for this? We get the following when running "systemctl status cphulkd":
● cphulkd.service - cPanel brute force detector services
Loaded: loaded (/etc/systemd/system/cphulkd.service; disabled; vendor preset: disabled)
Drop-In: /etc/systemd/system/cphulkd.service.d
└─override.conf
Active: failed (Result: exit-code) since Wed 2019-09-18 13:21:41 MDT; 50min a
go
Process: 4639 ExecStart=/usr/local/cpanel/scripts/restartsrv_cphulkd --notconf
igured-ok --systemd-service=cphulkd (code=exited, status=255)
CGroup: /system.slice/cphulkd.service
├─ 804 cPhulkd - processo
└─2063 cPhulkd - dbprocesso

Sep 18 13:21:40 vps.example.com systemd[1]: Starting cPanel brute force detector services...
Sep 18 13:21:41 vps.example.com systemd[1]: cphulkd.service: control process exited, code=exited status=255
Sep 18 13:21:41 vps.example.com systemd[1]: Failed to start cPanel brute force detector services.
Sep 18 13:21:41 vps.example.com systemd[1]: Unit cphulkd.service entered failed state.
Sep 18 13:21:41 vps.example.com systemd[1]: cphulkd.service failed.

EDIT: Sorry for this post. It actually is running as a process, it just lists as a failed service.
Hi,

Just want to share my experience troubleshooting this type of problem. I do encounter this errors, after I have upgraded my cpanel_php_fpm, dnsadmin, cphulkd, mailman cpanellogd, cpdavd, and tailwatchd. All of these service has not started after updating my cpanel. I have the same kernel as posted here.

To fix these problem, I did the workaround #2, which i edited the not started service "systemctl edit dnsadmin.service command. Fixing cpanel_php_fpm.service and dnsadmin.service, following the instruction works like a charm. But during the fixing I encounter the problem on cphulkd.service and tailwatchd.service, i wont start the service, after searching the net, and reading the journalctl logs.

I stumble upon checking the process. Even if the cphulkd.service is not started, there still a process running. for cphulkd there are two processes:
529 ? S 0:00 cPhulkd - processor
4867 ? S 0:00 \_ cPhulkd - dbprocessor

So stopping or killing this pid process. then trying to restart "systemctl start cphulkd.service will fix the problem. I did the same again for tailwatchd.service
1 process running for tailwatchd, killing this process the running again "systemctl start tailwatchd.service will fix the problem. This works for me.

Thank you,
valtechnical
 

megajosete10

Registered
Oct 6, 2019
1
0
1
España
cPanel Access Level
Root Administrator
Hello,

I have problems with services
clamd
dnsadmin
lfd

But I don't know how to solve it.
I have a vps server and my provider doesn't know how to do it.
my server with a Centos 7.7 (virtuozzo)

Who should solve this problem?
CenTOS?
cPanel?

I don't know how my solution should be while it is fixed.
Can someone tell me what file to modify and what lines do I have to add?

I would be very grateful
thanks to everyone.
 

dpfchiptuning

Registered
Nov 18, 2019
1
0
1
Italy
cPanel Access Level
Root Administrator
Hello,

I have problems with services
clamd
dnsadmin
lfd

But I don't know how to solve it.
I have a vps server and my provider doesn't know how to do it.
my server with a Centos 7.7 (virtuozzo)

Who should solve this problem?
CenTOS?
cPanel?

I don't know how my solution should be while it is fixed.
Can someone tell me what file to modify and what lines do I have to add?

I would be very grateful
thanks to everyone.
idem my problem
 

jimlongo

Well-Known Member
Mar 20, 2008
253
21
68
I just started noticing this for the last few days (clamd, spamd, dnsadmin), and wrote my provider to ask them to update the kernel on my VPS.
I disabled clamd and asked them to look at it.

CentOS Linux release 7.7.1908 (Core)
2.6.32-042stab128.2


They wrote back and said that the update to 84.0.15 cleared up these issues, which I can confirm are no longer happening for spamd and dnsadmin.

However reinstalled clamd and it immediately started reporting the same failures. They are looking at it again.
 
Last edited: