The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

urgent ftp problem

Discussion in 'General Discussion' started by shann, Apr 19, 2006.

  1. shann

    shann Well-Known Member

    Joined:
    Jul 5, 2002
    Messages:
    366
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Website Owner
    Hi,

    There is a problem with our FTP program, it is connecting to the server and then it is freezing. Any aidea of the problem

    ftp> ls
    200 PORT command successful
    150 Connecting to port 4251
    226-Options: -a
    226 16 matches total
    ftp> pwd
    257 "/" is your current location
    ftp> ls
    200 PORT command successful
    150 Connecting to port 4252
    226-Options: -a
    226 16 matches total
     
  2. shann

    shann Well-Known Member

    Joined:
    Jul 5, 2002
    Messages:
    366
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Website Owner
    update:

    It works with proftp and not with pureftp. Is anything I need to configure?
     
  3. SACHIN

    SACHIN Guest

    I have switched to pro-ftpd,still it is not worked having following error

    220---------- Welcome to Pure-FTPd [TLS] ----------
    220-You are user number 3 of 50 allowed.
    220-Local time is now 11:27. Server port: 21.
    220-IPv6 connections are also welcome on this server.
    220 You will be disconnected after 15 minutes of inactivity
    User (myusername)
    331 User pluse OK. Password required
    Password:
    230-User ***:( has group access to: pluseing
    230 OK. Current restricted directory is /
    ftp> dir
    200 PORT command successful
    150 Connecting to port 5008
    226-Sorry, we were unable to read [.]
    226-Options: -a -l
    226 0 matches total
    ftp> bye
    221-Goodbye. You uploaded 0 and downloaded 0 kbytes.
    221 Logout.
     
  4. webignition

    webignition Well-Known Member

    Joined:
    Jan 22, 2005
    Messages:
    1,880
    Likes Received:
    0
    Trophy Points:
    36
    Have you tried enabling passive mode in your FTP client?
     
  5. nettigritty

    nettigritty Well-Known Member
    PartnerNOC

    Joined:
    Jan 21, 2004
    Messages:
    194
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Bangalore, India
    if you are using a firewall, you will need to open passive ports for FTP or use active mode (disable PASV).
     
  6. Angel78

    Angel78 Well-Known Member

    Joined:
    May 9, 2002
    Messages:
    413
    Likes Received:
    1
    Trophy Points:
    16
    which are passive ports?
     
  7. nettigritty

    nettigritty Well-Known Member
    PartnerNOC

    Joined:
    Jan 21, 2004
    Messages:
    194
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Bangalore, India
    If you use apf:

    # Common ingress (inbound) TCP ports
    IG_TCP_CPORTS="21,22,25,..more.ports.here...,9999,30000_35000"

    30000_35000 is for passive FTP.
     
  8. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    However, if you do need to open up ports for PASV mode, then there's either a bug in your iptables script (e.g. APF) or with your iptables implementation (e.g. typically on a VPS), because the whole point of an SPI firewall is that you do not open up such port ranges, oetherwise you're downgrading your firewall from an SPI one to a static one, which is a reduction in your security protection.
     
Loading...

Share This Page