Urgent Help Needed - Changing Server

ImperialTrader

Well-Known Member
Aug 31, 2014
169
18
68
Egypt
cPanel Access Level
Root Administrator
I'm using AWS and WHM/cPanel
I took a snapshot from my Instance and I deleted the Instance and created a new one from the snapshot.
I have a big problem now where I found that all the hosted websites in my server aren't working!
Note: the server IP remains as it is and also all the website's IP doesn't change
Any urgent help?
 

Attachments

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,296
1,252
313
Houston
This sounds related specifically to the VM Configuration when you recreated the instance.

Do you have NAT routing configuration on the VM?

Is the correct IP address shown as being in use in WHM>>IP Functions>>Show IP Address Usage as well as WHM>>Account Functions>>List Accounts?
 

ImperialTrader

Well-Known Member
Aug 31, 2014
169
18
68
Egypt
cPanel Access Level
Root Administrator
This sounds related specifically to the VM Configuration when you recreated the instance.

Do you have NAT routing configuration on the VM?

Is the correct IP address shown as being in use in WHM>>IP Functions>>Show IP Address Usage as well as WHM>>Account Functions>>List Accounts?
In the beginning, it was showing the old Private IP of the VM (WHM >> Show or Delete Current IP Addresses)
But I added the Static IP in (Basic WebHost Manager Setup), so it reflected automatic and added the new Private IP of the VM in (WHM >> Show or Delete Current IP Addresses)
Also, I found the IP of all the hosted accounts have been changed from the Static IP to the old Private IP, so I changed it manually to the new Static IP (WHM >> Change Site’s IP Address)

Finally, the correct Static IP is now shown as being in use for all the accounts in (WHM>>Show IP Address Usage) as well as (WHM>>List Accounts).
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,296
1,252
313
Houston
You might also want to run the following:

1st:
/scripts/build_cpnat

Then for good measure fully run the IP Address Migration tool at WHM>>IP Functions>>IP Migration Wizard
 

ImperialTrader

Well-Known Member
Aug 31, 2014
169
18
68
Egypt
cPanel Access Level
Root Administrator
You might also want to run the following:

1st:
/scripts/build_cpnat

Then for good measure fully run the IP Address Migration tool at WHM>>IP Functions>>IP Migration Wizard
The command printed the correct new Private IP => Static IP
Also, this command hostname -i is printing the correct new Private IP

Regarding "IP Migration Wizard", I just did it now:
I added the new Private IP and when I navigated to the next step, I saw the list of my accounts, the old IP and the new IP, but I saw the old IP and the new IP are the same :)
But I continued the steps till the end.
 

Attachments

ImperialTrader

Well-Known Member
Aug 31, 2014
169
18
68
Egypt
cPanel Access Level
Root Administrator
The issue has been solved and I would like to share the solution here
We should rebuild the Apache /scripts/rebuildhttpdconf
Then restart Apache service /scripts/restartsrv_httpd