mojamoi

Well-Known Member
Jul 23, 2007
194
0
66
Hiya

someone can help me with the site for php5.2.0
php.net has only php5.2.4.....
pls help me with the package?

Thanks friends:)
 

mojamoi

Well-Known Member
Jul 23, 2007
194
0
66
i fixed it thanks

did some apt-get install flex

it solved

still i need help..
when i make apache file i get error

/usr/local/httpd-2.2.6/srclib/apr/libtool --silent --mode=link gcc -g -O2 -pthread -o libmain.la -static test_char.h config.lo log.lo main.lo vhost.lo util.lo util_script.lo util_md5.lo util_cfgtree.lo util_ebcdic.lo util_time.lo connection.lo listen.lo mpm_common.lo util_charset.lo util_debug.lo util_xml.lo util_filter.lo util_pcre.lo exports.lo scoreboard.lo error_bucket.lo protocol.lo core.lo request.lo provider.lo eoc_bucket.lo core_filters.lo
gawk -f /usr/local/httpd-2.2.6/build/make_var_export.awk `cat export_files` > export_vars.h
/bin/sh: /bin/gawk: No such file or directory
make[2]: *** [export_vars.h] Error 127
make[2]: Leaving directory `/usr/local/httpd-2.2.6/server'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/local/httpd-2.2.6/server'
make: *** [all-recursive] Error 1

what shud i install to recover from the errors?:(
 

mojamoi

Well-Known Member
Jul 23, 2007
194
0
66
how to i change the exec path to shell as well as all directories

Hi

I have installed php

l/php-5.2.0# /usr/local/php2/bin/php -v
PHP 5.2.0 (cli) (built: Oct 17 2007 08:32:17)
Copyright (c) 1997-2006 The PHP Group
Zend Engine v2.2.0, Copyright (c) 1998-2006 Zend Technologies
node3:/usr/local/php-5.2.0# php -v
-bash: php: command not found
node3:/usr/local/php-5.2.0#

but i
 

Todd Mitchell

Well-Known Member
Staff member
Nov 13, 2006
301
1
243
Houston, TX
I recommend submitting a ticket on this.

There appears to be a problem with the php build on the server. If you submit a ticket, please post the ticket number here and I will look at it for you since it is a rather urgent issue.
 

mojamoi

Well-Known Member
Jul 23, 2007
194
0
66
how do i submit a ticket sir?

Also upon second configuration of apache i get the error below
# ./configure --prefix=/usr/local/apache2 --enable-so
checking for chosen layout... Apache
checking for working mkdir -p... yes
checking build system type... x86_64-unknown-linux-gnu
checking host system type... x86_64-unknown-linux-gnu
checking target system type... x86_64-unknown-linux-gnu

Configuring Apache Portable Runtime library ...

checking for APR... yes
setting CC to "gcc"
setting CPP to "gcc -E"
setting CFLAGS to " -g -O2 -pthread"
setting CPPFLAGS to " -DLINUX=2 -D_REENTRANT -D_GNU_SOURCE"
setting LDFLAGS to " "

Configuring Apache Portable Runtime Utility library...

checking for APR-util... reconfig
configure: error: Cannot use an external APR with the bundled APR-util