The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

urgent help required!!!

Discussion in 'General Discussion' started by akt, Jun 29, 2004.

  1. akt

    akt Registered

    Joined:
    Jun 29, 2004
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    india
    Hello Friends,
    I had a receint cpanel and whm upgradation on my server. as i
    upgraded to stable 9.4 every seemed to be allright unless i checked the
    service status on the server it showed me
    exim (packageeximisnotinstalled)
    failed

    and
    ftpd failed


    i had some clue of what shall be done to resolve the problem...

    now i tried :
    /scripts/reseteximtodefaults
    /scripts/exim3
    /scripts/exim4

    and all such kind......
    when i run the /scripts/exim4 i recive an error like:
    ============================================================================
    =====
    Resetting Exim to cPanel Defaults and Installing the Latest Version
    `/etc/localdomains' -> `/etc/localdomains.eximreset'
    `/etc/aliases' -> `/etc/aliases.eximreset'
    `/etc/secondarymx' -> `/etc/secondarymx.eximreset'
    --18:08:20--
    http://diff.cpanel.net/exim-cpanel7.2.0/s7/exim-4.34-60_cpanel_stmpcontrol_a
    ntivirus_rewrite_mailman2_mailtrap_exiscan.i386.rpm
    =>
    `exim-4.34-60_cpanel_stmpcontrol_antivirus_rewrite_mailman2_mailtrap_exiscan
    .i386.rpm'
    Resolving diff.cpanel.net... done.
    Connecting to diff.cpanel.net[216.118.116.104]:80... connected.
    HTTP request sent, awaiting response... 200 OK
    Length: 1,246,302 [application/x-rpm]

    100%[====================================>] 1,246,302 1.63M/s ETA
    00:00

    18:08:21 (1.63 MB/s) -
    `exim-4.34-60_cpanel_stmpcontrol_antivirus_rewrite_mailman2_mailtrap_exiscan
    .i386.rpm' saved [1246302/1246302]

    Preparing... ###########################################
    [100%]
    `/etc/localdomains.eximreset' -> `/etc/localdomains'
    `/etc/aliases.eximreset' -> `/etc/aliases'
    `/etc/secondarymx.eximreset' -> `/etc/secondarymx'
    Building exim.conf...<b>Configuration file has an invalid syntax. Please
    try again.</b>
    Done
    exim: no process killed
    exim: no process killed
    Waiting for exim to restart..............finished.



    exim has failed, please contact the sysadmin.
    chmod: getting attributes of `/var/spool/exim/db/*': No such file or
    directory
    Install Complete
    ============================================================================
    =======
    when i run /scripts/exim3
    ============================================================================
    ========
    root@server [~]# /scripts/exim3
    Resetting Exim to cPanel Defaults and Installing the Latest Version
    `/etc/localdomains' -> `/etc/localdomains.eximreset'
    error: package exim is not installed
    Retrieving
    http://diff.cpanel.net/exim-cpanel6.5.0/exim-3.36-155_cpanel_stmpcontrol_ant
    ivirus_rewrite.i386.rpm
    /scripts/exim3: line 30: 3506 Segmentation fault (core dumped)
    rpm -Uvh
    http://diff.cpanel.net/exim-cpanel6.5.0/exim-3.36-155_cpanel_stmpcontrol_ant
    ivirus_rewrite.i386.rpm
    `/etc/localdomains.eximreset' -> `/etc/localdomains'
    Waiting for exim to restart..............finished.



    exim has failed, please contact the sysadmin.
    Reset Complete
    ============================================================================
    ========
    and same as above when for other commands....

    I am really into a big problem here as i am just not able to see any way out
    of this:
    nothing seems to be working to resolve the problem......

    i tried /scripts/upcp and then running the above commands but all in wane...
    i see that there is no exim in the /etc directory
    i see that there is no such service like exim.... when i try to restart the
    exim service it shows me exim no such service error

    i am really not understanding what shall be done
    is there any one who can get me out of this.....
    any help will be apprichated HELP!!!!!!
    Thanking You all........


    :)
     
  2. BenThomas

    BenThomas Well-Known Member

    Joined:
    Feb 12, 2004
    Messages:
    598
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Houston, Texas USA
    cPanel Access Level:
    Root Administrator
    If you haven't already then please submit a support ticket. That is the quickest way to get such an issue resolved.

    It would also be helpful if you provided some general information about your server such as the OS distribution.

    Have you also tried starting exim from the command line so that you can see what the specific error message is? That could be very helpful.

    Is there anything in exim's panic log as well? This may also give a strong indication of what the problem is.
     
  3. akt

    akt Registered

    Joined:
    Jun 29, 2004
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    india
    hello
    my operating system is linux(freeBsD) rh8 which i upgraded to..also i checked for the panic log and all files related the
    exim but the file were not existing ie panic etc...
    i executed the command for exim upgradation on command prompt...but the same error again...(as above)
    i have tried all i think....
    can You tell me what are all the commands which i should try on command prompt..(shell)
    Please help me out of this....

    -=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
    one more thing !!
    WHM service status i see some services failed i.e bind, apache, proftpd, and exim but when i restart the services they are restarted succesfully but shows as failed in service status...
    Why So.....

    thank You for the quick responce ...


    atuls..:)
     
    #3 akt, Jul 1, 2004
    Last edited: Jul 1, 2004
Loading...

Share This Page