The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

URGENT: mail() function broken in cpanel 7.

Discussion in 'E-mail Discussions' started by cyon, Jun 26, 2003.

  1. cyon

    cyon Well-Known Member
    PartnerNOC

    Joined:
    Jan 15, 2003
    Messages:
    320
    Likes Received:
    0
    Trophy Points:
    16
    hello,

    after upgrading my cpanel to version 7.0.5 E19 I can't send mails with the PHP mail() function. The formmail.pl skript isn't working anymore too.

    I downgraded cpanel to 6.4.2-S75, but the problem does still exists.

    have anyone some suggestions?

    hope this will be fixed soon, I have 300 clients on this server and they are spamming me with this problem.

    thx, dave.

    cPanel.net Support Ticket Number:
     
  2. ciphervendor

    ciphervendor Well-Known Member

    Joined:
    Aug 26, 2002
    Messages:
    1,052
    Likes Received:
    0
    Trophy Points:
    36
    Maybe try restarting Exim as a first step:

    service exim restart

    Next try tailing the Exim log for errors and while doing that attempt to send mail from a form or php script. You should find your answer in that Exim log.

    cPanel.net Support Ticket Number:
     
  3. cyon

    cyon Well-Known Member
    PartnerNOC

    Joined:
    Jan 15, 2003
    Messages:
    320
    Likes Received:
    0
    Trophy Points:
    16
    my logs didn't contain any entries about the mails I sent with mail().

    but I solved the problem by running /scripts/exim3

    now version 3 instead of 4 is installed and mail() works now.

    The problem is not really fixed but bypassed, and that works for me at the moment.

    greetz, dave.

    cPanel.net Support Ticket Number:
     
    #3 cyon, Jun 26, 2003
    Last edited: Jun 26, 2003
  4. rmj

    rmj Member

    Joined:
    Feb 20, 2003
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    1
    i'm having the same issue, i dont want to downgrade exim though, there has to be a solution to this.

    any ideas anyone? im sure more than a few of us are having this issue

    cPanel.net Support Ticket Number:
     
  5. cikul

    cikul Well-Known Member

    Joined:
    Nov 15, 2002
    Messages:
    49
    Likes Received:
    0
    Trophy Points:
    6
    i have some problem. but after i run /scripts/newexim the problem fixed :)

    cPanel.net Support Ticket Number:
     
  6. sexy_guy

    sexy_guy Well-Known Member

    Joined:
    Mar 19, 2003
    Messages:
    848
    Likes Received:
    0
    Trophy Points:
    16
    I cannot send mail from Moderbill. :confused:

    cPanel.net Support Ticket Number:
     
  7. rmj

    rmj Member

    Joined:
    Feb 20, 2003
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    1
    cikul if you looked at that script you'd see that its installing old v3.X of exim

    not a solution for v4

    just thought you should know though.

    cPanel.net Support Ticket Number:
     
  8. sexy_guy

    sexy_guy Well-Known Member

    Joined:
    Mar 19, 2003
    Messages:
    848
    Likes Received:
    0
    Trophy Points:
    16
    ** BUMP **

    This needs fixing, we cannot send mail from Modernbill. Whats up with this and when is it going to be fixed?

    cPanel.net Support Ticket Number:
     
  9. sexy_guy

    sexy_guy Well-Known Member

    Joined:
    Mar 19, 2003
    Messages:
    848
    Likes Received:
    0
    Trophy Points:
    16
    There is a major problem with the mail function in E19 and our private forums and those of our users are all affected. Has anyone submitted a TT on this yet?

    cPanel.net Support Ticket Number:
     
  10. cyon

    cyon Well-Known Member
    PartnerNOC

    Joined:
    Jan 15, 2003
    Messages:
    320
    Likes Received:
    0
    Trophy Points:
    16
    I've opened a TT, but no reply yet...

    cPanel.net Support Ticket Number:
     
  11. kcdworks

    kcdworks Well-Known Member

    Joined:
    Jul 28, 2002
    Messages:
    186
    Likes Received:
    0
    Trophy Points:
    16
    The only thing that has fixed this for us is to make sure that Apache is compiled with the Raise FD_SETSIZE option and then to restart httpd every time it happens (about twice a day), or to downgrade to Exim 3.

    The restarting Apache solution only temporarily fixes the problem. Downgrading to Exim 3 fixed us, but really shouldn't be the answer.

    cPanel.net Support Ticket Number:
     
  12. Tom Pyles

    Tom Pyles Well-Known Member

    Joined:
    Apr 26, 2002
    Messages:
    254
    Likes Received:
    0
    Trophy Points:
    16
    Sexy_guy,
    We too had problems with mail from Modernbill. I ended up going back to Exim3 and it now works. Not a solution, but a temporary fix for you until this stuff gets resolved.

    cPanel.net Support Ticket Number:
     
  13. cyon

    cyon Well-Known Member
    PartnerNOC

    Joined:
    Jan 15, 2003
    Messages:
    320
    Likes Received:
    0
    Trophy Points:
    16
    I think we have to wait till the programmers fix that bug and downgrade to exim3 till then..

    cPanel.net Support Ticket Number:
     
  14. Godcore

    Godcore Active Member

    Joined:
    Dec 31, 2002
    Messages:
    39
    Likes Received:
    0
    Trophy Points:
    6
    we're having the same problem. PHP scripts that used to work are now broken.

    cPanel.net Support Ticket Number:
     
  15. Godcore

    Godcore Active Member

    Joined:
    Dec 31, 2002
    Messages:
    39
    Likes Received:
    0
    Trophy Points:
    6
    We had the option "prevent the user nobody from sending mail to external domains" selected. Unchecked the box and all is good.

    cPanel.net Support Ticket Number:
     
  16. cyon

    cyon Well-Known Member
    PartnerNOC

    Joined:
    Jan 15, 2003
    Messages:
    320
    Likes Received:
    0
    Trophy Points:
    16
    I, and I think a lot of other users, have it unchecked - and it's not working although.

    cPanel.net Support Ticket Number: <- that suckz! :)
     
  17. sexy_guy

    sexy_guy Well-Known Member

    Joined:
    Mar 19, 2003
    Messages:
    848
    Likes Received:
    0
    Trophy Points:
    16
    Negative. This is not the issue. Thats a separate issue from what we are talking about in here.

    cPanel.net Support Ticket Number:
     
  18. Christleo

    Christleo Well-Known Member

    Joined:
    Mar 13, 2003
    Messages:
    64
    Likes Received:
    0
    Trophy Points:
    6
    I have met the problem both i type exim3 or newexim or exim4, my mail() just dont work.. that is very serious and my forum will have big problem that user can't receive any web send mail..

    cPanel.net Support Ticket Number:
     
  19. tAzMaNiAc

    tAzMaNiAc Well-Known Member

    Joined:
    Feb 16, 2003
    Messages:
    559
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Sachse, TX
    All,

    I don't have any problems with PHP Mail and I'm at 7.1.0-R20.. My forum customers are happily speeding off in the sunset.....
    At least I think so. I am going to do a few tests now just to be sure.


    Sexy_Guy,

    The WHM option (from Tweak Settings)
    ========
    Prevent the user 'nobody' from sending out mail to remote addresses (php and cgi scripts generally run as nobody if you are not using phpsuexec and suexec respectively.)
    ========

    DOES have to do partially with the PHP Mail option. PHP Mail IS a PHP script, so.. it does send mail out as nobody if no phpsuexec is on! I don't have phpsuexec installed, therefore this will affect my PHP Mail stuff if I had it CHECKED.

    Brenden

    cPanel.net Support Ticket Number:
     
  20. Christleo

    Christleo Well-Known Member

    Joined:
    Mar 13, 2003
    Messages:
    64
    Likes Received:
    0
    Trophy Points:
    6
    Prevent the user 'nobody' from sending out mail to remote addresses (php and cgi scripts generally run as nobody if you are not using phpsuexec and suexec respectively.)

    I have it uncheck... i have phpsuexec if i'm not wrong.. let me try both if it work.. (tick/untick) i mean..

    cPanel.net Support Ticket Number:
     
Loading...

Share This Page