Urgent -- Mail problem

Mini

Well-Known Member
Mar 4, 2005
98
0
156
Hello,

For some reason my daily backups don't seem to have saved mail for the past few weeks.

Today I had my server reloaded (because I stupidly accidentally deleted the /bin directory) on a new hard drive and had my old hard drive retained and connected to the server.

So when I use the restore tool to restore from the backup, a lot of the mail is missing.

However that mail is clearly there in my 'cur' directory on the old hard drive, and when I copy it in, it doesn't show (I'm using IMAP and I'm using webmail to check). But before when I did this, it worked (another time, some time ago, when I had to reload mail in due to a power failure at the DC which wrecked the hardware)

Furthermore the format of the old 'mail' directory seems to be different to the new one. For example, there are now actual folders apart from 'cur', which I created to organised my email. But in the old 'mail' directory it's just all in one 'cur' folder, and no actual folders in the storing of them.

Obviously there has been a change in format or version or something with the old cpanel and new cpanel version (which is RELEASE), or something else...

Could someone please help me out as to how I could restore my mail? I'm quite desperate here :(

Any help would truly be appreciated.

Thanks
 

Mini

Well-Known Member
Mar 4, 2005
98
0
156
Hi,

I think the problem is that the old server had mail in 'mbox' form and the new server has it in 'maildir' form... How would I change the settings back to 'mbox' for the new server?

Thanks
 
Thread starter Similar threads Forum Replies Date
sniperscope Email 7
S Email 5
S Email 5
C Email 5
A Email 19