The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

URGENT mail problem

Discussion in 'E-mail Discussions' started by ballisticsa, Sep 29, 2004.

  1. ballisticsa

    ballisticsa Member

    Joined:
    Sep 21, 2004
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Hi All,

    I have searched this entire forum for a solution to the problem that I am having, but it's been to no avail. I really hope that somebody here can help me out as this is dead urgent!

    I have a new dedicated server running RH and cpanel/whm. If I send an email to a local mail account the email goes through without a hitch. However if I send an email to remote address, it goes into the delivery queue and only gets delivered after about two hours. That is obviuosly a concern, but it's only a small part of the problem. If I send an email to any of my clients using my ISP mail account, they don't get delivered. They don't bouce back or anything like that, they just seem to disappear into thin air. I have asked a few different people to test this and exact same thing happens for them.

    I updated cpanel to the lastest release today in the hopes that this would correct it, but it never did.

    This is obviuosly a major problem for me, considering that none of my clients have email. I would greatly appreciate it if somebody has a solution to this.

    Thanks in advance!
     
  2. anup123

    anup123 Well-Known Member

    Joined:
    Mar 29, 2004
    Messages:
    897
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    This Planet
    Just take a look at exim_mainlog

    Do a tail -f /var/log/exim_mainlog

    And then watch what happens when you send a mail in different combinations as you mentioned.

    If you have integrated RBL's then also take a look at exim_rejectlog/exim_paniclog files...

    Anup
     
  3. ballisticsa

    ballisticsa Member

    Joined:
    Sep 21, 2004
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Hi Anup,

    Please bear with me, as I'm pretty new to this. I have taken a look at my exim log, I never sent any mails though, as the log seems keeps trying to send these mails that seem to have 'disappeared into thin air'. Or am I mistaken and it does always update every second or so?

    Anyways, this is what the log is showing and it's the same for evey one of them:

    2004-09-29 11:09:11 1CCg4s-0008RH-Vu malware acl condition: clamd: unable to connect to UNIX socket /var/run/clamav/clamd (No such file or directory)
    2004-09-29 11:09:11 1CCg4s-0008RH-Vu H=(LASERT.COM) [64.178.63.69] F=<> temporarily rejected after DATA
    2004-09-29 11:09:16 SMTP command timeout on TLS connection from (nrbl09.nrb.be) [217.117.32.72]
    2004-09-29 11:09:18 1CCg4z-0008RI-Um malware acl condition: clamd: unable to connect to UNIX socket /var/run/clamav/clamd (No such file or directory)
    2004-09-29 11:09:18 1CCg4z-0008RI-Um H=(zao2.tuad.ac.jp) [202.251.184.38] F=<> temporarily rejected after DATA

    Does this give you any idea what the problem is, and if so, please tell me there is a solution to it!

    Thanks again.
     
  4. ballisticsa

    ballisticsa Member

    Joined:
    Sep 21, 2004
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Anybody else? I really need to fix this ASAP :confused:
     
  5. Ramsy

    Ramsy Guest

    yep take a look @ your /etc/clamd.conf

    LocalSocket /var/clamd
    FixStaleSocket

    should be in there somewhere

    make sure the socketpath matches the one in ur exim.conf

    av_scanner = clamd:/var/clamd
    allow_domain_literals
     
  6. ballisticsa

    ballisticsa Member

    Joined:
    Sep 21, 2004
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Hi Ramsy,

    Thanks a bunch for the response!

    Okay, I had a look and I don't have a clamd.conf file, however, I do have a clamav.conf file. In that file, the following line is commented out:

    LocalSocket /var/run/clamav/clamd.sock (It says nothing about FixStaleSocket either?)

    Right at the top of the exim.conf file it has the following:

    av_scanner = clamd:/var/run/clamav/clamd (it says nothing about domain literals either?)

    I take it this is the problem, but how do I go about fixing it? Another thing I noticed is that in the clamav dir there is no .sock file...

    Any help would be greatly appreciated!
     
  7. anup123

    anup123 Well-Known Member

    Joined:
    Mar 29, 2004
    Messages:
    897
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    This Planet
    Hi.

    OK. To begin with, clamd has been installed with clamconnector or Anand's installer (http://cpanelappz.com). The log file shows that it's an issue with improper setup with clamd. So i would suggest following:

    If you have installed using the Add On Modules clamavconnector in WHM , uninstall it.

    Get your exim running first without clamd .... ie, comment out the av_scanner stuff in Exim configuration editor and so also any thing that appears in the middle ACL box which is concerne with clamd.

    Then we come to the next step....
    But first confirm that after removing clamd you have your exim working
    Sorry for the delay

    [EDIT] As you remove clamd stuff and restart exim keep a watch on exim_paniclog file. It should not show any error logged there... if it does, take care of those errors.
    [/EDIT]
    Anup
     
    #7 anup123, Sep 29, 2004
    Last edited: Sep 29, 2004
  8. ballisticsa

    ballisticsa Member

    Joined:
    Sep 21, 2004
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Hi guys,

    Thanks to all of you that helped me out, it appears that I have finally got this working.

    Anup, I did try commenting out all the clam stuff in the exim.conf, but all that happened then is that I started getting the sophie errors.

    The only option I had left was to uninstall exim and then reinstall it. Once I did that, the mail started to work perfectly.

    Thanks again for all the help.
     
  9. EMS

    EMS BANNED

    Joined:
    May 10, 2003
    Messages:
    250
    Likes Received:
    0
    Trophy Points:
    0
    Hi All,

    I just had this problem.

    Suddenly, no mail could be received and all smtp sending attempts were coming back with the dreaded "temporary local problem" error.

    I tailed the exim log and got this on every message...

    unable to connect to UNIX socket /var/run/clamav/clamd (No such file or directory)
    And the on about temporarily rejected after data.

    I reinstalled exim + clam using the installer at cpanelappz.com but this had no effect.

    I have now removed the line from the config...

    av_scanner = clamd:/var/run/clamav/clamd

    Mail is now working fine but im concerned that mail is not being checked for vruses.

    Any ideas ?
     
  10. anup123

    anup123 Well-Known Member

    Joined:
    Mar 29, 2004
    Messages:
    897
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    This Planet
    Check your clamav.conf file for socket path. It should be the same as the one that you have for av_scanner in WHM Exim configuration editor

    /etc/rc.d/init.d/exim restart

    Does it show clamd shutting down and coming back up again?

    Anup
     
  11. EMS

    EMS BANNED

    Joined:
    May 10, 2003
    Messages:
    250
    Likes Received:
    0
    Trophy Points:
    0
    Interestingly,

    localsocket now appears to be set to var/clamd

    I had someone install some security software yesterday - I didnt mention clam though.

    Restarting exim does restart clamav
     
  12. anup123

    anup123 Well-Known Member

    Joined:
    Mar 29, 2004
    Messages:
    897
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    This Planet
    someone installed clamavconnector (from Add On Modules) too on your already installed clam
    just set the socket path in /etc/clamav.conf

    to

    /var/run/clamav/clamd

    and restart exim and see if that sorts out the issue.
    Also ensure that you uncomment the av_scanner line in WHM.

    If the above doesn't work, just mv clamav.conf clamav.conf.orig
    Download clamupdater from http://cpanelappz.com
    Install it and see if everything turns out fine.

    [EDIT]
    Also in Add On Modules, just check that you don't have the clamavconnector checked as Install and Keep Updated
    [/EDIT]

    Anup
     
    #12 anup123, Sep 30, 2004
    Last edited: Sep 30, 2004
  13. EMS

    EMS BANNED

    Joined:
    May 10, 2003
    Messages:
    250
    Likes Received:
    0
    Trophy Points:
    0
    Made the changes and tailed the log

    Now getting..

    unable to connect to UNIX socket /var/run/clamav/clamd (connection refused)

    Am I right in thinking that I need to make sure the port specified in the clamav.conf is included in the firewall config ? (just installed apf) and all should be ok ?

    Edit... getting sophie errors

    malware acl condition: unable to connect to sophie UNIX socket (/var/run/sophie). errno=2
     
    #13 EMS, Sep 30, 2004
    Last edited: Sep 30, 2004
  14. mgdoyle

    mgdoyle Member
    PartnerNOC

    Joined:
    Apr 24, 2004
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    1
    sophie error for me too

    I uninstalled clam some time ago, and a recent cpanel update changed my exim.conf file to reinstate it. I was getting errors in exim_mainlog that it couldn't connect to the clamav socket. So I commented out the line in exim.conf list clamav as my av, and now I am getting exim_mainlog errors that

    malware acl condition: unable to connect to sophie UNIX socket (/var/run/sophie). errno=13

    Any ideas?
     
Loading...

Share This Page