Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

URGENT: mysql error...sudden

Discussion in 'General Discussion' started by Secret Agent, May 23, 2005.

  1. Secret Agent

    Secret Agent Guest

    WARNING : [2] mysql_connect(): Client does not support authentication protocol requested by server; consider upgrading MySQL client

    WARNING : [2] mysql_connect(): Client does not support authentication protocol requested by server; consider upgrading MySQL client
    /home/abc/public_html/inc/mysql.inc.php (line 61)

    WARNING : [512] Connection attempt failed
    [1251] - Client does not support authentication protocol requested by server; consider upgrading MySQL client
    /home/abc/public_html/inc/mysql.inc.php (line 45)

    WARNING : [2] session_start(): Cannot send session cache limiter - headers already sent (output started at /home/vns/public_html/inc/debug.inc.php:144)
    /home/abc/public_html/inc/certificate.inc.php (line 137)

    WARNING : [2] mysql_query(): supplied argument is not a valid MySQL-Link resource
    /home/abc/public_html/inc/mysql.inc.php (line 153)

    WARNING : [512] SELECT failed in SQL: SELECT * FROM superusers WHERE db LIKE "abc_mydomain"

    [1251] - Client does not support authentication protocol requested by server; consider upgrading MySQL client
    /home/abc/public_html/inc/mysql.inc.php (line 45)

    Database "abc_mydomain" not exist

    I got this out of the blue suddenly. MySQL restarts fine as well. I'm on 4.1.11
     
  2. BenThomas

    BenThomas Well-Known Member

    Joined:
    Feb 12, 2004
    Messages:
    598
    Likes Received:
    0
    Trophy Points:
    166
    Location:
    Houston, Texas USA
    cPanel Access Level:
    Root Administrator
    Rebuild mod_php using easyapache. Make sure you select "Use system mysql" in the options.
     
  3. Secret Agent

    Secret Agent Guest

    Thank you Ben. I actually ended up fixing this by removing the database user and re-adding it.

    Thanks
     
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice